Problem with automatic switch

I've just bought an automatic switch, 2 input, 1 output to allow two different computers to use a Lexmark Optra R+ through the Parallel port.

Problem is, one computer prints correctly, it is a laptop, the other, desktop, prints a page with PJL stuff on, and then correctly prints the document. I have at one point managed to get the switch to work with the desktop machine, but the laptop wasn't plugged into it as it wasn't available.

I know it is the switch, as I have tried with a manual selector switch and both machines print correctly.

Anyone any suggestions? The switch is a cheap thing that I found in BYTE, a computer superstore in the UK. It has some jumpers, but there is no mention of what the do, it also has a power supply, but says that this is optional, and it does appear to work (almost) without it.

Both computers are set up for ECP printer ports, maybe that is the problem? It maybe that the Lexmark is trying to communicate back with the machine, I haven't a clue.

I would assume it is something simple to fix, or it is a fault with the switch.

Thanks for any help.
JoncAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

magigrafCommented:
Jonc...

You just said it in your question, while this might not be the direct cause.

Your Lexmark printer is a Bidirectional printer, and these even expensive automatic switches do not offer the Bidirectional support. (at least from one of our Biggest cable supplier in Canada)

You could always try the other Options; as EPP or RAW and test if you still experience the same problem.

Let me know how did it go.
Regards
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jrhelgesonCommented:
Have you tried switching the connections each computer is using?
--If the desktop was using port a, try port b.

This is the "Basic" header of a PCL print job, what line of PCL code does your printer start printing at?

%-12345X@PJL SET PAGEPROTECT=OFF
@PJL SET RESOLUTION=300
@PJL ENTER LANGUAGE=PCL

does it continue printing PCL code after the third line listed here?

This is generally caused by a switchbox that is slow to switch inputs, and in switching will cause a single character to get dropped from the header --Thus causing the printer not to understand the entire command, leaving the printer to assume that  it is unformatted text, and printing it.

Does the PCL code [that prints] change a little with each print job? --Is it dropping diferent characters when it switches, or always the same one character?

Magigraf's answer may be the one,

Let me know...

Joel.
0
jrhelgesonCommented:
BTW, The toner cartridges for that printer are EXPENSIVE AS HELL!!!  I cannot believe it!
300 bucks for 14k pages?

Shees-
0
OWASP: Avoiding Hacker Tricks

Learn to build secure applications from the mindset of the hacker and avoid being exploited.

JoncAuthor Commented:
I'm gonna try setting to EPP, but as I won't have access to the machines until the weekend again I don't know if it will work. If not, I can upgrade my switch for an extra 25 pounds (double the price).


The header that gets printed is similar to

%-12345X@PJL SET PAGEPROTECT=OFF
@PJL SET RESOLUTION=300
@PJL ENTER LANGUAGE=PCL

but as I haven't got a printout with me, I can't confirm it is identical, but this looks pretty similar.

With regards to the price of the toners, I know how expensive they are, though they are a bit cheaper in the UK, I think we are about 150 pounds which would be about $270 or something around that. Anyway, the printer is a very nice unit, I'd buy another one.

I've also been told that a file "drvwppqt.vxd" may be interfering which appears to have something to do with the parallel port zip drive.

Anway, I'll try and look at the machine as soon as possible and tell you what happens.
0
jrhelgesonCommented:
Do you have a parallel port zip drive attached to that PC?
if so,
Have you tried it w/o having the Zip drive attached?

jr
0
JoncAuthor Commented:
It isn't connected at the moment, probably hasn't been connected for about 5 months. It printer has never been put through the zip drive, always a direct connection to the port or through a manual parallel switch. The manual parallel switch doesn't appear to have a problem with the lexmark though. I think that at the moment, the manual switch selects between a colour printer and the Lexmark for the desktop machine, though it may have been disconnected for the moment, I can't remember what I left it like, I had to ensure the printers could be used before I left is some way or another.
0
JoncAuthor Commented:
I don't know if anyone is still reading this, but you wanted to know what happened. Well, I tried to solve it yesterday, even went and bought a bi-directional switch thinking that that may be the problem.

Anyway I have a really weird thing going on with the machine now.
The laptop prints fine, the desktop prints rubbish, (PJL stuff then load of garbled characters), but if when I print, I change the printer driver to another one installed (identical except for name), then it prints perfectly. If I then make this other printer the default printer, and try and print again, it fails, but if I then manually select the initial printer again, all is fine. Obviously this is not a solution to the problem, so I've set it back up through the serial port again until I find a solution.

I changed the desktop to EPP, but the laptop doesn't have an option in the BIOS setup to change from ECP and I couldn't find the manual.

Anyway, thought someone may be interested in what happened.

Oh, and occasionally during my testing of it, instead of getting the usual %-12345X@PJL JOB

I would get

@PJJL JOB
@PJJL SEET RRESOLUUTTION == 6000
@PPJJL RRDDYMSGG  DDISPLLAAY  == ""MMicrosofft Wwoorrd -- DDocummeent2"
@PJLL EENTER LAANGUUAAGE == PPossttsscript

MM


Anyway, I'll get back intouch with Lexmark to see if they can help solve it.
0
jrhelgesonCommented:
Why was magigraf's answer accepted?
Do we have this problem reslolved?
0
magigrafCommented:
Joel,

Unfortunately EE autograde questions being inactive for 2 weeks, which I don't find it fair neither for me nor for the other experts..
What can we do else than suggest to EE and wait??
Regards
0
jrhelgesonCommented:
Autograde -Can- be a good thing
0
JoncAuthor Commented:
It wasn't autograded, but i thought as it had been open for so long, I should probably grade it before EE get on to me to do it, though I don't know if they would have.


I'll open a new one back up for solutions if you want, what you reckon, I still need help, the problem with it is, I don't have access to the printer very often, it is 50 miles away, and I don't go to the office very often, only when I have time.

I may not be going back for 2/3 weeks now, and trying to get someone in that office to perform anything is not a good idea.


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.