NT Backup not working using AT-- permissions problem

For some reason, NT backup isn't working with the AT command. I have the backup hardware set up on my PDC, and it'll back up that information fine. When I schedule a ackup of my BDC I get the message "You do not have permission to access portions of. Please see the owner or administrator to get permission.".
The BDC has a share set up for backup (let's call it backup$). The schedule service is runnign as the Administrator. backup operators, domain admins, and (finally) the Administrator have full control of the backup share. I know that the administrator has permission on every directory, every file on that server. Permission is still being denied.

I checked the advanced user rights and made sure the Administrator had 'em all. Still no good. Am I missing something?

The backup$ is mapped to i: on the PDC. The batch file launched every night is NTBACKUP BACKUP  i: /V /R /B /D "FULL BACKUP" /L "C:\LOG\LOG.TXT" /hc:on

the AT command was
at 20:00 /interactive /every:m,t,w,th,f,s cmd /c c:\bkupfull.bat

Any ideas?
danterrillAsked:
Who is Participating?
 
kuk010998Connect With a Mentor Commented:
Tip: schedule a cmd w/ option 'interactive' - once it fires, you have a command prompt reacting quite like your scheduled job would. Anything you start from here works under the schedule account. In general, buying BackupExec or ArcServe is far better than AT-scheduling NTBACKUP. Last thought: Run the schedule service under the system account, then let the batch file first establish the needed network connections (net use X: \\computer\share password /USER:domain\user), call ntbackup then delete the connections. Drive letters used in the batch MUST NOT exist or be mapped by the logged-in user, but the account used is independent. Lastly, you could set up the share used for backup as a null share on the BDC gravely compromising security.
0
 
biyiadeniranCommented:
What kind of access do users access the directory remotely have:
try setting it like this:
NETWORK  Read
if it doesn't work try full control.

Good luck
0
 
danterrillAuthor Commented:
The Administrator has full control of the share and the directories. I know I can read all of the files. I know that the schedule service is running as the administrator, but it's almost as if the backup itself is running as another user.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
heikoLeiter CB-EntwicklungCommented:
user that want to backup entire system has to act as part of system. this is a enhanced right !!
make sure that only users who has rigths to
- act as part of operating system
- system backup operator
can invoke such commands.
0
 
danterrillAuthor Commented:
I'm afraid that account already has those rights. Any other ideas?
0
 
heikoLeiter CB-EntwicklungCommented:
do you know about object you dont can access too?
I think this can be profiles stored on this BDC because of this will be created with rigths to owner only. Administratros AND system are excluded from this.
On my machines i take over owner ship of all to admin and give full control to user and read access to admin and system.

hope this helps
0
 
danterrillAuthor Commented:
The schedule account, which is  doing the backup, is the owner of the directories, and has full permissions on them. Guess I'll have to call Microsoft today.
0
 
kuk010998Commented:
Sorry this was intended as comment.
0
 
danterrillAuthor Commented:
Thanks, KUK -- that did it!
0
 
kuk010998Commented:
Heh - have had enough probs with scheduled jobs. Scheduling VB apps - scheduling Access - etc. I even have a machine running two copies of the scheduler under different accounts! The one thing I have had no luck with is sending an email from a scheduled Access code. That scheduled cmd trick I offered is invaluable - e.g. to set up an exchange profile for the system account!
0
 
danterrillAuthor Commented:
How did you set up the multiple schedule account?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.