[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Rogue IDE CD-ROM drive

Posted on 1998-02-04
18
Medium Priority
?
363 Views
Last Modified: 2013-12-16
I have an ASUS P55T2P4 mother board, Two Hard drives, and a 24X creative cd-rom.  After installing the bus master software (Intel 82371SB PCI Bus Master IDE Controllers) I keep getting a Creative Labs IDE CD-ROM drive entry in my device manager, hard disk controller lines.  Before I used the standard IDE controllers but needed the performance of the intel.  So why does device manager continue to load the IDE CD-ROM drive when the CD-ROM is slaved to the secondary port all by itself??
How do I tell windows not to try and load this??
I have removed it several times then when i reboot windows prompts me that it has located new hardware and is installing software for it.

p.s. my motherboard recognizes the CD-ROM during boot up with no problems.
 
0
Comment
Question by:mission
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 3
  • +4
18 Comments
 

Author Comment

by:mission
ID: 1754217
Edited text of question
0
 
LVL 1

Expert Comment

by:ngpudding
ID: 1754218
Sometimes I do also faced this kind of problems when fixing up Win95 for my friends. But my last resort will be disabling the device in the current hardware configuration by unchecking the box after you bring up the Properties page of a certain device.
By doing that, you are actually reclaiming resources back and those resources will not be loaded again unless check the box again.
0
 

Author Comment

by:mission
ID: 1754219
is there a way to remove it permanently from device manager?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 9

Expert Comment

by:rmarotta
ID: 1754220
Do you have a sound card with an IDE port built on it?
Also, when you said "the CD-ROM is slaved to the secondary port all by itself."  Do you mean that it is on the secondary port by itself (it should then be master) or is it slaved to one of the hard drives there?
regards,
Ralph

0
 

Author Comment

by:mission
ID: 1754221
yes my soundcard does have an ide connection on it.

the cd-rom is set to slave mode on the secondary ide.
all documentation with the cd-rom drive informed me to slave the cd-rom to the secondary port even if that is the only device on it.  I tried to make it a master any way and the machine does not boot at all.  I called creative about this and they said that is the way they are designed.  I dont understand this but info from other sources repeat what creative said.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1754222
mission,
A couple more questions...  Does your soundcard software give you an option to disble the IDE port?  Are you using the windows busmaster driver or one that came with the motherboard?  Is the CD-Rom operating in PIO mode?

0
 

Author Comment

by:mission
ID: 1754223
first: the software for the sound card does not have an option to disable the port nor is there any jumper settings.
second: I used the windows one at first then decided to use the intel busmaster one that came with the motherboard.
third: yes the cd-rom is operationg in mode 4, at least that is what the boot up prompts tell me.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1754224
Hi Mission!

Thanks for the invitation Magigraf!

Mission, I have read through all of the posts, which sound card do you have? Not trying to be redundant here, but with some of the cards you can make some ini file changes or a registry entry to prevent this.

By the way, if the current answer doesn't satisfy you, reject it, as it will encourage other techs to come in.

Dennis
0
 

Author Comment

by:mission
ID: 1754225
it is a sound blaster awe32 pnp
0
 
LVL 7

Expert Comment

by:busuka
ID: 1754226
Mission, I'm going to suggest you to make thing, that worked for
me personally as well as for many people over the 'net:
(maybe this is not best way, and I can't completely describe why
it worked, but my guess that Creative PnP cards uses some resource
that start to pop up conflict after Intel BM driver install).

- Boot to Win95 Safe Mode. To do it: right after message 'Starting
  Win95' press F8. Select Safe Mode from menu
- Enter Device Manager (right-click on My Computer -> Properties
  -> Device Manager tab)
- select BM driver in HDD Controllers section and remove it
  (I assume you can remove ONLY 82371SB PIIX driver, I remember I
  was failed to remove Primary dual fifo and Secondary dual fifo
  drivers).
- if you have Standard IDE/ESDI controller, remove it as well
- shut down
- open the case and PHYSICALLY pull out SB PnP card.
- boot Win95. let it detect 82371SB controller and install drivers
 NOW: It's VERY important that you don't have ANY hardware conflicts
 on this step. Once you got stabilly working system with BM
 drivers you can proceed further.
- shut down and insert SB AWE card back
- let it be detected (and updated in PnP database) by Win95.
- install sound drivers if needed (usually not)
 Now here can be couple ways:
1) IDE port on SB card detected. You can enter Device Manager and
  uncheck it from Original Configuration.
2) My home: Win95 silently installed Standard IDE/ESDI controller
  with no conflicts whatsoever.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1754227
This is a problem I have experienced several times before, and it is frustrating that you cannot disable the stupid IDE driver on the sound card, (Who on earth uses those anymore anyway?)  I have tried but have not been successful.
I have just given it up and left it.

0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1754228
Unfortunately the AWE 32 was the B****** child of the group, which is what prompted Creative Labs to issue the AWE 64 gold. There are 4 different AWE 32 cards, CT3900, CT3600, CT 3620 and CT 3671. Some of these are software configurable to shut down the IDE bus, while some are hardware configurable and the later one's are not configurable at all and require shutting the bus off in windows. If it will help you, I'll cut and paste together all of the issues with your model of card, however you'll need to give me the model number from the card itself so I can do so.
Dennis
0
 
LVL 5

Expert Comment

by:tstaddon
ID: 1754229
You may also need to specify in your BIOS that you do not have a hard disk on the same channel as the CDROM.

Is this a real problem, or just an annoyance, and if so why?

Why not disable the 2nd IDE port in the computer and use the CDROM drive through the sound card?



0
 
LVL 7

Expert Comment

by:busuka
ID: 1754230
This will greatly affect perfomance of CD-ROM (AFAIK).
0
 
LVL 7

Expert Comment

by:busuka
ID: 1754231
mission, how about feedback.
BTW, if my suggestion worked, you can consider it as answer.
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 400 total points
ID: 1754232
Busuka, why would Mission accept your comment as the answer when it doesn't resolve the issue. The bus mastering controller appears to be installed correctly. Mission only asked why the Sound Blaster IDE controller was present and how to get rid of it.

Mission, simply put, click Start, Settings, Control Panel, then click the System Icon and then click Device Manager. Next go down to the Sound Blaster IDE controller area and expand it by clicking the "+" sign. Highlight the entry and click Properties. Next, uncheck the box next to "Original Configuration (current)" click OK and then close all boxes and restart the system. You may incur a couple of restarts, but the device will eventually not be shown. Make sure that there is no calling line in either Config.sys or Autoexec.bat for this device.
0
 
LVL 7

Expert Comment

by:busuka
ID: 1754233
That is why I'm asked for feedback and not rushed on Answer button.
0
 

Author Comment

by:mission
ID: 1754234
Thanx to all for the info but I just went in and connected the cd-rom to the sound card anyways.  Of course that did not work either but I reinstalled windows under that configuration and it appears to work so for.  sorry if i have not returned any comments but i have been inoperative this week.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
A small collection of useful tips and tricks for Windows 10 users that I decided to write as a result of recent questions that were asked and answered at Experts Exchange. Two short video tutorials included. Enjoy..
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question