Solved

Canon BJ-200e LPT1 port problem on Win95

Posted on 1998-02-04
28
553 Views
Last Modified: 2013-12-03
I have a black and white BJ-200E canon printer that I got couple of years back with win 3.1 drivers. Now I have a win95 toshiba laptop that I want to use it with. I have downloaded latest canon drivers and installed it on my pc.
However, I keep getting
'cannot access port LPT1: port might already be in use by another program, try quitting other programs and try again'.
There is no other printer using that device. There are no IRQ conflicts. Any help would be appreciated.
I should add that when I connect the printer to LPT1 and boot the pc, the error light comes on on the printer as the laptop boots up.
0
Comment
Question by:brahatswing
  • 10
  • 7
  • 3
  • +8
28 Comments
 
LVL 32

Expert Comment

by:jhance
Comment Utility
Are you 100% sure that no other program is using the LPT1: port?  There are many things that might be grabbing it like a SCSI driver for a parallel-port SCSI type device, a scanner driver, another printer driver (like ones from HP) that is polling the port all the time.
0
 

Author Comment

by:brahatswing
Comment Utility
I am not 100% sure if no other device is using the LPT port. I do have a iomega jaz drive connected through a SCSI PCMCIA card (Adaptec). I looked at the IRQs and there was no conflict. But is there a way I could find out if it or anyother device is trying to grab the LPT1 port? I know it is not another printer since I've deleted all other printers from the printer menu.
-s
0
 
LVL 2

Expert Comment

by:terminus
Comment Utility
One thing to try too would be using another centronics cable to link to your printer : if the error lights come up at boot-time, maybe your cable is simply bad. Best solution would be to borrow one from a friend or colleague ...
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
Go into your printer setup, spool settings and click "Disable bi-directional printing for this printer"
0
 

Expert Comment

by:agust
Comment Utility
try changing the ecp port and update your lpt.vxd driver.
this can correct your problem.
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
Did my recommendation work? Or are you still interested in resolving this issue?
0
 

Author Comment

by:brahatswing
Comment Utility
The 'disable birectional printing' button was greyed out (inactive) in the spool settings. Hence I cannot do that.

Regarding the recommendation to 'change the ECP port', I changed the driver settings for LPT1 to be 'ECP Printer port' from 'printer port'. But no luck.

Thanks for the recommendations, but I am still stuck
-s

0
 
LVL 9

Expert Comment

by:cymbolic
Comment Utility
have you tried any other printer on that port?
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
What is the exact date & version of the drivers that you are using?
0
 

Author Comment

by:brahatswing
Comment Utility
1) I haven't tried another printer on that port - since I use the network printer for other uses and not the LPT port. That is a good idea, I'll try to find another printer to hook this up to.

2) I am using the latest driver for BJ200-E from Canon (downloaded from the web site): Version 3.93E for wind95. I use the printer with my win3.1 PC and it works perfectly well. It is just the laptop (with win95) that is creating problems. So I don't think it is the cable either.

The fact that the error light comes on when I boot my laptop, might have something to do with this.

-S
0
 

Expert Comment

by:agust
Comment Utility
does the cannon driver has a file that can disable the bidirectional option?
if it has try disable this option.

0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
If the error light comes on when you turn it on.  That is a major red flag there.

Can you print to any printers using this laptop? (using the lpt port).  Have you used this same cable?  Try another printer, and print to it from this laptop using the same cable.  If you duplicate the problem, replace the cable.
If problem still persists, we can focus on the lapotp.
0
 
LVL 2

Expert Comment

by:theTerabyte
Comment Utility
ok, this is all getting jumbled up, so let's straghten this all out:

1. Make sure teh cable works
      try it on a different computer

2. make sure the printer works
      try a different cable and computer

3. make sure the laptop works.
      try a different cable and printer with the laptop.

the key to solving this problem is getting it organized, then we can assess credit and who solved it.
0
 

Author Comment

by:brahatswing
Comment Utility
To Terabyte's comment:

1) I tried the printer and the cable on my 486 win3.1 PC and it WORKED.

2) I think this case is taken care of in above case since it's clear both the cable and the printer work.

3) I haven't done this yet. I will try a diff. printer on LPT of my laptop and report back.

thanks
-s
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 1

Expert Comment

by:jsouth
Comment Utility
Check your BIOS or CMOS and make sure that your parellel ports are setup right. I think it should say Auto or 378 under the parellel ports.
0
 

Expert Comment

by:agust
Comment Utility
ok. try checking the cannon dip switch it can be emulating an epson lq printer.
Or change the dip switch to this emulation and try it.
good luck....
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
jsouth,

IS THAT AN ANSWER?
0
 

Author Comment

by:brahatswing
Comment Utility
My parallel ports seem to be setup right:
it says
Input/Output Range  0378-037A
Interrupt Request   07

I haven't yet been able to lay my hands on another printer yet, so I haven't tried that yet.
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
When you do, let us know.
0
 
LVL 1

Expert Comment

by:jct052097
Comment Utility
you've changed the driver of the printer port to ECP,
but in Win95.
You have to change to ECP in the bios setup.
Then, when you restart Win95, it will automatically detect
the new ECP port.

Try another think:
Boot in MS-DOS mode, and try to print anything, for example:
DIR >lpt1
if it works in MS-DOS mode, the only problem is to
change the setup type printer port, or to reinstall Win95.

0
 

Author Comment

by:brahatswing
Comment Utility
I loaded the drivers on a different laptap running win95 and the printer worked just fine. So it is my port settings that are an issue.
I want to go back to a comment by jhance earlier that asked about another device hogging the port: I replied to that, and I should emphasize that I DO have an Iomega Jazz drive with a scsi PCMCIA card as an attachement to my laptop. The other working laptop did not have the Jazz driver installed.
Is that a  problem? Should I be asking Iomega? thanks
-s
0
 
LVL 1

Expert Comment

by:adamgg
Comment Utility
Try testing the printer through DOS,
just goto "C:\"
type "edit autoexec.bat"
from there goto the file menu and hit the print button, does this work?

* Don't use a DOS shell!  Click the start button then "Restart the computer in MS-DOS mode"
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
Have you solved your problem yet?
Have you successfully been able to get your laptop to print?

What is currently happening, haven't heard from you for a few days.

jr
0
 

Author Comment

by:brahatswing
Comment Utility
I tried 'adamgg's suggestion and it WORKED! So the printing works from the DOS mode. What do I need to do to make it work from windows? Does this confirm that my IOMEGA driver is messing things up with the parallel port?
thanks
-s
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
Boot Your computer in safe mode (hold down shift key after turning power on, until you see the windows 95 banner).
Try printing from safe mode, and see if it works.

Have you tried a different printer cable?
0
 

Expert Comment

by:chcheah
Comment Utility
Enter the BIOS setup
Change the printer port in the BIOS setup to
ADDRESS : 378H, IRQ 7
MODE : STANDARD ( sometimes denoted as SPP or NORMAL )
Save the new BIOS settings and reboot the machine.

Certain Canon old models do not work when printer port
is set to anything else but Standard mode.
0
 
LVL 15

Expert Comment

by:jrhelgeson
Comment Utility
Are you still interested in resolving this issue?
0
 
LVL 15

Accepted Solution

by:
jrhelgeson earned 300 total points
Comment Utility
Is your problem resolved?
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Word / Printing 8 48
GPS save in database 19 36
pic in header needs to resize on mobile 4 54
hp deskjet 1055 8 18
Introduction HTML checkboxes provide the perfect way for a web developer to receive client input when the client's options might be none, one or many.  But the PHP code for processing the checkboxes can be confusing at first.  What if a checkbox is…
Printers have changed substantially in the last 30 or so years, not just in technical capabilities but in cost and usage as well.  Printers were originally used for interfacing with the operator, not necessarily for printing copy or pictures. In …
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
The viewer will learn how to count occurrences of each item in an array.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now