Solved

disk write error / pri master HDD error

Posted on 1998-02-07
18
355 Views
Last Modified: 2010-05-18
When I turn on the computer I receive disk write error message (unable to write to disk in drive c). When I continue as prompted I have a Pri Master HDD Error. However, if I run setup I can start W95 in safe mode. Then if I shut down windows and choose restart it will run in normal mode. If I boot from a floppy I can write to drive c (eg. mkdir). I also reinstalled W95 (no change). My question is: what is causing the problem and how do fix it so that when I turn on the computer it will start in normal mode every time?
0
Comment
Question by:bryan_kay
  • 6
  • 5
  • 2
  • +4
18 Comments
 
LVL 3

Expert Comment

by:q2guo
Comment Utility
Most probably, there is a loose connection between
your HardDrive and the motherboard.  Open you computer
and tighten the connection.  The other possibility is
your hard drive will die soon.  Did you run scandisk?
Were there bad sectors?  I suggest you to backup all you
file on this hard drive...

Terry
0
 

Author Comment

by:bryan_kay
Comment Utility
I've run scandisk; no bad sectors (new HD). I've opened the computer; all connections are tight. Suggestions??
0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
First: how big your Pri Mater HDD ? Enter BIOS setup and post what
mode your HDD set (Normal, Large, LBA, CHS, ...).
0
 

Author Comment

by:bryan_kay
Comment Utility
Att'n busuka: mode Large. size 3.2 GB.
0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
Ah-HA !!! This is a cause: Large. On stabile systems it prevents
Win95 from using long filename (LFN). In less stabile systems it
may lead to not-load or bad load of Win95 (your case). I'm afraid
that you need to force type of your HDD to LBA and reformat it
(it's imperative to reformat it to prevent future loss of data).

Hope this helps.
0
 

Author Comment

by:bryan_kay
Comment Utility
busuka- In Setup I have always had LBA turned on. How would I force my HDD to LBA?  B.
0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
Oops. I thought you said by 'Att'n busuka: mode Large. size 3.2 GB'
that your HD in Large mode. Anyway, right after POST (Power-On Self
Test) BIOS outputs on screen table with your hardware. This is
table jumps before message 'Starting Win95' and usually pass very
quickly, so it's quite hard to catch it, but try and post how BIOS
really detected this HDD.
BTW, usually in BIOS setup -> Configuration (or Normal config) you
have type of your HDD Auto. I meant change it to LBA.
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Bryan: This should resolve your problem if it doesn't, let me know. If it does, I would appreciate your rejecting the proposed answer so that I may post the following as the answer.
=================

First, if your using the retail version of Windows 95, v.950 or 950a, it doesn't matter whether LBA is active or not, you will not be able to access the entire 3.2g as one drive. Retail versions of Windows 95 have a drive size limitation.

PSS ID Number: Q127851
Article last modified on 07-15-1996
 
5.x 6.00 6.20 6.21 6.22 95
 
WINDOWS
 

kbtool kbnetwork kbinterop kbsetup
 
---------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Windows 95
 - Microsoft MS-DOS operating system versions 5.x, 6.0, 6.2, 6.21,
   6.22
---------------------------------------------------------------------
 
SUMMARY
=======
 
Microsoft Windows NT supports the creation of primary partitions and
logical (physical) drives of up to 4 gigabytes (GB) using the File
Allocation Table (FAT) file system, but Windows 95 and Microsoft MS-DOS do
not support these drives. The limit for drives using the FAT file system in
Windows 95 and MS-DOS is 2 GB.
 
MORE INFORMATION
================
 
Both MS-DOS and Windows 95 use a 16-bit FAT for logical drives larger than
15 megabytes (MB). The maximum number of clusters for a 16-bit FAT drive
is 64K, or 65,536 bytes (where 1K = 1024 bytes). In addition, the maximum
cluster size in MS-DOS and Windows 95 is 32K, or 32,768 bytes. Therefore,
the maximum logical drive size in MS-DOS and Windows 95 is calculated as
follows:
 
   32K x 64K = 2048 MB = 2 GB
 
Windows NT uses a 64K maximum cluster size on 16-bit FAT drives. The
maximum logical drive size in Windows NT is calculated as follows:
 
   64K x 64K = 4096 MB = 4 GB
 
NOTE: On a FAT drive, space is allocated by clusters. That is, a file that
is smaller than the drive's cluster size will still be allocated one full
cluster, thus wasting the additional space in the cluster. Similarly, a
file that is large enough to fill 3-1/2 clusters will be allocated four
full clusters. Using a smaller cluster size will typically result in less
wasted space on the drive.
 
The cluster size for a FAT drive is determined when the drive is formatted
and varies depending on the size of the logical drive. For more information
about cluster and logical drive sizes in MS-DOS, please see the following
article in the Microsoft Knowledge Base:
 
   TITLE: FAT Type and Cluster Size Depends on Logical Drive Size
   ID: Q67321
 
Windows 95 and MS-DOS use the FDISK utility to partition a disk. When it
accesses a hard disk, FDISK uses the system AT ROM BIOS INT13h interface,
which has a maximum of 1024 cylinders, 255 heads, and 63 sectors per track.
FDISK can access any drive within the limits imposed by the AT ROM BIOS,
which means that FDISK can access drives of up to 8 GB, calculated as
follows:
 
   1024 cylinders x 255 heads x 63 sectors per track x 512 bytes per
   sector = 8,422,686,720 bytes, or roughly 8 GB
 
The original IDE hardware interface is limited to 16 heads, which reduces
the maximum drive size to 504 MB. Newer IDE (ATAPI) technology, however,
uses a translation scheme called Logical Block Addressing (LBA) to exceed
the 504-MB limit as imposed by the system AT ROM BIOS and IDE specifi-
cation. SCSI and ESDI hard drive controllers use similar translation
methods that are usually built into the controller card's ROM BIOS to
exceed the 504-MB drive size limit. For more information about the use of
large hard disks with MS-DOS and Windows 95, please see the following
article in the Microsoft Knowledge Base:
 
   TITLE: Windows 95 Support for Large IDE Hard Disks
   ID: Q126855
 
The FDISK utility in MS-DOS and Windows 95 can create an extended partition
larger than 2 GB. FDISK can then create multiple formatted drives of up to
2 GB in this extended partition that conform to the AT ROM BIOS constraints
mentioned earlier. FDISK will not, however, allow the creation of a primary
FAT partition or logical drive in an extended FAT partition that is larger
than 2 GB. Note also that, as mentioned earlier, logical drives larger than
504 MB cannot be accessed using MS-DOS or Windows 95 unless LBA or geometry
translation is used.
 
Windows NT allows you to create 4 GB FAT drives, either as a primary
partition or as a logical drive in an extended partition. Because MS-DOS
and Windows 95 have a maximum partition size of 2 GB, FAT drives larger
than 2 GB created using Windows NT cannot be reliably accessed using MS-DOS
or Windows 95.
 
NOTE: Microsoft does not recommend using MS-DOS or Windows 95 with a 4 GB
FAT drive created in Windows NT. If you use Windows NT's dual boot feature
to boot MS-DOS or Windows 95, you should be able to access the drive, but
you may experience unexpected behaviors. In particular, some applications
or utilities may incorrectly report that 0 bytes of free space exist on the
drive.

If you partition your new hard drive into two partitions, one 2g and one 1.xg, you won't have the problem any longer.
Dennis
0
 

Author Comment

by:bryan_kay
Comment Utility
I checked my version of Win95. It turns out to be 4.00.950B.
According to the help screen it will support HDD up to 2TB.
B.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
bryan kay,
You said it is a new HD.  Did you format it with FAT32?
You would have to run FDISK first using the version that came with Windows 95B.
If so, starting from another operating system or version other than Win95B can cause problems with the FAT32 drive.
Regards,
Ralph

0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
bryan, I have another guess. Recently, I heard in one of discussions,
that 2 HDDs, one Ultra-ATA (UDMA) and second non-Ultra-ATA  can't
sit one one IDE line, so if this is your situation, move your
slave on Secondary IDE Master.

0
 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
Hmmm..  maybe something is trying to write to a read-only file?
Do you run a config.sys or autoexec.bat file?
If so, please paste them here for us.
Ralph

0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Bryan, would you post your motherboard make and model, Bios type and version as well as the 2 hard drives your using.
Dennis
0
 

Author Comment

by:bryan_kay
Comment Utility
Problem Solved: I simply replaced the HDD with another one.The new one dosn't give me those errors. According to the technicians who replaced the drive, the original probaly has a manufacturer's defect. I did not try every solution proposed so I am not positive that this was the only solution. However, it was one that worked. Thanks for all the input guys.
    The closest solution to the one I used was the answer from q2quo which I rejected (hard drive will die soon). Terry: if you think this was a reasonable solution, post it and I will transfer the  points to you.
     
bryan
0
 
LVL 1

Expert Comment

by:c4lv1n
Comment Utility
Hey, this is the cause for your problems:
you MUST partition AND format your harddisk with LBA turned on!
This is because the LBA makes other remarks in the partition table than LARGE or others. So try following: Wipe ALL DATA from the harddisk. Delete ALL partitions.
Save this blank partition table !!!
goto BIOS and turn on LBA.
Partition your harddisk and format it. And now: PROBLEM SOLVED.
So every new harddisk will work if it is not partitioned. If you create new partitions on this new harddisk you do the same as described above.
Try with your old disk, you will be supprised.
0
 

Author Comment

by:bryan_kay
Comment Utility
I exchanged the HDD which was giving me problems for
another one. I no longer have access to the old disk
so I can't try your suggestion on it.


0
 
LVL 7

Expert Comment

by:busuka
Comment Utility
Glad for you that you solved problem. Now you can delete this
question and refund your points. Just post into Customer Service
0 pts question with question ID and subject: please remove my question.

0
 
LVL 7

Accepted Solution

by:
linda101698 earned 50 total points
Comment Utility
I'm posting bryan_kay's comment to what the solution was so everyone can see what solved the problem.

Problem Solved: I simply replaced the HDD with another one.The new
                         one dosn't give me those errors. According to the technicians who
                         replaced the drive, the original probaly has a manufacturer's defect. I did
                         not try every solution proposed so I am not positive that this was the
                         only solution. However, it was one that worked. Thanks for all the input
                         guys.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Mouse resolution (dpi) 2 73
Wireless mouse not working... 2 36
Intel 2.53Ghz processor vs. ? 7 31
Power to 2.5 inch hard disk 3 32
this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
This is about my first experience with programming Arduino.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now