Netscape Communicator 4.03 - Hidden messages in INBOX

Hello Communicator Experts,

My remote customer experiences a very strange problem. All  read messages in INBOX (i.e. messages without green unread mark) become hidden after switching to another folder or closing mail window. "Total messages" still shows a correct number of messages but there is no way to see them.

If moved to other folders immediately after reading, read messages remain readable.

I've checked files "inbox" and "inbox.snm" in "mail" directory. They seem to contain valid information.

The customer has reinstalled Netscape Communicator to the same destination with no result.

Removing file "popstated.dat"  also was useless...

Any ideas will be highly appreciated.

Best regards,
Mihails Nikitins
nikitinsAsked:
Who is Participating?
 
magigrafConnect With a Mentor Commented:
nikitins...

From the file name I can tell you that it's not the 128 bit security it's the 64 bit release.

Another thing I would like to point here, is that Communicator last release is 4.04 and is now FREE as Standard Edition.
(www.netscape.com)

I do realize that the procedure of UNINSTALLING then REINSTALLING is not what you want, but at that stage to correct the problem I believe it's your ultimum solution here. (you could stay months before you find out what went wrong if you ever find out)

My best technique for a quick Uninstall and Reinstall is:

1) Copy or more your profile from under the Users directory (with all it's content( bookmark, mail, news etc..)

2) Uninstall the old copy

3) Reinstall the new one (preferably into a new PATH like c:\Netscape instead of the deafult c:\Programs Files\Netscape...)

4) After the install is successful, launch Netscape

5) Create the NEW profile the same as the old profile (e.g.: Old prfile name was "Peter" the new one will be "Peter")

6) Then close Netscape, rename the NEW profile unders Users from Peter to PeterNew

7) Now move back all your OLD prfile to the new installation under Users.

That will make your new install work with ALL your previous settings without any glitch.

Hope this helped
Regards
0
 
tecbuilderCommented:
I have had the same problem on rare occasions.  I think it is a bug and not much you can do about it.  All the messages due show up again, but I don't know what I did in order to make them return.
0
 
magigrafCommented:
nikitins...
Which release of Communicator are you running??
Regards
0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 
tecbuilderCommented:
FYI, I am using NS 4.04.
0
 
magigrafCommented:
I'm running the same release but 128bit and NEVER had that problem.

In my inbox I receive daily about 50 to 75 messages.
I keep only 30 days of messages from EE which accumulates well over 3000 messages, and again never had or seen nor heard about that problem.  But I believe you guys.

nikitins...

Could you give us more info about your system, and what apps are running, Norton etc...

Regards
0
 
tecbuilderCommented:
Like I said it rarely happens.  I also am using the 128 bit version.  I generally get 30-40 messages a day, and I delete my messages on a regular basis.  Perhaps this is where the problem lies.  It has not occurred lately and I have been empting the trash about once a week.
0
 
magigrafCommented:
tecbuilder: Where is the answer???
0
 
tecbuilderCommented:
My sincere apologies.  I did not know I posted an answer until I came back to read your comment.  It was definitely not intended to be an answer.

Reject my so-called answer nikitins.
0
 
magigrafCommented:
tecbuilder...
I was really hoping for one ;-(
It would have been interresting to find out why it's happening.
Regards
0
 
tecbuilderCommented:
The next time it happens to me I will be much more careful to note what I do to get the email back and what I was doing to make the email go away.
0
 
nikitinsAuthor Commented:
I'm glad to know that the bug is already known. Thanks for your reply, tecbuilder,
but I really would like to know a way fixing the problem. ;)

My customer does not have huge megabytes in his folders, as he is a new user.
At the very beginning INBOX worked properly. As I said, reinstallation to the same
destination hasn't fixed the problem. Full removing and reinstalling of Netscape is not
the best solution, because it's a long procedure to save and recover user's files.

This is Netscape Communicator v. 4.03, extracted from cb302e403.exe. I don't know
how to find out whether it's 128 bit version.

Regards,
Mihails Nikitins

0
 
nikitinsAuthor Commented:
Thank you, magigraf, for the detailed instructions of recovering user information. It will save
a lot of my time.

It's a sore true that we are living in the age of buggy software and buggy operating
systems. :(  I remeber reliable computer environment of  1980s... :)

Best wishes,
Mihails Nikitins
0
 
magigrafCommented:
nikitins...

I know what you mean, our mind was focused on production then, but today our mind is focused on how to get around the bugs that stalls our production.

Regards
0
 
nikitinsAuthor Commented:
Hmmm-mmm, I wanted to give magigraf 250 points, not 25. :( I chose "Good" and  250 points.
Magigraf, how can I give you the rest 225 points? Should I ask a fictive question or can I drop e-mail
to site administrators?

Mihails Nikitins
0
 
magigrafCommented:
Mihails...

You gave me what I deserve, don't worry.  You actually gave me the 250 points and because you graded me with B=good the EE site gave me 3 times what you gave me to a total of 750 points.

The 25 points that you see right now are the value than any other person beside you or me would have to pay to read the question.

Thanks for your concern, you are a gentlemen.
Regards
0
 
nikitinsAuthor Commented:
I have solved the problem!

Uninstallation hasn't help anymore, because the problem was in damaged INBOX.SNM file.
After removing it, everything works perfectly (Netscape generates new SNM file automatically).

Thanks to all of you. I hope this information could help you. :)

Regards,
Mihails Nikitins
0
 
nikitinsAuthor Commented:
SHAME ON ME!!!

The solution was *A BIT* simpler:

View -> Messages -> All

This setting is defined for each folder separately.
Deleting of .SNM file forced Netscape to restore all default folder settings.

I've never used this option. My customer *DID*. :( :)

Mihails
0
All Courses

From novice to tech pro — start learning today.