[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 261
  • Last Modified:

No answer from Dial-up Server

Win95 network
When I call DUS, I don't get a terminal screen.
DUS only shows 'Monitoring' in Status window, whether there is an incoming call or not.
Registry settings on a sever machine under

HKEY_LOCAL_MACHINE/
System/
CurrentControlSet/
Services/
Class/
Modem/
0000/

in a subfolder 'Answer' for a string
value '1' is "ATA<cr>"

and in a subfolder 'Monitor' for a string
value '1' is "None"

The only control lights on an external USR Sportster Vi 33.6
modem that are ON when DUS is enabled are AA (Auto Answer),TR (Data Terminal Ready),CS(Clear to Send).

I know that when I install Dial-up Server I shouldn't have to deal with no stupid modems or registry but hey, it doesn't answer no calls!

Maybe somebody has different(correct) registry settings that I could use. I'm open to any suggestions.
0
mariush
Asked:
mariush
  • 6
  • 3
  • 2
  • +1
1 Solution
 
mariushAuthor Commented:
Adjusted points to 100
0
 
laeuchliCommented:
Make sure on the computer that is calling the modem has the option bring up terminal after dial.
jesse.laeuchli@usa.net
www.angelfire.com/biz/freestore/index.html

0
 
mariushAuthor Commented:
I wish it was something simple as that.
If You have the DUS enabled, then maybe You could give me Your registry values of those keys I wrote about in my question.
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
mariushAuthor Commented:
Adjusted points to 200
0
 
laeuchliCommented:
in my registery I have three vaules in moniter which are default which has has no vaule set,1 which is ATS0=0<cr>, 2 which is None
0
 
mariushAuthor Commented:
How about an 'Answer' key and do You use DUServer?
0
 
laeuchliCommented:
Answer is the same as you and yes I use dialup sever.
0
 
alexbikCommented:
Hi,

It sounds a bit odd that the AA light is on, and the
answer string is set to ATA. Either you let your software
answer the incoming calls for you by sending ATA when it
receives a RING from your modem, or you let your modem do
this all by itself, but not both. If your modem is in Auto
Answer mode, it will still send a RING on an incoming call.
If your software sees this, and sends an ATA (while your
modem is still handshaking), your modem will definitively
hang up right away.

Alex
0
 
mariushAuthor Commented:
I'm sorry I couldn't respond to that but I'm a bit busy lately. I wouldn't relie on that AA light. It comes on when an answering machine comes on on the same line. How do You suggest I set my modem registry settings to get the modem to answer the calls?
This is what I have right now:

Answer        (Default)           (value not set)
              1                   "None"
Fax           (Default)           (value not set)
              Class1DTESpeed      "AUTO"
Hangup        (Default)           (value not set)
              1                   "ATH<cr>"
Init          (Default)           (value not set)
              1                   "AT<cr>"
              2                   "AT&F1<cr>"
Monitor       (Default)           (value not set)
              1                   "ATS0=1"



0
 
alexbikCommented:
Hi,

The Monitor setting (ATS0=1) puts the modem in AA mode.
I'm not sure what is meant by 'Monitor' here, but if this
hould be some passive thing to check what's going on,
putting the modem in AA mode doesn't seem to be the right
thing to do to me. On the other had, if this is indeed the
case, this mistake is too obvious to be true, not even
microsoft makes that kind of mistakes. How did those entries
get there anyway? I Know that USR modems can be a bit different from rockwel based modems (in initstrings and stuff), but ATS0=1
is the 'take incoming calls on first ring' command on every
modem I've ever seen. Bottom line is, that if you have not
altered the registry settings yourself, you can be quite sure
that they are correct. If you're not sure about this, try
changing the ATS0=1 command into just a plain 'AT'. This
doesn't do anything besides making you modem say 'OK', so It
can't hurt..
0
 
mariushAuthor Commented:
I have altered my registry to begin with, cause modem doesn't answer but I also think that my modem could be messed up.
I just found out that when monitor is set to "AT<cr>" and Answer to "ATA<cr>" I am able to connect by first dialing from the client and then enabling the DUServer. When registry is set like that the modem's lights that come on are AA, TR, CS, OH. If I enable server first then client gets busy signal.
I think the oriyginal settings for Answer were "ATA<cr>" and Monitor "None" but they didn't work either.

0
 
jvidorCommented:
be sure to check that option to 'allow call access', in connection options of dial-up configuration, is checked and password is set. yet don't forget to specify the type of server is yours. to connect 'workgroups' or 'slip/ppp-internet' in the same dialog box.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 6
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now