Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 347
  • Last Modified:

PPP connection using Caldera OpenLinux

I am having problems connecting to my isp. I get no sound, or even any response from my modem at all.  I know it works
because I can get on the internet using win95.  I obtained the following information from my isp:

the ppp-on script:
#!/bin/sh

/usr/sbin/pppd /dev/cua2 38400 \
connect "/usr/sbin/chat -f /etc/ppp/chat-netcom" \
defaultroute modem crtscts lock

the chat-netcom script:

ABORT           BUSY
ABORT           'NO CARRIER'
''              ATZ
OK              AT+FCLASS=0
OK              AT&F&C1&D2
OK              ATDT(provider no.)
CONNECT         ''
login:          us,ppp,userID
Password:       your-passwd
'PPP session'   ''

the option script:

domain ix.netcom.com
ipcp-accept-local
ipcp-accept-remote
noipdefault

the ppp-off script:
#
# If the ppp0 pid file is present then the program is running. Stop it.
if [ -r /var/run/$DEVICE.pid ]; then
kill -INT `cat /var/run/$DEVICE.pid`
#
# If unsuccessful, ensure that the pid file is removed.
#
if [ ! "$?" = "0" ]; then
echo "removing stale $DEVICE pid file."
rm -f /var/run/$DEVICE.pid
exit 1
fi
#
# Success. Terminate with proper status.
#
echo "$DEVICE link terminated"
exit 0
fi
#
# The link is not active
#
echo "$DEVICE link is not active"
exit

the resolv.conf script is set up with the proper domain and
nameservers.

I have also tried using dip but I still get no response from my modem.  Win95 says that my modem is connected to COM 1 and the serial.vxd driver is COM 2 and has an irq3 and address 0x02f8.  Using the setserial command, it shows the same thing but is /dev/cua1 (which is also COM 2).  So how do I get my modem to respond?  I have read the serial, ISP-HOOKUP and several other HOW-TO's and get the same result.  
0
shipley
Asked:
shipley
  • 2
  • 2
1 Solution
 
spjuverCommented:
You can't use 'ppp /dev/cua2 ....' when the modem is attached to COM1 under WIN95. Should be 'ppp /dev/cua0...) under linux.

You can test the modem response with minicom (is included in the most linux packages) or 'cu -l cuax' where x is the device number for your serial port.
0
 
shipleyAuthor Commented:
The 'ppp /dev/cua2' in the scripts is just a sample that I got from my isp. You are correct in saying that COM1 under win95 is /dev/cua0, but linux is telling me that the device can't be open. But when I use '/bin/setserial -bg /dev/cua1' instead of /dev/cua0, linux see's the port address and irq setting of the serial driver.  The problem is that if I use the ppp scripts and minicom using /dev/cua1 (though I think it should be /dev/cua0 because modem is on COM1), I get no response from my modem.  The same goes if I use /dev/cua0 for the ppp scripts and minicom.  Could the problem be that my win95 uses PnP? And if so, what do I do to correct it?
0
 
spjuverCommented:
Ahhh... you have PnP cards...

If you have isapnp tools do a pnpdump|more and check if any card uses irq 3 or 4 in the tables.


Otherwise it can be a initialize-string problem in the modem.
The modem may not echo AT-commands by default.

Find the windows driver file and do a cat on it to find windows initialize string. It worked on my modem (I don't have any manual for it)
0
 
shipleyAuthor Commented:
Well, I'll try your suggestion to see if it works, but I found some new info on my modem.  My modem is a "Winmodem/mwave" and  was told that it will not work on my linux system no matter how much I try.  It uses the cpu via a DSP to do the modulation.  Does PnP use this type of device as a modem? Or does it just happen to be that I found a device that just don't work in linux?
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now