ESS1688 AudioDrive soundcard midi setup

I have an ESS1688 AudioDrive sound card.
I've configured with sndconfig (--noprobe options, otherwise a core dump).
Wav and internal midi works OK, but not external midi.
(And doom's musserver says that it can't find /dev/sequencer, though it exists actually).

I have in modules.conf "alias sound sb" and "alias midi opl3".

My /etc/sndstat gives:

[~]# cat /dev/sndstat
Sound Driver:3.5.4-960630
Kernel: Linux localhost.localdomain 2.0.32 #1 Wed Nov 19 00:46:45 EST 1997
i586
Config options:
Installed drivers:

Card config:

Audio devices:
0: ESS ES1688 AudioDrive (rev 11)

Synth devices:
0: Yamaha OPL-3

Midi devices:

Timers:
0: System clock

Mixers:
0: Sound Blaster


note that midi port mpu401 is not recognized, and there are no drivers found).
I also tried to launch mpu401 module, but it didn't work.
Please, help.


lgvAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

xtermCommented:
I have a Compaq with that lousy card in it too.  Although when
I cat /dev/sndstat, the midi device doesn't show up (and never
has for any ESS**88 cards that I have run), midi, wav, mp3, etc.
all work perfectly.

My configs are at http://foo.rawx.com/[kernel.txt/sndstat.txt &
dmesg.txt]   Set yours up like mine.  Should work fine.
0
lgvAuthor Commented:
As far as I can see, you're proposing me to build sound into the kernel. At this moment I don't have disk space enough to install both kernel source and C compiler. Why doesn't sound work as a module?
I see that you are using OSS/Free 3.8, but I have the RedHat driver which seems to be a modified version of OSS/Free's. Does that make the difference? Where could I find OSS/Free 3.8 precompiled 'sb' and 'opl' modules?
Thank you for your interest.
0
xtermCommented:
I'm not necessarily proposing that you build sound into the
kernel, but I am proposing that you either (A) run sndconfig
again with the same parameters I'm using, or (B) build a fresh
sound module (which of course you can't do, since you say you
don't have enough disk space.)

If you have to use precompiled modules (which I don't like,
because you get a whole bunch of modules instead of just sound.o)
then get the modules package for whatever kernel you have from
the place you got linux from.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

lgvAuthor Commented:
----------------- cat /dev/sndstat output I have recompiled the kernel with your parameters and the sound built in. Midi is still missing.
If I use playmidi with -e option (external midi), I get an error message. So I still can't use my external midi equipment.
I don't see anything but internal synthesis under KDE midi programs.
Do you have an external midi sound module connected to your ESS joystick port? Does it work?

I don't have /dev/music but I have /dev/sequencer, /dev/midinn, erc. Is it OK?

Here you are some additional info.
Thank you again.

------------------------ cat /dev/sndstat

OSSS/Free3.8s8-980222 (Mon Mar 16 12:21:41 CET 1998 root,
Linux localhost.localdomain 2.0.32 #2 Mon Mar 16 12:04:21 CET 1998 i586 unknown)
Load type: Driver compiled into kernel
Kernel: Linux localhost.localdomain 2.0.32 #3 Mon Mar 16 12:23:31 CET 1998 i586
Config options: 2000002

Installed drivers:
Type 1: OPL-2/OPL-3 FM
Type 26: MPU-401 (UART)
Type 2: Sound Blaster
Type 29: Sound Blaster PnP
Type 7: SB MPU-401

Card config:
Sound Blaster at 0x220 irq 5 drq 1,5
(SB MPU-401 at 0x330 irq 5 drq 0)
OPL-2/OPL-3 FM at 0x388 drq 0

Audio devices:
0: ESS ES1688 AudioDrive (rev 11) (3.1)

Synth devices:
0: Yamaha OPL-3

Midi devices:

Timers:
0: System clock

Mixers:
0: Sound Blaster

----------------- Relevant part of dmesg output ------------------------
Sound initialization started
<ESS ES1688 AudioDrive (rev 11) (3.1)> at 0x220 irq 5 dma 1,5
<Yamaha OPL3 FM> at 0x388
Sound initialization complete

0
luteijnCommented:
Midi works for me, I'll be happy to donate you my 'sound.o',
I have kernel 2.0.33, but it _should_ work (force insmod
perhaps needed?).
I'll put the sound.o file on my old homepage, let me know when
you're done with it, even if it doesn't work :)
(best use explicit 'download' function (shift left (?) with netcape I think))
And good luck with your card.

http://elektron.et.tudelft.nl/~luteijn/

Here's my output (hmm alot, sorry...):
(relevant line from lsmod:)
sound             25            1 (autoclean)
# cat /etc/soundconf
/*      Generated by configure. Don't edit!!!!  */
/*      Making changes to this file is not as simple as it may look.    */

/*      If you change the CONFIG_ settings in local.h you       */
/*      _have_ to edit .defines too.    */

#undef  CONFIG_PAS
#define CONFIG_SB
#undef  CONFIG_ADLIB
#undef  CONFIG_GUS
#define CONFIG_MPU401
#undef  CONFIG_UART6850
#undef  CONFIG_PSS
#undef  CONFIG_GUS16
#undef  CONFIG_GUSMAX
#undef  CONFIG_MSS
#undef  CONFIG_SSCAPE
#undef  CONFIG_TRIX
#undef  CONFIG_MAD16
#undef  CONFIG_CS4232
#undef  CONFIG_MAUI
#undef  CONFIG_SPNP
#undef  CONFIG_UNUSED1
#undef  CONFIG_UNUSED2
#undef  CONFIG_AEDSP16
#define CONFIG_AUDIO
#define CONFIG_MIDI
#define CONFIG_YM3812

#undef  CONFIG_MPU_EMU
#undef  CONFIG_AD1848
#define CONFIG_SBDSP
#define CONFIG_UART401
#define CONFIG_SEQUENCER

#define SBC_BASE 0x220
#define SBC_IRQ 5
#define SBC_DMA 1
#define SB_DMA2 5
#define SB_MPU_BASE 0x330
#define SB_MPU_IRQ 9
#define MPU_BASE 0x330
#define MPU_IRQ 9
#define DSP_BUFFSIZE 65536
#define SELECTED_SOUND_OPTIONS  0x00a80012

cat /dev/sndstat
Sound Driver:3.5.4-960630 (Mon Feb 2 22:42:16 MET 1998 root,
Linux ampersand.pc.luteijn.nl 2.0.33 #1 Mon Feb 2 21:20:35 MET 1998 i486 unknown)
Kernel: Linux ampersand.pc.luteijn.nl 2.0.33 #1 Mon Feb 2 21:20:35 MET 1998 i486
Config options: 0

Installed drivers:
Type 1: OPL-2/OPL-3 FM
Type 2: Sound Blaster
Type 7: SB MPU-401

Card config:
Sound Blaster at 0x220 irq 5 drq 1,5
SB MPU-401 at 0x330 irq 9 drq 0
OPL-2/OPL-3 FM at 0x388 drq 0

Audio devices:
0: ESS ES1688 AudioDrive (rev 11)

Synth devices:
0: Yamaha OPL-3

Midi devices:
0: ESS ES1688

Timers:
0: System clock

Mixers:
0: Sound Blaster
# playmidi -e /mnt/hda5/midi/dueling.mid
Playmidi 2.3 Copyright (C) 1994-1996 Nathan I. Laredo
This is free software with ABSOLUTELY NO WARRANTY.
For details please see the file COPYING.

(No error message. No sound either, but I don't have external midi devices.)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lgvAuthor Commented:
Didn't have the time to grade the answer, but it should be rejected. I couldn't download the sound.o offered. Tried to compile 2.0.33 with that parameters, but there's no way to make external midi work.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.