[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 570
  • Last Modified:

unlocking a serial device

Heya all!

Sometimes after i reboot my linux box a serial port or two
are locked for some reason.. and a file LCK..ttySx is created in /var/lock

Is there anyway to unlock this device so it's useable again ?

unlock /var/lock/LCK..ttySx doesn't work..  makes the computer THINK it's unlocked, but still doesn't work.

Is there another way I should be doing this?

Thanks
Andrew

q@qonline.com.au
0
Q010797
Asked:
Q010797
1 Solution
 
bjacobsCommented:
Delete the LCK file
0
 
Q010797Author Commented:
that's the same as unlock /var/lock/{lock file}

no go.  I need some correct way of doing it
0
 
spjuverCommented:
Which daemons are running??
Do a 'ps -ax' and post it.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Q010797Author Commented:
I have to wait till the problem occurs again (only ever after a reboot) and I will paste the ps -ax here . .

Have just rebooted.. if I don't have locked tty's in an hour.. I won't have them at all . . makes sense right ? :)
0
 
Q010797Author Commented:
at the moment . .ttyR7 is locked but it shouldn't be

120  ?  S    0:00 /usr/local/sbin/mgetty ttyR6 -n 1 -D -x2 -m "" ATZ OK
  121  ?  D    0:00 /usr/local/sbin/mgetty ttyR7 -n 1 -D -x2 -m "" ATZ OK
  122  ?  S    0:00 /usr/local/sbin/mgetty ttyS0 -n 1 -D -x2 -m "" ATZ OK
  123  ?  S    0:00 /usr/local/sbin/mgetty ttyS1 -n 1 -D -x2 -m "" ATZ OK
  124  ?  S    0:00 /usr/local/sbin/mgetty ttyS2 -n 1 -D -x2 -m "" ATZ OK
  125  ?  S    0:00 /usr/local/sbin/mgetty ttyS3 -n 1 -D -x2 -m "" ATZ OK

it has a D instead of an S next to it... this help anyone fix my problem?
0
 
spjuverCommented:
The only way to get a lock-file is to start a deamon which uses that port. The problem can, with other words, be a hanging process or a process with crashed.

If it only occurs during/after a reboot check your boot scripts for such kind of daemons.
0
 
Q010797Author Commented:
Thing is... straight after the boot there will be no lock file for upto 30minutes..  and I assume it's mgetty that is hanging.  Why does it only do it sometimes? and why only after a reboot?  I don't usually have to reboot more than twice for it to go away.
0
 
luteijnCommented:
Perhaps rebooting somehow upsets your modems, and some of them
start to babble endlessly with the getty, after a while confusing
eachother so much that they keep at it forever...
See if anything interesting is in your syslog (getty complaining
about what is send to it by the modem for instance)
Sometimes my modem does things like this when used for dialin,
I then just killed all the stuff interacting with it: kill -9 `ps |grep S2 |grep -v grep|awk '{printf $1}' `
removed the lock file: rm /var/spool/uucp/LCK..cua2, and reset the whole thing: stty crtscts < /dev/cua2 ; printf "+++at&Y0s0=4\n\r" >/dev/cua2
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now