[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Hang up RAS connection automatically

Posted on 1998-02-22
11
Medium Priority
?
909 Views
Last Modified: 2013-12-23
I have setup a new Microsoft proxy server 2.0 as a gateway for a workgroup to access the Internet via modem connection. It works well, such as to cache URLs, automatically dial the ISP ...

The problem is, it seems the RAS connection cannot be disconnected automatically when there is no user to access the net. Of course, I noticed there is an option in Modem properties, Disconnect a call if idle for more than n minutes, but it looks the option has no any effect. I also have tried to use Dial-up Networking to manually call an ISP, then do nothing to wait for the line disconnect, still with no luck. :-( So, I have to hang up the RAS connection manually every time the clients have no interest on the net. :-((

Also, the Dialing Hour Schedule has no any effects to control client's access to the net. Why?


Any idea?
0
Comment
Question by:bbao
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 37

Author Comment

by:bbao
ID: 1571053
I already knew, to make the auto-dial schedule has effection, just start the schedule service.
0
 
LVL 2

Expert Comment

by:eizens
ID: 1571054
It's possible, thatsome applications generate some traffic -- for example, some mail client, checking mail-box every 10 min, when default tim-out for dial-up is 20 min.
Best regards, Eizens
0
 
LVL 37

Author Comment

by:bbao
ID: 1571055
Thanks for your comment.

I have already disabled all the Server, Workstation and NetBIOS binding to the RAS WAN Wrapper, and I am sure there is no other traffic such as email checking, they are all stopped. But, no help! :-(

I have checked M$ newsgroups, and discovered that there were a lot of discusses on this topics there. It looks that is really a problem!

Any idea?
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 1

Accepted Solution

by:
kuk010998 earned 300 total points
ID: 1571056
I spent the 400$ with MS on this subject. Result - "Sorry" but no refund.

In more detail - Proxy does NOT issue the equivalent of RASDIAL /DISCONNECT himself. MS will NOT add this functionality - reason I got being: customers in the US can afford waving their connections eternally. European market is not important enough. Proxy relies on the idle timeout feature of RAS. The RAS internal code is such that times under 2 minutes cannot be guaranteed - it may hang up earlier, but most probably it will add 60 seconds to the configured value, and round up to 2 minutes. Furthermore, it needs to have the same timeout entered  both under 'user options' AND under 'login options' (NOT logical but that´s what the MS guy said - and I have actually experienced this once). You already know to disable unneeded bindings - another thing the MS guy mentioned (I also already had done it).

>I am sure there is no other traffic
Even checked with SMS netmon - helped in one case where I had a SNA server continually broadcasting junk, but Proxy/RAS still is able to $%%& up without such help.

Did I forget something? Oh yes - I still had to reinstall several times to make it behave. Reinstall NT from Scratch, not only Proxy! I believe the RAS machinery is a little bit sensitive to repeated reconfiguring.

Another thing: Do you want to have clients connected via WinSock proxy only, w/o TCP/IP on the internal network? If so, and you want them to use the web proxy as well, you are in for more fun (MS could add a feature to handle this cleanly, but they won´t because mostly we worthless europeans would be interested). The instructions in the Proxy FAQ (which was on the web but MS cut all links leading to it when they introduced 2.0) say to configure the clients to use the internal IP number of the proxy machine so (not having TCP(IP bound to the NIC) I added MS loopback, gave it an IP and used that - worked like a charm for a few weeks then bang...

Last not-well-known Proxy trick: If you want IPX Winsock Clients, the client config needs to refer to the *internal* IPX adress, but setup configures the external one.

Good luck.

0
 
LVL 37

Author Comment

by:bbao
ID: 1571057
Did you try to stop the RAS service according the schedule you specified in order to disconnect the phone line? Or some other ways? Of course, I don't like the way to timely shutdown this server. :)

Also, did you notice that if you dial-up manually, the connection will be hang on time.

So, I think it is possible but needs more thinking. Anyway, it looks that is a bad egg made by M$. :-(

BTW, why M$ did not refund your money?
0
 
LVL 1

Expert Comment

by:kuk010998
ID: 1571058
>Did you try to stop the RAS service according the schedule
Would be no problem but did not fit the bill in our case.
>Also, did you notice that if you dial-up manually, the connection will be hang on time.
You´re lucky. This thing I am hacking at had the no-hangup bug with manual dialing while Proxy 2.0ß was installed...
>bad egg made by M$. :-(
Well, as I said it should be easy for the Proxy team to fix - have Proxy issue the hangup himself - and as proxy has far better data to estimate future usage it could do so more intelligently than RAS... I still like Proxy but would prefer to deploy it in conjunction with an external ISDN router.

>BTW, why M$ did not refund your money?
Probably my fault - too p&%$ed off & overworked to press it. I had only 1 installation showing the prob, and as those people could not wait I had NT reinstalled 5 times over when the MS guy called, so I could not test easily... My own Proxy started being nasty some time after the case was closed.

Have fun

0
 
LVL 37

Author Comment

by:bbao
ID: 1571059
I got it to work!

One of your comments is most important for me: Furthermore, it needs to have the same timeout entered both under 'user options' AND under 'login options'.

It looks, the Logon Preferences is for Auto-dial, Auto-logon?

BTW, sometimes, the proxy dial-up to the Internet without any client request. What is it doing? For active caching? I use system default caching options.

Thanks!
0
 
LVL 1

Expert Comment

by:kuk010998
ID: 1571060
>I got it to work!
Nice to hear.

>needs to have the same timeout...
>It looks, the Logon Preferences is for Auto-dial, Auto-logon?
As I said - not logical. The doc for this option dialog clearly states its values are used only in the case where you log in to a network via RAS from the Ctrl-Alt-Del Login box. But perhaps these values need to be read by a service which does not have access to the interactive user´s registry hive - so it looks in the .DEFAULT hive instead.

>BTW, sometimes, the proxy dial-up to the Internet without any client request. What is it doing? For active caching? I use system default caching options.
Apart from the fact that you should restrict active caching anyway (to keep proxy´s dialing behavior predictable) you may also have Exchange clients causing the proxy to dial. The pre-outlook (and outlook perhaps as well) will always use a winsock.dll if it finds one, even if not configured to do so. If your client is using Winsock Proxy via IPX, starting the Exch. Client will force the Proxy to dial... I´m too lazy right now to look it up, please do so yourself - check the proxy FAQ first (tells you how to tell the proxy client DLL to ignore Exchange), then KB articles Q152344, Q167030 (how to prevent Exchange Cl. to make TCP/IP calls).
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1571061
(keeping the points)
0
 
LVL 37

Author Comment

by:bbao
ID: 1571062
?
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1571063
bbao, you're wondering about my comment?
Well, it's just a trick to view this question as often as I like without paying the points again.
Will work as long as the programmers at E-E don't check the date.

I don't worry about the points, but I have a link now to this question, and want to see it immediately.
I'm using E-E as my knowlege-base too ;-)
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

FIPS stands for the Federal Information Processing Standardisation and FIPS 140-2 is a collection of standards that are generically associated with hardware and software cryptography. In most cases, people can refer to this as the method of encrypti…
This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question