Solved

Linux wont BOOT!!!

Posted on 1998-02-23
5
232 Views
Last Modified: 2013-12-15
Installed linux in my 5.1G Hard Drive,
I installed LILO in the same drive as root directory "/"
I added that partition to OS/2 boot manager
When I try to boot, The screen only dysplays:

L

and that's all.

The hardDrive is a Western Digital 35200,
Physicaly it has around 10500 cylinders.
the Bios translates it as something around 523 Cylinders

Whats wring with LILO????

If the problem is the 1023 barrier, How can I know where in my drive is???


0
Comment
Question by:Tonahuac
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 

Expert Comment

by:spjuver
ID: 1631410
First, don't use LILO. It is too sensitive. I don't know how LILO works but a guess is that LILO links itself to the cylinder where it can find vmlinuz.
If you move vmlinuz physically on the harddisk you will get the famous 'L'.

If you use windows and have a viruscheck active it can one day say 'Find a virus in the boot sector - removing...' and you have no LILO anymore.

Survey, it is definetly the '1023 barrier' and the solution is the use loadlin or boot disk for linux.

You can check the partitions physical position with fdisk.


0
 
LVL 2

Expert Comment

by:jeffa072897
ID: 1631411
Every time I've seen this the hard disk with Linux on it was not visible during POST. The drive required an OS driver to see it.
Example - SCSI drive on controller with no BIOS
          Drives that require disk management software on the
          boot sector.
If you can't boot the system with a DOS floppy and see the hard disk in question, you either have to use loadlin or change the controller setup. LILO Will only see drives that are present according to the system's BIOS and/or a disk controller's BIOS.
If the drive isn't there with the BIOS you get the "L"
         

0
 

Accepted Solution

by:
christg earned 200 total points
ID: 1631412
You can try to disable the lba for your hard drive
0
 
LVL 1

Expert Comment

by:hwillekens
ID: 1631413
Boot linux using loadlin and run lilo again
0
 

Expert Comment

by:hal9k
ID: 1631414
Use a boot disk, like for slackware...at the boot options prompt type 'mount root=/dev/whatever_device_it's_on' (typically /dev/hda1, but you'll want to check with fdisk) when it loads up, login, and then run lilo. take the floppy out again and reboot. If that doesn't work then you've specified options in lilo.conf incorrectly
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question