Solved

Capture problem in Intranetware client

Posted on 1998-02-23
22
417 Views
Last Modified: 2012-08-13
We capture printers on netware 4.11 server over a container login script from an Intranetware Client 4.11 using the following syntax:
#CAPTURE Q=.GPEDV_NPS1_B4318.DRUCKER.EDV.NST NB NFF C=1 /TI=10 L=1 /NT
If we endcap these capture over a user login script it makes problem under NT.
There are the sign:"LPT1 is not configured or not present"
If we endcap the capture over "Network properties Endcap" it works fine.
Any ideas??
regards
Gerd
0
Comment
Question by:brauner071697
22 Comments
 
LVL 5

Expert Comment

by:jstegall
ID: 1591839
Try referencing the with Q=<queue name> s=<server name>
and not the NDS name.  This worked to solve a simular problem so
may work for you.
0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591840
sorry, but it doesnt't work.
If I endcap in the login script I get the following error message:
Error returned from '#CAPTURE /endcap L=1' command: 3101
any ideas
regards
gerd

0
 
LVL 4

Expert Comment

by:saar2
ID: 1591841
Are you using Win95 or DOS workstations?

Saar
0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591842
Do you have print job configurations? Check this TID: 2931424
This problem may apply to NT also.
=====
LOGINW31.EXE Not Capturing Print Job Config.  (Last modified: 09JAN1998)

     This document (2931424) is provided subject to the disclaimer at the end of this document.
         Forward this document to a colleague
         Submit comment about this document to its author

     Symptom

     A Print Job Configuration is created and made default for a user under their user's properties
     page in NetWare Administrator. Using the Novell intraNetWare Client for DOS/Windows
     version 2.20 , the user's login script is edited to include the line"#CAPTURE" which should read
     the Print Job Configuration and run the capture for the user. However, the following error is
     generated and appear in the login script results window:

          Error returned from '#CAPTURE ' command: 3101

     Cause

     The problem is in the LOGINW31.EXE file dated 06-27-97 9:18a file size 5,512 bytes. With version
     2.20 of the client, the capture utility was internalized into the GUI login, and Print Job
     Configurations won't run.

     This problem has also been seen with LOGINW95.EXE from the 2.20 Windows 95 client.

     Solution

     There is no solution at this time. Novell engineering is working towards a fix.

     WORKAROUND:
     A workaround is possible if the user's script maps their defaut drive (ie.
     F:=SERVER_NAME/SYS:\) BEFORE the capture statement runs and then the external command
     "#F:\PUBLIC\CAPTURE.EXE" is called in the login script. The external capture command will run
     the Print Job Configuration.

     SEARCH: DOS Windows 3.11 for Workgroups External Command 2.2 2.20 loginw95 print job
     capture.exe gui

                    Please select if this document solved your problem.

      Document Title:
                          LOGINW31.EXE Not Capturing Print Job Config.
      Document ID:
                          2931424
      Creation Date:
                          24OCT97
      Modified Date:
                          09JAN98
      Document Revision:
                          2
      Novell Product Class:
                          NetWare OS
                          Novell BorderManager
      Novell Product and Version:
                          NetWare 4.11
                          NetWare 4.11 Kayak
                          NetWare 3.12
                          NetWare 3.2
                          intraNetWare
                          intraNetWare Client CD (August 97)


     DISCLAIMER

     The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this
     information. However, the information provided in this document is for your information only. Novell makes no
     explicit or implied claims to the validity of this information.

     Any trademarks referenced in this document are the property of their respective owners. Consult your product
     manuals for complete trademark information.
0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591843
We are using Windows NT 4.0 with SP3 and the Intranetware Client for NT ver.4.11.

Sorry Jstegall,
but it doesn't work. I've tried it with your information but it is always the same.
LPT1: is an unknown device after #Capture /endcap L=1.
If we endcap it manually over NT it works.

any ideas?
regards
gerd
0
 
LVL 2

Expert Comment

by:avi_shava
ID: 1591844
I almost sure this will work - Remove the # before the capture, in this client capture is an internal command, not requiring capture.exe.

Avi
0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591845
The option to endcapture is "EC" not "/endcap"
CAPTURE EC L=1 should do what you want, using the internal
client32 command.  For the external command you must use #.
0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591846
To Avi
I have removed the # in front of capture and the capture work but in the endcap section of my login script I'll receive the following error:
"Error returned from '#CAPTURE /endcap L=1' command: 3101"
My endcap line was "CAPTURE /endcap L=1"
It looks like executing an external command.

To Jstegall
It is the same result, if I take EC or ENDCAP, both ending the capture but in NT I'll receive the message:
"LPT1: is an unknown device "

Any other Ideas?

regards
Gerd
0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591847
Try using EC without the leading "/" and see if you get the message if You use EC ALL then re-capture the port you want.  If
you try it use capture sh to see if all ports are back to local.

0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591848
Try putting your end capture command in a batch file and call
it from the login scriptwith:  
  #command /c <my end capture>.bat replace text between "<>"
with the name of your batch file.
If these suggestions you have gotten from us here you might want
to open an incident with Novell to resolve this.
0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591849
sorry experts,
nothing of that what you said will working.
If I place the commands like jstegall said the LPT is set to local mode, with capture /sh it looks right, but if I print on LPT1 I got the message:
LPT1: is an unknown device

Now I've put the batch file into the startup folder and it worked. That is not so good but the only way it works.
Thanks

Gerd
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 3

Expert Comment

by:paulnic
ID: 1591850
silly question, but you are using the current 4.11A client for NT?
0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591851
Do you have a local printer connected to the workstation where
you end capture? No printer on lpt1 will give you an error when
you try to print to it.  After you endcap have you looked at the
port in device manager to see its status?  What is it?

If you have the latest client and these suggestions still doesn't work, I would try using NAL, if you don't want to have to update all the remote users startup folder.
With nal you can force run any executable file, you can set it up
so it won't intrude on the users.
0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591852
Yes, I have a local printer connected to LPT1. This is the reason why I would like to endcapture LPT1!!!
In the device manager the drivers for the parallel port are active.
Yes I have the latest client and the latest SP for NT.
0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591853
To paulnic,
yes we using the client 4.11a
0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591854
You can not capture the ports of the systems that have local printers.   You can use a if statement something like this:
if "%P_STATION" = "<station address>" goto localp
do your normal capture after doing this for all the stations with
local printers

localp:
do the commom stuff from here to the end of the script.

You can get the station address in monitor, or set an environment
variable to %P_STATION and check the variable when you need it.
or you can set an environment variable for all stations with local printers.
SET LOCALP=YES in the stations startup file.
then branch on LOCALP in the login script.
These are some of the workarrounds you can use.
If as you say, the batch files work, you can call the batch to end capture based on the localp variable.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1591855
Could you post the capture segment of the Login script here, AND
Could you post the capture /endcap segment as well?

Is this the Latest version of Client32?
0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591856
Will you please give reasons why you reject answers?  I am confused, you said a batch execution of capture works, I showed
you how you could use that to solve you problem.  You rejected
the answer but didn't say why, so I am not sure of what you are
trying to do.  Since you know the users that have the local printers you have the address in NWadmin if they are logged on.
Did you try the batch from the personal login script by
EXIT "NAME OF BATCH FILE" have it in the workstation search path.


0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591857
Hy Jstegall,
I 've rejected your answer, because nothing of your answer worked.
I've tried all the things you said.
sorry!

regards
Gerd
0
 
LVL 5

Expert Comment

by:jstegall
ID: 1591858
If that didn't work you have an issue we are not aware of.
Will you post the login script you tried using my suggestions?
If you would rather, you can e-mail them to me at
johnie.stegall@epa.state.oh.us.  I would like to see them as
jrhelgeson also asked.  If you do the capture based on if the
machine has a local printer, you will not need to use endcap.
When you send me what you tried tell what message you received
with that try.
0
 
LVL 3

Author Comment

by:brauner071697
ID: 1591859
Hy experts,
here are my capture line from the container login script and the endcapture line from my personal login script.

#CAPTURE Q=.GPEDV_NPS1_B4318.DRUCKER.EDV.NST NB NFF C=1 /TI=10 L=1 /NT
If I endcap using the following command:
         "CAPTURE /endcap L=1"

I get the following error message:
"Error returned from '#CAPTURE /endcap L=1' command: 3101"
     
regards
gerd
0
 
LVL 5

Accepted Solution

by:
jstegall earned 300 total points
ID: 1591860
You didn't show me the tries you made of my suggestions.  Why are
you using the external command when capture is internal to Client32?  You do not seem to be using print job configurations, this is an assumption since you didn't answer that question.
Did you try:
IF "%P_STATION" = "<what ever the station address is>" then goto local:
use the above for each local printer workstation, do not include
the < > but the " " are required.  After all the workstations are listed put the capture statement, after the capture statements put the lable local:.  I asked you to post that portion of your container login script or email it to me.


0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

In  today’s increasingly digital world, managed service providers (MSPs) fight for their customers’ attention, looking for ways to make them stay and purchase more services. One way to encourage that behavior is to develop a dependable brand of prod…
We have come a long way with backup and data protection — from backing up to floppies, external drives, CDs, Blu-ray, flash drives, SSD drives, and now to the cloud.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now