Builder:I can't dinamically load winsock.dll

Posted on 1998-03-05
Last Modified: 2008-02-01
I'm trying to implement a tcpip cliente with winsock.dll, because i need binary comunication
with a server. But  the LoadLibrary("winsock.dll") fails.

How can i load the library?
i tried with others, "twain.dll" fails too, but "NViewlib.dll" works fine.

Sorry, I haven't explain it enought,
The library winsock.dll is in the windows directory, and the error that returns
GetLastError is number 31. It says that a device in the system does'n works ??
I have the TCP/IP installed, and it works!

Question by:ineila
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 22

Expert Comment

ID: 1183068
Where is winsock.dl?  You must specify a path to it or it must be in the windows directory or in the dirrectory with your app.

What is the error code returned by GetLastError()?

Author Comment

ID: 1183069
Edited text of question
LVL 23

Accepted Solution

chensu earned 30 total points
ID: 1183070
Use Wsock32.dll instead. Winsock.dll seems to be used by 16-bit applications running on 32-bit Windows even though it is a 32-bit dll.

By the way, twain.dll is definitely 16-bit while twain_32.dll is 32-bit.
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!


Author Comment

ID: 1183071
It seems to works fine in my windows NT, but GetLastError returns 120 in my
Windows 95, it says the function only works in Win32 ?? It isn't an error not?

LVL 23

Expert Comment

ID: 1183072
After which function, GetLastError returns 120?

Author Comment

ID: 1183073
After function LoadLibrary("wsock32.dll").
And, working with my NT, when i try to import function socket, it says denied access.
With the function connect, recv, etc, it says can't find resource. ??

LVL 23

Expert Comment

ID: 1183074
I tried it on my Windows 95. LoadLibrary("wsock32.dll") succeeded and returned a non-NULL handle. Check your system.

Author Comment

ID: 1183075
Ok. I checked my system.. but my error was that i didn't initialize the windows sockets
subsystem, with WSAStartup()!

Thank you.


Expert Comment

ID: 3179996
You would save yourself a lot of trouble if you just go and get a commercial Winsock VCL.

I use IP*Works! from  -  it's native VCLs, and they have a free trial.

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many modern programming languages support the concept of a property -- a class member that combines characteristics of both a data member and a method.  These are sometimes called "smart fields" because you can add logic that is applied automaticall…
Container Orchestration platforms empower organizations to scale their apps at an exceptional rate. This is the reason numerous innovation-driven companies are moving apps to an appropriated datacenter wide platform that empowers them to scale at a …
The goal of the video will be to teach the user the difference and consequence of passing data by value vs passing data by reference in C++. An example of passing data by value as well as an example of passing data by reference will be be given. Bot…
The viewer will learn how to use the return statement in functions in C++. The video will also teach the user how to pass data to a function and have the function return data back for further processing.

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question