USR 56k sportster internal

I cant seem to get my USR sportster to work in linux i have tried the init strin AT&F1 and also AT&F&H1&R2&B1&S0=1&K1&M4&S1S13=1S2=255&W But the dang thing dont wanna work.
Any suggestions would be great
monsterAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

christgCommented:
What are the setting for your modem. Irq, iobase ans the com ports
0
mike_stoneCommented:
Look at your manual or box, does it perchance have the word "Winmodem" on it?  If so, you're hosed, because the modem relies on Windows95 to set up a com port for it before it can work.  This is the latest scheme (called soft modems) to save money and provide low-cost hardware in PC's.  I recently fell victim to this and had to exchange my "Sportster Winmodem" for real Sportster which sets up its own hardware port.  If you're running windows, you can find the default settings for your com ports using the Control Panel "Ports" icon or by using Device manager under "My Computer" -> Properties.
0
monsterAuthor Commented:
The modem is set up for COM2 IRQ3.
Also the box doesnt say anything about winmodem just say faxmodem.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

mike_stoneCommented:
OK, good.  No winmodem

Verify that the jumpers on the modem are set properly.  COM2 is standard for an internal modem.  Also make sure COM2 is *DISABLED* on your motherboard (set through BIOS)!!

In Linux, cat /proc/resources and make sure the ports are assigned as follows:
COM1: IRQ 4, I/O 0x3F8-0x3FF
COM2: IRQ 3, I/O 0x2F8-0x2FF

If you haven't already, try running minicom to see if you can manually enter modem commands and get a response.  You can read all about minicom in the man pages or the HOWTO reference.

Again, if you have windows or another O/S installed, make sure the modem works properly there first, then wrestle with Linux it might be a little easier to troubleshoot.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
monsterAuthor Commented:
Ok here is some more info. First I wanna thank you guys for trying to help me.
Ok now when I do a cat /proc/resources i get a No Such File or Directory.
The jumpers are set right I have them set the way the were when I bought the modem which is all the jumpers on all the pins.
I did a setserial /dev/modem to see what it said and it says:
/dev/modem,UART: unknown, Port: 0x02f8, IRQ 3
I hope this info helps a little

Thanx again for your help
0
mike_stoneCommented:
Hmmm... Sorry about the filename, /proc is a special file system that has hooks directly into your kernel / system.  I don't have access to my Linux system from here, but the file names there are meant to be descriptive.  ls /proc should help figure out the file name you are looking for, it varies from version to version.  You are looking for something obvious like /proc/ioports, or /proc/interrupts.  You can cat these files to collect info about the kernel's view of your machine.  If that doesn't take care of it, you can post a new question or maybe re-open this one for someone else to have a gander at.

Also, did you find the BIOS setting to disable your motherboard's built-in COM2, and have you successfully used the modem with another O/S?

If you post a new question, include the distribution you are using (ie redHat) and version of your kernel which you can find by looking in /boot.  The kernel version will be the number you see at the end of your vmlinuz file.  ie vmlinuz-2.0.31-2 (the kernel version is 2.0.31)
  -- Good luck
0
mike_stoneCommented:
Hmmm... Sorry about the filename, /proc is a special file system that has hooks directly into your kernel / system.  I don't have access to my Linux system from here, but the file names there are meant to be descriptive.  ls /proc should help figure out the file name you are looking for, it varies from version to version.  You are looking for something obvious like /proc/ioports, or /proc/interrupts.  You can cat these files to collect info about the kernel's view of your machine.  If that doesn't take care of it, you can post a new question or maybe re-open this one for someone else to have a gander at.

Also, did you find the BIOS setting to disable your motherboard's built-in COM2, and have you successfully used the modem with another O/S?

If you post a new question, include the distribution you are using (ie redHat) and version of your kernel which you can find by looking in /boot.  The kernel version will be the number you see at the end of your vmlinuz file.  ie vmlinuz-2.0.31-2 (the kernel version is 2.0.31)
  -- Good luck
0
mike_stoneCommented:
Hmmm... Sorry about the filename, /proc is a special file system that has hooks directly into your kernel / system.  I don't have access to my Linux system from here, but the file names there are meant to be descriptive.  ls /proc should help figure out the file name you are looking for, it varies from version to version.  You are looking for something obvious like /proc/ioports, or /proc/interrupts.  You can cat these files to collect info about the kernel's view of your machine.  If that doesn't take care of it, you can post a new question or maybe re-open this one for someone else to have a gander at.

Also, did you find the BIOS setting to disable your motherboard's built-in COM2, and have you successfully used the modem with another O/S?

If you post a new question, include the distribution you are using (ie redHat) and version of your kernel which you can find by looking in /boot.  The kernel version will be the number you see at the end of your vmlinuz file.  ie vmlinuz-2.0.31-2 (the kernel version is 2.0.31)
  -- Good luck
0
monsterAuthor Commented:
I couldn't find anything in BIOS to disable COM2

And what exactly am I looking for in the /proc directory?
0
monsterAuthor Commented:
I couldn't find anything in BIOS to disable COM2

And what exactly am I looking for in the /proc directory?
0
mike_stoneCommented:
All BIOS setup programs are different, but there should be something to disable specific COM ports, and until you disable COM2, your modem will not be able to use it.  If you are running an older motherboard, there may be a jumper instead.  Another alternative would be to try setting the modem for COM3 or COM4.

/proc contains files which you can look at to see how your kernel views your system.  So, this is where you can check if it has detected and configured your COM ports.  You could also use dmesg to view the startup log:

dmesg | more

If linux encountered problems with your serial ports, you should see an error message to that effect in the output from the command above.
0
monsterAuthor Commented:
Man oh man this has become quite a mission......lol
I reset the jumpers to make the modem on COM3 IRQ5 i still dont get anything.
Also I did the dmsg | more thing it had one unknown pci device but i think it might be the soundcard since its an unsupported card the message that was with that is:
Unknown PCI Device (1274:5000) Please Read include/linux/pci.h
I read it and couldn't get anything outta it.
Now also I have the RedHat Linux Unleashed book and was looking through it and it said something about adding a modem was like adding a terminal so i looked through the adding a terminal part and it was talking about a mknod command but the modes and everything lost me do you know anything about this?
I hope im not driving you nuts with this stuff. Learning a new OS like linux seems to be quite a task :)
0
monsterAuthor Commented:
oh i though of something in BIOS there is a thing that asks about a plug and play OS its ON because of win95 could that be why the modem isnt working? and if it is can i turn it off and on between OS's without messing anything up?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.