Solved

CompuServe & PPP Without Restart

Posted on 1998-03-19
6
359 Views
Last Modified: 2013-12-27
I have a Mac 7300/200 with OS 8.1 and OT/PPP 1.3 and CompuServe 3.0.1.

Currently if I want to use CompuServe to access the Internet instead of my other 2 ISPs, I must use the CompuServe PPP Switcher.  Each time I use it, I must restart my computer.

How can I avoid that?

Is there a way to add a CompuServe configuration to the PPP control panel, just like I have 2 other ISPs there and can easily switch between them without restarting?

The subnet mask and name server addresses for CompuServe are already entered in the TCP/IP control panel.
0
Comment
Question by:lcauvin
  • 3
  • 3
6 Comments
 

Author Comment

by:lcauvin
ID: 1542474
Edited text of question
0
 
LVL 2

Expert Comment

by:gormenghast
ID: 1542475
Hi

You can create a connect script in PPP or FreePPP. Then connect using script
Example:

Send: \d\d\d
Wait: Host Name:
Send: CIS
Wait: User ID:
Send: <your compuserve_id>/go:pppconnect
Wait: Password:
Send: <your password>
Wait: PPP

Or you could make a terminal connection manually.

Regards
0
 

Author Comment

by:lcauvin
ID: 1542476
I had tried a similar method to what you suggested, unsuccessfully, and got the same results as with your method, as below:

When I try to connect to a command-line host using the terminal window (and create a connect script that I would like to save), I always get the following response after entering the password.  Yet I know the login and password are correct.

?? LOGINE - Invalid entry - try again
Password:

When I keep reentering the password, I keep getting the same message until I am told that only authorized users may log on.

By the way, on the script you suggest, you start with </d/d/d>.  I don't know what that means, so I typed it in as is.  Maybe that's the problem.  Also, after my user ID, I typed the </>before <go:pppconnect>  I hope that's what you meant.
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 
LVL 2

Accepted Solution

by:
gormenghast earned 400 total points
ID: 1542477
Hi

The \d\d\d in the first send are just some returns to wake up the server.

I used the < & > symbols only to indicate where your user id and password should go. They should not have been included, replace <your compuserve_id> with your id only and <your password> with your password only do not include < or >.
Similarly the "Wait" and "Send" are only there to indicate whether to click on either the Send or Wait radio button in the connection script dialog. You also need to check the checkbox to send a return after each send field (not the wait field).

You are creating the script in the connection script dialog window, then choosing the connection method as "Connection Script" and not trying to create the script in the terminal connection window aren't you?

Also are you using a comma in the user id number and not a period as you would in the email address?

I have used several versions of PPP and FreePPP with Compuserve on several different macs so would be surprised if you will not be able to manage it eventually. What version of PPP are you using?

If you want me to send you a screen shot from a correctly set up connection script then you may email me at the following address.

snorman@pavilion.co.uk

Good Luck
0
 
LVL 2

Expert Comment

by:gormenghast
ID: 1542478
Hi

I must first apologise for confusing things in my last answer in experts-exchange.
I was forgetting about the changes in PPP and that the connection script dialog is no longer in use.
So forget all I said about radio buttons & checkboxes etc.

I no longer use Compuserve, but I still have a company account which is in the process of being
wound up so I was still able to attempt a login using this account.
I made a successful terminal PPP connection with the following responses at the terminal prompts:

--------------------------------------------------------------
Host Name: CIS

User ID: 106167,1253/GO:PPPCONNECT

Password: my_password

--------------------------------------------------

I also saved this on close as a connection script. However when I tried to connect using the script it
was failing with: "Couldn't match password" while waiting to receive the password prompt.
You may be able to tweak the script by forcing it to pause for a bit longer before trying to match
"Password". Failing that you will have to make a manual terminal connection each time.

Anyway you won't have to re-boot that is for sure.
0
 

Author Comment

by:lcauvin
ID: 1542479
I am very happy to have connected to CompuServe via PPP.  As a matter of fact, I am functioning in that mode right now.  However, I have not been able to automate the connection.  I must type the information in the terminal window each time.  I will ask another question about that, but so far so good.
0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Apple's line of laptop computers has made significant strides forward in the last few years. The biggest change being the switch to Intel processors in 2005. One thing about Apple hardware, especially that from a few years ago, is the tendency for i…
Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now