IIS / FP / codebase applet problem

I have IIS and am trying to get an FP hover button working on the server side via an ASP. I have copied the fphover.class file from FP and placed it in an execute directory on the server, pointed to by the codepase parm but it will not run.

I think I am doing something really stupid, can you explain the steps I should go thru to get this working please?

Thanks
tsd05Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bigelosCommented:
FP hover is a pain in the butt in my opinion.  (Won't work on some versions of Netscape, etc., etc.).

OK, now for the solution:
I recommend putting the fphover.class file in a _fpclass subdirectory below where it is called from, and then setting the codebase to _fpclass.  In addition, this directory must have the permissions set properly, and also the file permissions set properly.

I have set up a working example at
http://kanga.unixnet.org/~bigelos/temp/test/fphover.html

I need to double-check the permissions and get them to you.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bigelosCommented:
The permissions for the _fpclass directory are universal read and execute (rx).  The permissions for the html file calling the fphover.class just have to be read (r).  The permissions for the fphover.class file only need to be read (r).

You can see my directory structure (and files) by browsing to
http://kanga.unixnet.org/~bigelos/temp/test

Let me know if you have anymore problems.
0
tsd05Author Commented:
Thanks for that but I still have problems. I have copied your stuff to my laptop running NT 4.0 WS and it doesn't seem to work. My understanding of this is that the applet is running on the client side so me not having IIS is nothing to do with the problem. My permissions on the files are "ALL" but I still get the message "applet can't start class fphover not found" in Netscape.

If I create my own simple applets then I can run client or server side with no problem, so I am not sure about permissions.

Any further ideas?

Regards
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

bigelosCommented:
Change the NT permissions on the files and directories so that Everyone has Full Control and see if that fixes it.  (Don't leave it this way--just trouble shooting).

I haven't seen NT permissions with "ALL".  The options I get are Full Control, No Access, Read, Change, and Special Access.  (R-click on the file, choose properties-security-permissions).  

Is ALL a group?
0
tsd05Author Commented:
Sorry, full control is (ALL,ALL), tried setting to full for everyone, still get fphover class not found
0
bigelosCommented:
Please post your code so I can take a look at it.
0
bigelosCommented:
Looks like another auto-grade.  Thanks, tsd05.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
HTML

From novice to tech pro — start learning today.