Solved

PB3400/200 Ethernet Errors

Posted on 1998-03-26
24
568 Views
Last Modified: 2013-12-27
I am trying to set up an Ethernet connection using the combined modem/ethernet connection cable that came with the machine -- then to a Cat 5 cable -- then to an AppleTalk compatible hub -- then to a 20th Anniversary Mac.  Simple AppleShare file sharing.

When going to the AppleTalk Control Panel and trying to select Ethernet, it looks for a zone and then errors out with a message "an error has occured please check your cables".  

With all the same settings (except for the last segment of the IP address of course) this works FINE on my 20th Anniversary Mac (and the hub can see the 20th AM).

Both systems are running MacOS 8.1.

I have defined the TCP/IP addresses and saved those configurations.  

I have double checked the cables themselves (tried two different cables) and done it once with the mixed Ethertalk and Modem cable and once directly into the back of the PB.

I have checked to make sure the Extensions folder has the PB3400 Ethernet extension installed.

I am running out of ideas on what the problem could be.

Any suggestions.
0
Comment
Question by:SHuntVA
  • 9
  • 6
  • 2
  • +6
24 Comments
 
LVL 2

Expert Comment

by:squint
ID: 1542484
Are you sure that this is a modem/Ethertalk cable, I'm unaware that such a cable can exist.  A modem cable will need a RJ-11 jack to plug into a phone or wall jack, but an RJ-11 connector does not hook up to the first wire in a RJ-45 connection used in 10BaseT.  Is there a special adapter?

Try this; connect just one end of a 10BaseT cable to the back of the PB, leaving the other end of the cable unattached, then try to change the AppleTalk setting.  If you do not get any errors, then it is a cable problem for sure.
0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542485
Thanks for the suggestion .... but.  

I have reinstalled MacOS 8.1 and kept the special extensions off while trying all this.

Have tried virtually every cable combination.  The "dual connector" comes with the PB3400 with internal modem/ethernet card.  Has an RJ45 at one end and plugs for modem and RJ45 ethernet connection.  But I have tried three different enet cables ... plugged into this special cable and directly into the back of the PB.

Have also tried the new "unsupported" PB3400 modem and ethernet routines.  No success so far.

Gettin pretty frustrated about the "simplicity" of getting this setup working.

Steve
0
 
LVL 2

Expert Comment

by:kmrussell
ID: 1542486
What kind of hub are you using? Are you using a router with this hub? If so, what's the brand name?
0
 
LVL 2

Expert Comment

by:squint
ID: 1542487
Have you tried my suggestion?  Do *not* disable any extensions as you try this.  Just plug-in your end of the connector, then try to open the control panel.

If yes, what type of errors do you get?
0
 
LVL 2

Expert Comment

by:kmrussell
ID: 1542488
Trash the tcp/ip prefs by going into hard drive....system....preferences and hold down
"options" key while emtying trash and then restart computer
-reconfigured tcp/ip
0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542489
Thanks for all the suggestions but ... none of the proposed fixes have worked.

I am trying to establish simple file sharing between two Macs with both Macs connected to an Ethernet hub.  I would like to avoid having to install an AppleShare server but ...

A local repair service (working to fix another problem on the PB) connected the PB to their ethernet network and everything worked fine ... so it is not a hardware or software problem.

Before doing any of the following, I trashed the TCP/IP Preferences file and made sure that all the same extensions/control panels that worked for the repair service were in the System Folder (MacOS 8.1)

I am obviously doing something wrong with the TCP/IP ethernet settings so I will try to explain what I am doing and see if anyone can figure out the source of the problem.

TCP/IP Control Panel --
+  created a "new" configuration -- so my PPP doesn't get lost
+  chose "ethernet" and "manual" as the first two items
+  entered 10.50.50.5 as the IP address for the PB
+  entered 255.255.255.0 as the subnet mask
+  entered 10.50.50.0 as the router address
+  entered 10.50.50.10 as the server address
+  entered the domain name we use for Internet access ... though this ethernet won't be connected to the Internet and we won't be using it ... just to make sure the entries are complete.

+  Saved the TCP/IP settings

Control Panel -- AppleTalk
+  Choose Ethernet as the option
+  When it tries to establish the link it errors out with "An error occurred attempting to use Ethernet.  Make sure your connections are correct."  

This is the same error message that I have been receiving consistently since this whole caper started.  It seems that my attempts to set up manual IP addresses does not work when there is no server involved.

Any suggestions, or should I just relent and put an AppleShare Server on my 20th Anniversary Mac and be done with it?
0
 
LVL 3

Expert Comment

by:rickyr
ID: 1542490
Hi...
TCP/IP and IP numbers have nothing whatsoever to do with AppleShare (Unless you are talking about AppleShare IP. So installing server software on your other Mac won't make any difference. It could be because AppleTalk is not active in the chooser.....

For info on how to do this have a look at....
http://info.utas.edu.au/docs/macnugf/connappl.html

regards



0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542491
I understand your comment HOWEVER ....

The Ethernet network is NOT getting set up correctly or working correctly ...

This fact is evident when trying to switch over and actually USE it with AppleShare.

Let's try AGAIN ... and please read the entire thread so I don't have to repeat all the stuff again.

+  The problem is that I have been UNSUCCESSFUL in getting basic Ethernet connectivity between two machines thru an intermediate hub.  Theoretically this is supposed to work but it doesn't seem to based on my settings ... see earlier message of what I have been attempting.  

+  The hub shows NO ACTIVITY from the PB3400 ... even though it is configured EXACTLY the same way as the 20th Anniversary Mac on the other port.

+  I am looking for specific advice on what I am doing wrong with the IP setup ... because that is the basic problem ... but I can't see the error of my ways.

+  The AppleShare errors are a symptom of the problem.

Steve
0
 
LVL 30

Expert Comment

by:weed
ID: 1542492
TCP/IP has NOTHING to do with it...your settings are going to be in the network controll panel,sharing setup controll panel and the chooser...thats IT...secondly make sure something is SHARED on both computers and that both computers have file sharing ON. Computers wont show up on the network if nothing is shared
0
 
LVL 2

Expert Comment

by:squint
ID: 1542493
You have already established that the software configuration is fine, since your friendly repair shop had the PB connected to their network.  No special configuration is required for AppleTalk over Ethernet.

If the repair shop had connected the machine with your cable, then you know you (special) cable is fine as well.

I'll assume that you've tried different ports on the hub, it is most likely fine.

Which leaves... your UTP cable !  The light on the hub not coming on supports this theory.

Have you tried both regular and crossover cables?  I know you mentioned that you've tried two different cables, but are they the same type?  

Take both ends of the UTP cable and hold them in the same direction under a bright light.  A normal patch cable with have an identical arrangement of color wires inside the jack.  A crossover cable will have wire number 1 crossed with 3, and number 2 crossed with 6.  Number 1 being the left most wire, when you are looking directly at the copper side of the jack.  I'm not sure which one you'll need, but your manual will tell you.
0
 

Expert Comment

by:JetDiesel
ID: 1542494
This is just an aside . . .
I'm really fascinated there can be a combination ethernet/modem cable, as modems require a cord similar to phone cords (crossover) and ethernet requires a straight through cord.  Obviously the modem could just ignore the extra pins of the 10-BaseT connector, but does it also switch the inputs?  That seems very odd to me.  If you know any more about this please tell me, I'd appreciate it (or if you'd want points for that info, don't bother, it's more of a curiosity).
0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542495
For Jet -- The Apple connector cable came with the PowerBook 3400/200 and has an RJ-45 connector on one end ... with a black dual plug at the other end (it is about 12" long).  The black connector has an RJ-11 plug with the standard Apple modem icon and a RJ-45 connection with the standard Apple Ethernet icon.  Other than the icons and the Apple logo there are no other markings.  The book that came with the PB says this should work.

I think the internal card (not a PCMCIA card) in the PB is a dual Ethernet/Modem card supplied by Global Village ... though there is no indication with the installed software who actually is the supplier.

The one thing I haven't tried lately is to disable the STF Fax software that I have .. there may be a conflict there that just will never let the Ethernet connection get set up.  Will let you know.

This is a most frustrating problem because it conflicts with EVERY SINGLE bit of information about how easy it is to set up Ethertalk and AppleShare networks.  I am beginning to believe that I need AppleShareIP to make this thing work.

Thanks for your help.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 1

Author Comment

by:SHuntVA
ID: 1542496
FYI -- I have tried directly connecting the RJ-45 Ethernet cable directly into the back of the PB and it doesn't change anything.

I think there is a software incompatibility in here somewhere but I'll be damned if I can find it.  I have reverted to 8.1 only extensions and every other variation that is possible ... no difference.
0
 
LVL 2

Expert Comment

by:squint
ID: 1542497
1.) Networking on the Mac *is* easy.  Proof?  Your repair shop just plugged it in and "everything worked fine" (your words).

2.) AppleShare IP won't help you one bit, you're having a hardware problem.  You already *know* it's not software!!!!  Your repair shop had it working using your software configuration.

I think we are missing a small piece of information here that most of us take for granted.  You mentioned that the PB was connected through the special cable to another UTP cable before connecting to the hub, how are these two cables connected?  Have you tried connecting the special cable directly to the hub?
0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542498
Thanks for your patience squint ...

except that the repair shop had it connected to a server ... not going Mac to Mac thru a hub.

Actually the "special cable" is an adapter that takes the single RJ-45 connection out of the PB and allows you to plug in the hub AND the phone line connection.  I have tried connecting the hub directly to the back of the PB ... with three different "patch" cables (two different mfgs) which should work.  These are the same cables that come out of the comm board on the 20th Anniversary Mac and the hub can see the 20th AM machine ok.

Unfortunately I have been out of the country and swamped so am just about ready to get back into serious trouble shooting on this.  

Thanks again for the patience ... hands-off diagnosis is VERY difficult.

Steve
0
 
LVL 2

Expert Comment

by:squint
ID: 1542499
Your last comment answered some questions from my earlier post.  

If your machine was connected directly to a server at the repair shop, the cable that was used *must* be a "crossover" cable.  If you use the same cable to connect directly to a hub, it will not work.  To confirm this, simply connect the cable to your 20th AM Mac, you should be able to use AppleTalk between the two machines.

Please read my comments about "crossover" cable for more infomation.
0
 
LVL 6

Expert Comment

by:TheHub
ID: 1542500
IP addr must be unique on each machine where the first 3 octets are identical:
mac1 - 109.20.5.1
mac2 - 109.20.5.2

Subnet mask must be identical on each machine:
255.255.255.0

plug the faulty mac into the known good port in the hub using the known good ethernet cable. plug the working mac into a different port. turn on file sharing on both machines. select ethernet @ both the AppleTalk and TCP/IP cdevs. make sure the same version of AppleShare is installed on both machines in the extensions folder.

good luck
0
 
LVL 2

Expert Comment

by:ipierce
ID: 1542501
Well I hope things are going well.  Also make sure to give the machines a network name and to enable file sharing in the File Sharing (or Sharing setup for older OS) control panel.  

I would try downloading MacTCP Ping or a similar utility and try pinging the macs from each other, too.
0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542502
An update

I finally got a chance to try a new crossover cable -- and AppleShare between the two systems came up immediately.  (Ethernet IP settings were already correct and everything worked fine.)

Without changing the extensions, the link through the hub would not work -- changed many different patch cables but nothing worked.

I am now fairly convinced that this "AppleTalk" compatible hub or the PB3400 Ethernet software is NOT compatible with the hub.  There does not appear to be any other explanation.

FYI -- the hub shows a green light from the 20th Anniversary Mac but doesn't show one from the PB3400.  I have tried updating both the 3400 modem and 3400 Ethernet extensions in the unsupported area of Apple.com.  There have been rumors that the PB3400s had widely varied Ethernet errors and perhaps this is just one of the things that never got corrected.

Any other possible ideas before we close out this saga.
0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542503
Mystery solved ....

The Hub turned out to be a 100BaseT ONLY ... and would never recognize the PB (despite the 10/100 Ethernet extension).

Once I got a new Hub that supports 10BaseT ... everything popped up just fine.

I am going to ask the administrator to split points between Squint and The Hub ... thanks for your help.
0
 
LVL 2

Expert Comment

by:squint
ID: 1542504
You mean the 20th Anniversary Mac has built-in 100 BaseT ?

I wan't aware of *any* Macs that have built-in 100BT.

Glad you have it worked out.
0
 
LVL 6

Expert Comment

by:TheHub
ID: 1542505
You have a 10/100 hub. Get a 10baseT hub and try again.
0
 
LVL 1

Author Comment

by:SHuntVA
ID: 1542506
The 20th Anniversary Mac doesn't have a built-in card but I bought the 100BaseT version and plugged it into the PCI connection.

I have asked the managers of this to split the points 100 to "The Hub" and 100 to "squint" for their assistance and patience.

Another perspective .... the FIRST thing anyone should do after changing their IP address or changing their computer name should be to ZAP the PRAM ....

It took a few hours to find that trick because this info gets cached and any changes without updating PRAM seem to cause AppleTalk to go haywire.  Just another lesson learned from this saga .... which is actually MUCH MUCH MUCH more complicated and troublesome on the Windows side of the ledger.
0
 
LVL 7

Accepted Solution

by:
linda101698 earned 200 total points
ID: 1542507
I am posting the solution by SHuntVA so it can be saved in the previously asked questions.

Linda Gardner
Customer Service @ Experts Exchange

The 20th Anniversary Mac doesn't have a built-in card but I bought the
     100BaseT version and plugged it into the PCI connection.

         Another perspective .... the FIRST thing anyone should do after changing
     their IP address or changing their computer name should be to ZAP the
     PRAM ....

     It took a few hours to find that trick because this info gets cached and any
     changes without updating PRAM seem to cause AppleTalk to go
     haywire.  Just another lesson learned from this saga .... which is actually
     MUCH MUCH MUCH more complicated and troublesome on the Windows
     side of the ledger.  
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Suggested Solutions

Troubleshooting Apple Desktops has its challenges just like any component of high technology and innovation. Some hardware issues within Apple Desktops, are fairly simple to resolve and have straight-forward procedures. With other hardware probl…
Apple's line of laptop computers has made significant strides forward in the last few years. The biggest change being the switch to Intel processors in 2005. One thing about Apple hardware, especially that from a few years ago, is the tendency for i…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now