Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 368
  • Last Modified:

Terminal Emulation--Messy Screen--Fix?

In FreeBSD 2.2.5, with TERM cons25 or vt100, the screen
becomes messy when I dial and log in to another FreeBSD
system (or any unix).  "screen" doesn't help. (X-Windows
does, but I'd like to be able to work without X.) What's
wrong here?
0
andrsn
Asked:
andrsn
1 Solution
 
admintcCommented:
Isn't the terminal type for the  FreeBSD console pc? Also, make sure the terminal
 type is set right on the remote system too.
If bash is your shell:  export TERM=pc      (or vt102/cons25/vt100/console)
sh                        TERM=pc; export TERM
csh/tcsh                setenv TERM pc
0
 
braveheartCommented:
If X works fine, remember that you can still define your terminal type as xterm without having to use X. xterm is compatible with a whole variety of proprietary variants too, as well as vt100 (if the screen size is right), so it is a very useful option.

You may have to communicate your screen size to the remote host but this will depend on the UNIX flavour (at the remote host). The usual default is 80x24 or 80x22 characters so if your screen is different, that is probably why things are going wrong. You could try setting shell variables (rows,columns or cols) and similarly named environment variables to appropriate values.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now