Solved

Autologon works only once

Posted on 1998-04-02
8
961 Views
Last Modified: 2013-12-28
I'm running winnt4 with SP3, and the only user
of my machine.
I've done the suggested changes on regedit
'autoadminlogon', set to '1', 'default pswrd.'),
I restart and it works fine... for one single time;
next time I start my machine, it goes back to
asking for a password.
Also, I have tried Tweaky (powertoys), same thing.
What's the way to avoid that annoying request?.
when I installed winnt, I didn't enter any password,
so at that screen I just press 'enter'
0
Comment
Question by:efrain12
  • 2
  • 2
  • 2
  • +2
8 Comments
 
LVL 3

Accepted Solution

by:
biyiadeniran earned 30 total points
ID: 1791603
1. Start Registry Editor (Regedt32.exe) and select the following subkey:
 
   HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion
      \Winlogon
 
2. Select the DontDisplayLastUserName value, and then click String from the
   Edit menu.
 
3. Type 0 in the String Editor dialog box, and then click OK.
 
4. Exit Registry Editor and restart your Windows NT computer.

0
 

Author Comment

by:efrain12
ID: 1791604
Sorry, but it's doing the same  thing.
There was no such a name ('DontDisplayLastUserName'),it had
to create one.
What I have noticed is, winnt by itself changes the value on
'autoadminlogon' from '1' to '0'.
What's wrong with my machine?, why keeps asking me (and
delaying the boot up process) for a password?.
0
 

Expert Comment

by:peacock
ID: 1791605
You MUST have a password in the relevent fields and not leave it blank, set it under the Administrator and then re-type it under Network in TweakUI (or in DefaultPassword in the registry)
0
Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

 

Expert Comment

by:melanson
ID: 1791606
If you must leave the password blank, create a .REG file with the keys you wish to change. Call it AutoLogon.REG and put it in your Winnt directory (or wherever). Create a .CMD file with the following:
@echo off
regedit /s c:\winnt\AutoLogon.REG

Copy the .CMD file to the Startup group under C:\winnt\Profiles\All Users

Be sure that the  HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\DontDisplayLastUserName value is set to 0.


0
 
LVL 3

Expert Comment

by:biyiadeniran
ID: 1791607
Follow this instruction:

WARNING: Using Registry Editor incorrectly can cause serious,
system-wide problems that may require you to reinstall Windows NT to
correct them. Microsoft cannot guarantee that any problems resulting
from the use of Registry Editor can be solved. Use this tool at your
own risk.
 
1. Start REGEDT32.EXE and locate the following Registry subkey:
 
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft
      \Windows NT\CurrentVersion\Winlogon
 
2. Establish your domain name, account name, and password, using the
   values you would normally type when logging on. You should assign
   the following values:
 
      DefaultDomainName
      DefaultUserName
      DefaultPassword
 
   NOTE: The DefaultPassword value may not exist. If it doesn't, from
   the Edit menu, choose Add Value. In the Value Name field, type:
   "DefaultPassword" (without the quotation marks). Select REG_SZ for
   the Data Type. In the String field, type your password. Save your
   changes.
 
   Also, if no DefaultPassword string is specified, Windows NT
   automatically changes the value of the AutoAdminLogon key from 1 (true)
   to 0 (false), thus disabling the AutoAdminLogon feature.
 
3. From the Edit menu, choose Add Value. Enter AutoAdminLogon in the
   Value Name field. Select REG_SZ for the Data Type. Enter 1 in the
   String field. Save your changes.
 
4. Exit REGEDT32.
 
5. Exit Windows NT and turn off your computer.
 
6. Restart your computer and Windows NT. You should be able to logon
   automatically.

Hope it helps
'Biyi
0
 

Author Comment

by:efrain12
ID: 1791608
And, where in the world do you find the data type? (to select
'REG_SZ'),
I clicked everywhere, didn't see any data type options.
Can you please tell me how/where to select it?.
Thanks.
0
 
LVL 6

Expert Comment

by:kapes
ID: 8008750
REG_SZ = string datatype.

If you use REGEDIT, and move on to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft
     \Windows NT\CurrentVersion\Winlogon

Right click in the right pane,
from the popup select NEw > String

type the required values.
0
 
LVL 6

Expert Comment

by:kapes
ID: 12347108
Also if your default password is blank then it will work only once...

You have to set a non-blank password to make it work more than once.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now