Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

Ip address's

I have a network card and a modem, both of which are set up to use TCP/IP. but then I go to check my IP address, It ALWAYS says my net card IP, not internet IP. how can I set it up so the internet IP is reported, not my network IP?
0
KEWL
Asked:
KEWL
1 Solution
 
stotterCommented:
The IP adress is for a machine not a card on the machine.
Go to the Control Panel, Network icon, doubleclick on the TCP/IP icon. There you will get
a screen where need to choose:
"Obtain an IP address automaticaly" (this is used when you dailup to an ISP and his server assigns you with an IP number. Or if you connect trough the network and your server assignes it automaticaly, DHCP in NT serevers for example.)

"Speify an IP adress"  (this is used if your macine has been assigend a permanent address.)

You should consult your system administrator what is the right choice.
0
 
pablocostaCommented:
I think I had same problem and solved it.
IP address is for a card on a machine (just think if you want IP forwarding) not for a machine.
Also the card needs an IP to work on the network, and the DUN adapter wants to obtain a custom IP address given by the ISP server.

Please ask if you want my answer
0
 
david_rCommented:
KEWL, are you running winipcfg?  if so, it gives you a pull down box to switch from your NIC to the PPP adapter
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
KEWLAuthor Commented:
I dont have a fixed IP, and am not planning on getting one. are there any other options?
0
 
JBURGHARDTCommented:
You don't realy need to know your IP Internet address. first of all it is always diffrent and if you know it and you tell it to someone on Internet then this person could bring your computer down.
0
 
dpavusinCommented:
KEWL, what is the problem here. Have you set your network to "Obtain an IP address automaticaly"? If you have, you should automatically obtain IP from your ISP when you connect to net (over dial-up).

Can you explain your problem a bit more detaily? What exactly are you trying to achieve?

At DOS in windows prompt type netstat -n and read your local IP address. See if it is changing dynamically. Please tell us where from are you reading your network card address.

Regards,

Damir
0
 
kmorgan040198Commented:
You should have two instances of TCP/IP loaded--one for your network card and one for your modem.  If you look in the network icon in control panel, you should have drivers loaded for both cards and two copies of TCP/IP.  Each card will need to be bound to its own TCP/IP protocol to get IP addresses for each.  You can set one for a dynamic IP and the other for hard-coded or vice versa.

WINIPCFG will have a drop-down box so that you can choose whichever card (defaults to the active one) and display the IP address for that card.
0
 
kmrussellCommented:
KEWL, try david_r's answer again, he is not saying you have a fixed ip, when you get connected, you check the ip address that was given to you dynamically in "winipcfg" from start...run
0
 
kmrussellCommented:
Hello????
0
 
KEWLAuthor Commented:
Thanx. I worked it out a bout a day before I got this msg anyway, but I'll be nice and grade you
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now