Solved

Device IOS Error when initializing...

Posted on 1998-04-08
22
325 Views
Last Modified: 2013-12-16
A friend of mine has a Compaq Presario with Windows95.  It worked fine until this morning when she turned it on and it wouldn't go past the following error message:
"While initializing device IOS:  Error:  An I/O sysbsystem driver failed to load.  Either a file in the .\iosubsys subdirectory is corrupt, or the system is low on memory"
16Mb of RAM, 1Gb HD, 3.5"FD and a CD-ROM, soundcard and speakers.

Would appreciate an answer.  Have had great success, and fantastic answers from Smeebud on other problems.
Thanks,
doberman
email: serenity@inlink.com
0
Comment
Question by:doberman062797
  • 6
  • 5
  • 5
  • +5
22 Comments
 
LVL 9

Accepted Solution

by:
magigraf earned 200 total points
ID: 1755400
doberman...

Please look into this info+++++++++++++++

SYMPTOMS

When you restart Windows 95 after installing a program or making a configuration change to your computer, you may receive one of the following error messages:

•Windows initializing device IOS: Windows protection error. IOS failed to Initialize, Please restart
•While initializing IOS: Windows protection error. You need to restart your computer.
•Windows initializing device IOS: Windows protection error. You need to restart your computer.

After the error message is displayed, you may not be able to start Windows 95 normally. However, you should be able to start Windows 95 in Safe mode.


RESOLUTION

It may also be possible to start Windows 95 normally after using the following procedure:



1.Boot Windows 95 in Safe mode or to a command prompt.

2.Perform one of the following two steps:

    - Edit the Config.sys and Autoexec.bat files and disable any
      references to Smartdrv.exe. To disable a line, type "rem"
      (without quotation marks) at the beginning of the line.

    - Rename Smartdrv.exe to another name.

3.Restart your computer normally.

Hope this helped
Regards
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1755401
doberman,
Try pressing F8 key at "Starting Windows95" message during bootup.  Select safe mode.  Click My Computer, then right-click on C: drive, select Properties> select Tools> click Check Now button.
When its finished re-boot.
Let me know what happens.
Regards,
Ralph

0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1755402
Sorry Mag,
We posted together!
Ralph

0
 
LVL 9

Expert Comment

by:magigraf
ID: 1755403
No problem Ralph!!
0
 

Author Comment

by:doberman062797
ID: 1755404
To: magigraf and rmarotta,

I had already tried both of the comments you posted.  It won't even let us into Windows95 in Safe Mode.  We can only get to a C:\> prompt.  Windows will not start under any circumstances.

She has a "restore" Windows95 CD, and it says if she uses it all her data files will be erased.  She may have ver.A of Windows, do you think it would be possible to use a regular Win95 (ver.A) CD and perform a "reinstall"???  Of course, like most people she hasn't any backup of her data.  I can find the files for QuikBooks and Quicken, and may be able to copy to floppy, but her files are soooo large it will take more than one floppy for each of her "backup" data files that are located on her harddrive.

Any other suggestions would be a help.  We contacted Compaq and Quantum, and neither company had ever heard of this problem.  Now I know I saw similar references to this error message on Microsoft's Support Site.  Could it really be true these two companies have "gumballs" working for them.  At least I know I can get an answer for something from Experts Exchange, even if it is something I've already tried.  If one of you hasn't heard of the problem before you research it before you comment on something.

Hoping to hear from you with other possibilities.
doberman
serenity@inlink.com

0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1755405
Have you tried to run scandisk from Dos?
Instead of going to safe mode, select Command Prompt at the F8 menu.
Then type:  SCANDISK
Ralph

0
 

Author Comment

by:doberman062797
ID: 1755406
To: rmarotta

Yes, I ran Scandisk from Dos.  Didn't make any difference.  I found some of her QuikBook data files lost in the system, and had it fix those.  Nothing else out of whack.  I have a disk called, "Troubleshooter".  Let it boot to Troubleshooter and ran diagnostics, nothing failed, all tests passed.  I thought maybe the motherboard was causing problems, or the harddrive, but Troubleshooter checked them out and they passed, including the CMOS and BIOS setups were ok when I looked at them.

I am lost in this one.

Thanks,
doberman
serenity@inlink.com
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1755407
Please post your autoexec.bat & config.sys files here.

0
 

Author Comment

by:doberman062797
ID: 1755408
Autoexec.bat   does not exist.
----------------------------------------------------------------
Autoexec.dos   has the following:
if exist c:\firstboo.txt goto exit
copy c:\windows\options\cabs
c:\windows\options\cabs\runsetup /IS /IW /IQ
:exit
----------------------------------------------------------------
Config.sys   has the following:
c:\windows\command\cpqdrv\cpqidecd.sys /D:ided001
files=20
buffers=20
----------------------------------------------------------------
Config.dos   has the following:
rem Microsoft OEM Preload config.sys
rem
rem Copyright (C) 1995 Microsoft Corporation
rem All rights reserved
rem it is up the the OEM user to supply a replacement for this config.sys
rem once they have completed the factory install portions of Windows setup
rem
rem This one overlays the initial config.sys in the root after the
rem factory preconfigurations completed

[common]
files=20
buffers=40
device=c:\windows\himem.sys /testmem:off
dos=high,umb
shell=c:\windows\command.com c:\windows /P
----------------------------------------------------------------
She said all was working until she turned on the system Wed.(4/8/98) morning.

Thanks
doberman
serenity@inlink.com

0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1755409
Magigraf??
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1755410
doberman & rmarotta...

Sorry for the delay, I do not come often to EE as I use to do in the past. Forgive me for that:

O.K.

There is 2 approaches here:

1) To create a new config.sys and autoexec.bat (to trick windows setup)

or

2) To start a corrective install.

Let try the first option:

BEFORE ANYTHING DO THE FOLLOWING AT THE DOS PROMPT

Copy config.sys config.org

This will keep a backup copy of the original config.sys if we ever needed it in the future.

Let's create an autoexec.bat with this line:

SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND

and your config.sys would be:

DEVICE=C:\WINDOWS\HIMEM.SYS
c:\windows\command\cpqdrv\cpqidecd.sys /D:ided001

JUST CUT AND PASTE THEM.

If this does not help, I want you to do the following:

1) Boot to DOS (I guess this is the only option you have :-(  
2) Go to windows directory and type
    dir/p

I want you to tell me what are the date on most of the files.

• if they are 24/8/96  you've got OSR2 the second release.
• if they are 24/8/95  you've got the first release.

I will post steps right after your feedback!!
Regards
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:doberman062797
ID: 1755411
To:  magigraf
Tried what you recommended for Config.sys and Autoexec.bat.  Still got the same Error message when it tried to start Windows.

Looked and the windows directory and the majority of her dates are 1995 (8/20/95, 7/11/95, etc.)   Just a couple 1996 dates, and whatever else they put in themselves.

She said her husband had been on the system the night before, teaching himself Windows 95 with a workbook he had.  He told her he couldn't remember exactly what files he moved around, but he was practicing "drag and drop".  She wonders if he may have moved these important files and now nobody knows where they are.  He did say he also did "drag and drop" to the recycle bin.  OOOOOHHHHH!!!!!   Sometimes people are "scarey" when it comes to their computers...

Waiting to hear from you,
doberman
serenity@inlink.com
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1755412
doberman...

That's fine!!

What I need to find out from you is the following:

1) If the installation disks for windows95 are on floppies or CD-Rom version??
2) If they are on CD-Rom (proceed with step 3...)
3) We need to find out the command line entry for her CD-Rom in the autoexec.bat
--Without that line entry we cannot make the CD-Rom drive available in DOS to run that corrective install I want.

I know that compaq leaves the drivers on the hard drive, could you try to locate them??
Or try to locate an old copy of autoexec.bat and copy that line.

it should look something like that: (not exactly since her's another make of Cd-Rom drive)

C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD001 /M:8 /V
** just to get the idea O.K.??

Search for all autoexec files by typing the following at a Dos prompt.

dir auto*.*
followed by enter.

Please post results.

I will take it from there
Regards
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1755413
Doberman, do you have anyone around you with a copy of Norton utilities that you can borrow the unerase disk from and possibly recover the files sent to the recycle bin?
Dennis
0
 
LVL 1

Expert Comment

by:shawnd
ID: 1755414
Hey...
Doberman.. check if there is a copy of 95 already on the hard disk...

Go to windows\options\cabs directory and see if the setup is there. If so run it and be weary of the files it asks you to replace/keep during the installlation..

Good Luck.

Shawn

0
 
LVL 9

Expert Comment

by:magigraf
ID: 1755415
doberman...

Just a quick note before you attempt to run that Re-install as suggested by Shawn.
If you find these disks you should run the corrective install after we really fail to restore the missing files.

Now you have more than an option here, the fastest and less heache would be to run from the DOS Prompt that setup as follow:

setup /p f

Here are the switches in details:
++++++++++++++++++++++++++++++++++++++++++++++++++

Reinstall win95 from the command prompt using (setup /p f ) command.
This setup switches will clean your system files and replace missing and damaged files, keeping all your apps and updated drivers.

The switch  f

Means a Clean Registry mode. It forces Detection to clean the root branch of the registry before starting. It will also remove commands that are pointing to the wrong locations including Win 95 files.

The switch  /p

The string can contain one or more detection switches separated by a semicolon (;). For example, if you want to use  /p f

The switch /d

This switch can be used if you do not want Setup to use your existing configuration (like Win.ini and System.ini files).

To restore or adjust your windows installation:
 
 From dos insert your CD type this command... at your CD-ROM drive letter
" setup /d /p f "  Without quotes

You would want at that stage to choose from  "Full or Custom Setup", choose Custom. This will give you more control through a step by step of the setup.

This should set back all entries in place and restore all functions as before the problem occured.

++++++++++++++++++++++++++++++++++++++++

Hope this helped
Regards
0
 

Author Comment

by:doberman062797
ID: 1755416
To: Magigraf, and all those who had plenty of suggestions.  

Lynne received the disks from Compaq today, all those that didn't come with the system when she purchased it.  I installed the drivers for the CD-ROM and then used a Windows 95 ver.A CD to reinstall the appropriate necessary files to get windows started.  I finally got into Windows and the first place we looked was the Recycle Bin to see if her husband had put anything in.  Sure enough, ALL the Windows System and IOSystem files were in the recycle bin.  Autoexec.bat and Config.sys as well.

She told her husband she was "burning" the book he was using to teach himself Windows 95.  In his practicing "drag and drop" he DID put all the system info into the Recycle Bin.  I mentioned that possibility briefly in one of my comments, but really didn't think someone would do that.

I hope this hasn't been too much of a headache for you all.  Once again, thank you for all the suggestions, it's nice to have "more than one head" thinking on the problem.

doberman   aka  Frann
serenity@inlink.com
0
 
LVL 9

Expert Comment

by:magigraf
ID: 1755417
doberman...

Thanks for the update, keep those switches handy for future references.
All the best
Regards
0
 

Expert Comment

by:linker01
ID: 1755418
Found this problem not necessarily exclusive to particular machine or software, but usually occurrs upon reboot from new software or hardware installation. MS indicates this is a problem with Win/95 Rel 1, 2,and 2.1. MS says if  IE 4.0 is installed problem does not occurr. I had to rename RMM.PDR to RMM.OLD in the windows\system\iosubsys directory and OS booted OK but did not " re-create " the file as I expected. I did find several prople who had the problem were using Toshiba Tecra 5XX model laptops. THe software my customer was installing was a "Travelers Insurance" company provided analytical software package.
0
 

Expert Comment

by:linker01
ID: 1755419
Append to previous message.. After I got the system back up and running I did install I/E 4.0 and the RMM.PDR file was infact rebuilt during the process. System seems to be functioning fine now..
0
 

Expert Comment

by:martin_huizing
ID: 1755420
Remove "USB support for OSR-2" at "Add/Remove Programs" in your Control Panel.

You can re-install USB support when going to:
www.windrivers.com

Martin Huizing
Compaq TSR
martin.huizing@compaq.com
0
 

Expert Comment

by:thirtysomething8
ID: 1755421
This problem has occurred on several Toshiba laptops that were in the Docked mode. The latest incident occurred when the user installed Visual Basic 4.0. Undocking the laptop, booting in safe mode, removing the floppy drive controller and the PC card devices,and reinstalling IE 4.0 seemed to work.
0

Featured Post

Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

Join & Write a Comment

This is an article about Leadership and accepting and adapting to new challenges. It focuses mostly on upgrading to Windows 10.
A Bare Metal Image backup allows for the restore of an entire system to a similar or dissimilar hardware. They are highly useful for migrations and disaster recovery. Bare Metal Image backups support Full and Incremental backups. Differential backup…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now