Solved

Does Anyone Here own Installshield Product

Posted on 1998-04-08
20
915 Views
Last Modified: 2013-11-14
I've posted this in many newsgroups. Please know this is not just Netscape communicator related.

Hello Programmers,
1st I'm not a programmer so if you reply please know if you speak
"programmese", I'll probably not understand.
I troubleshoot at www.experts-exchange.com, a Q@A site. We have been
seeing a lot of problems lately with
installations [THE DECOMPRESSION OF %S FAILED] using "Installshield".
It's hard for me to think that after reading and trying most of the
solutions recommended; most are changing the 'temp' and or "tmp", i.e;
SET TEMP=C:\TMP and variations of that, along with very good
optimization of the questioners system, including:
-------
1. Turn off CD-ROM caching.

2. Make approximately 45 MB of hard drive space available at
minimum, as Installshield (depending on the parameters set by
the software writer) will look at the minimum set when the
file(s) are compressed. This makes room for the program files
(38 MB base parameter) and extra working space for cleanup if
that parameter has been chosen. Compressed drives only estimate
the amount of free space available and may need even more than
the amount being reported as available (Installshield parameter
minimum as against acutal free space plus cleanup). If this has
been left at default values in Installshield, a program with
15MB of files could be calling for 40MB plus another 40MB for
cleanup)

3. Free up memory. Installshield requires 8 MB of physical RAM,
with approximately 5,500k free.

NOTE: In addition to the foregoing, if QEMM or Stacker are
running in the background, the probability of failure increases
progressively in a linear fashion, eg: the lower the amount of
installed ram, the higher the probability of a failure.

We still are not solving this.
I'm beginning to think it's more hardware related that software or
envirernment setting.
The [THE DECOMPRESSION OF %S FAILED] is mostly with Netscape
Communicator, however, if a person has trouble
with that he or she also has the identical problem with ALL other
DECOMPRESSION installations.
Can anyone help me understand why, [other than a corrupted file], this
occurs and hopefully how to fix it.
A lot of people now simply can't install programs.

NOTE: In all cases the questioner reports a certain % where the istallation fails. This varies,
i.e.; 38% then fails, or 78% then fails.

Please refere to http://www.experts-exchange.com/Q.10046601
for related conversation.

Regards,
Bud
0
Comment
Question by:smeebud
  • 8
  • 7
  • 2
  • +3
20 Comments
 
LVL 6

Expert Comment

by:clifABB
Comment Utility
I know it's not much of an answer, but have you contacted InstallShield and/or Netscape tech support? (I'd try the former first)

The line "THE DECOMPRESSION OF %S FAILED" sounds like part of a C language printf statement where '%S' is supposed to be replaced with some text which, for some reason, is not.

If you can get ahold of a good tech support person and give them that line, perhaps they can pass it to a programmer who can figure out what would cause the error.
0
 
LVL 14

Author Comment

by:smeebud
Comment Utility
Wow,
I 1st posted in the C Language area, and was told it was a Visual Basic call???

Thanks.
Bud
0
 
LVL 8

Expert Comment

by:Kobe_Lenjou
Comment Utility
I got the errror myself lately, I just cleared out my /temp and al was OK (I'm on an NT4 server)
0
 
LVL 3

Expert Comment

by:byang
Comment Utility
I've used InstallShield and another install package called WISE, I think basicly there're 2 scenarios for your problems:

1. out of disk space.
2. if you're installing from a CD, the CD is bad. Try it on another CD drive (different brand).
0
 
LVL 39

Expert Comment

by:abel
Comment Utility
Bud,
The times installation failed, have you tried copying the CD to the HD and installing from there? I've had troubles lots of times due to driver failures, which didn't occur when copying to the HD.
Searching DejaNews and some other sites gave several solutions. Maybe you've already tried them, but in a nutshell, here they are (I quote):

From http://help.netscape.com/kb/client/970619-7.html
"In addition and in some cases, the video driver may have caused a problem during initial stages of setup. You may want to switch to VGA video driver for the duration of setup."

"I suddenly started encountering this problem as well.....I then found out that this was happening because of some device driver that was installed...what I suggest is that you identify what you installed recently...then uninstall that and try the self extracting file again...no luck, then try uninstalling another software that you installed...in my case it was ZipFolders that was the culprit!"

"This error is very common in WINOS/2 when the partitions are HPFS because the Win API is not capable for determine the amount of free space available in large partitions (>2Gb). In old Win (Fat16) applications is possible a similar behavior with FAT32." (if this is the case, I don't know of any solution...)

And from http://207.50.16.140/jgarcia/ufaq/navcom/noinstal.html:
"Search the hard disc for uninst*.exe; if you find files that fit, make sure they are not Read-Only."

Some other documentation stated that it could be due to driver failure and/or hardware failure. Try the "copying to HD" I first stated, or try to install in "Save Mode".
If I understood you correctly, there was enough room on your HD and the TMP and TEMP settings were correct and the TMP/TEMP directories are empty when starting the installation.

Hope some of these options apply to your problem,

Regards, Abel
0
 
LVL 6

Expert Comment

by:clifABB
Comment Utility
It certainly is NOT a Visual Basic call.  We don't use anything that even remotely looks like that (the '%s', I mean).

Apparently, from the last two postings it seems your problem is drive space (or lack there of).
0
 
LVL 39

Expert Comment

by:abel
Comment Utility
BTW, I have InstallShield 5 Free Edition which comes with Visual Studio. In the documentation supplied with it, there's no mention of this error.
BTW2, you'll have to excuse me, but I'm going on holiday. If you want any reply from me to a reply of you, it'll be in about 10 days....
0
 
LVL 14

Author Comment

by:smeebud
Comment Utility
Hello all,
Well, 1st Abel. All you information is good. But I already had that documented.

2nd, I looked at my question and realized I left out a important part.
I said, "The [THE DECOMPRESSION OF %S FAILED] is mostly with Netscape     Communicator, however, if a person has trouble  with that he or she also has the identical problem with ALL other  DECOMPRESSION installations. Can anyone help me understand why, [other than a corrupted file], this occurs and hopefully how to fix it.
A lot of people now simply can't install programs.".

What I left out was that the  [THE DECOMPRESSION OF %S FAILED] message occures with netscape. Other installation will not flash the [THE DECOMPRESSION OF %S FAILED], but rather asorted other messages, or simply lockup the systems.

I have not seen and error of that nature yet when installing from a CD.

Is what everyone telling me that the [THE DECOMPRESSION OF %S FAILED] message
is not from installshield??

Bud
0
 
LVL 6

Expert Comment

by:clifABB
Comment Utility
Yes, it IS from InstallShield.  Extstub.exe contains that message.
0
 
LVL 6

Expert Comment

by:clifABB
Comment Utility
A bit more on extstub.exe.  It's used in self extracting setups (single file installs and, I believe, install from web).

There is no delimiter between these two lines in the executable, so they are probably related:
The decompression of %s failed. There may not be enough free disk space available in the TEMP directory.

I would be willing to bet that you don't have enough space in your TEMP directory (or your TEMP directory doesn't exists) and InstallShield is having a failure in displaying the error.

Make sure you have enough space in temp (both Windows\temp and \temp)

0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 14

Author Comment

by:smeebud
Comment Utility
Clif,
Adide from creating a permenent swapfile, 80mg, and a having gobs of mgs left on the HDD, how would I allocate Space to a temp file.

Temp directories exist, Veriations do to different systems, but I always have them;
----
Try, in this order:
Search the hard disc for uninst*.exe; if you find files that fit, make sure
they are not Read-Only.
Create the directory C:\Temp and add to autoexec.bat the lines

SET TEMP=C:\Temp
SET TMP=C:\Temp

and reboot. (Optional - also create c:\tmp and use SET TMP=C:\tmp)
Before and after, delete any files in C:\Temp and \Windows\Temp.

[UNLESS YOU DO HAVE BAD RAM]
It has noting to do with RAM.  I have found out that if you change the
location of the TEMP directory, it takes care of this error in some cases.
Just edit your autoexec.bat file and change the line:
SET TEMP[SOMEPATH]
to point to another location.

THIS IS THE ONLY LINE I USE
SET TEMP=C:\TMP

Bud
0
 
LVL 6

Expert Comment

by:clifABB
Comment Utility
You don't allocate space to a temp directory, you just make sure that the drive which contains your temp directory has enough space.

If you're running on NT or 95, setting your Temp environment in autoexec.bat shouldn't have any effect.  This value is in the registry. (\HKEY_CURRENT_USER\Environment)

InstallShield may, or may not, use the temp directory the os wants it to use.  Possibly it creates it's own temp directory on the fly (as pkzip does).  In this case, the temp directory would be on the drive that's running the install.

But at the very least, I have found for you the fact that your error message exists in InstallShield (rather than Netscape).
0
 
LVL 14

Author Comment

by:smeebud
Comment Utility
Ok
At last some progress. The only "Environment" I have is in
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\Print\Environments.
Which to me is better as it does not get re-written as does HKEY_CURRENT_USER.

Can I get you to do two things before I grade.
1. Tell me where to read about "extstub.exe"
2. Write InstallShield asking the question I asked. I wrote them but not having any of thier products, they said they would not answer.

Thanks for your efforts. This has been driving me crazy.

Bud
0
 
LVL 6

Expert Comment

by:clifABB
Comment Utility
Good news, bad news...

Good news:
I can do the second thing you ask.
1. I don't know where you can "read" about extstub.exe.  The information I got was from looking at the hex code using an app called FileView.  You would be surprised at what doesn't get compiled!

Bad news:
Four day weekend.  I won't be able to call InstallShield until Tuesday.

I will post an answer as information I get from InstallShield.

If another expert can call InstallShield before I can get to it, then let them answer.
0
 
LVL 14

Author Comment

by:smeebud
Comment Utility
Ok, clif.
I think you're on the train of thought I'm on so if you want to answer this go ahead.
i can wait for the installshield feedback.

I Don't think you have to call. They answer thier tech mail pretty fast.

Regards
Bud
0
 
LVL 6

Accepted Solution

by:
clifABB earned 200 total points
Comment Utility
Ok, smeebud.  Installshield verified that it was indeed their error message.  What I got from them was a stock answer about making sure the temp directory existed.  

I told them it did then they said to make sure I had enough space available.  I told then I had tonnes.  They said Windows limits the size of the TEMP directory and it may be full even though I have ample free space available on your hard disk.

I told them I'd check that part out, but to limit call backs, was there anything else.  They said that occasionally there was a conflict with the video drivers and I might switch to standard VGA (or boot in safe mode).  I said "Thanks a lot" as sarcastically as I could (I didn't really but would have liked to).  And that was it.

I'm going to submit this as an answer, but I'm an honorable sort.  If this doesn't do it, you should reject the answer.

I'm sorry I could do more.
0
 
LVL 14

Author Comment

by:smeebud
Comment Utility
Clif,
That's what I needed to know. you did what i asked as I could not get feedback from them.
I don't believe them when they say that temp's have limits, as you said above.
You've done a fine job and I thank you.

If you can find out per your statement, "InstallShield may, or may not, use the temp directory the os wants it to use.  Possibly it creates it's own temp directory on the fly (as pkzip does).  In this case, the temp directory would be on the drive that's running the install."
That InstallShield uses it's own temp directory, that would be helpful.

Regards,
Bud

0
 

Expert Comment

by:cmoore23
Comment Utility
I think I have a solution/explanation.

When the decompression occurs the files are written to a tempory directory (probably c:\temp or c:\windows\temp).  This much is known already.

If ANY file being decompressed already exists in this tempory directory it will be overwritten UNLESS IT IS READONLY.  Ie. if there is already a setup.exe which is read-only, the decompression will fail.  So the % completed will vary depending on which file already exists as read-only.  If it is setup.exe then it fails VERY quickly, whereas if it is a dll that it gets to later then the %completed will be higher of course.

I found out a) from everyone elses suggestions re UNINST*.EXE, and b) because my 'client' had a SETUP.EXE pre-loaded from a CD-ROM (which of course copies as READONLY).

Solution is CLEAR OUT all temp directories before decompressing, however the problem lies with InstallShield's decompression and should really be tackled there by them.

Regards
Chris.

0
 
LVL 14

Author Comment

by:smeebud
Comment Utility
Thanks Cmoore,
I'll add thatto my database.

regards
Bud
0
 
LVL 14

Author Comment

by:smeebud
Comment Utility
Please see:
http://www.experts-exchange.com/Q.10042082

a typical example.

Bud
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

One of the most frequently asked questions on EE in the "Windows Installer" zone is how to eliminate self-triggered installation of some product.  The problem occurs when, suddenly, whenever a certain application is launched, or even when a folder i…
Have you ever wanted to restrict the users input in a textbox to numbers, and while doing that make sure that they can't 'cheat' by pasting in non-numeric text? Of course you can do that with code you write yourself but it's tedious and error-prone …
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
Get people started with the utilization of class modules. Class modules can be a powerful tool in Microsoft Access. They allow you to create self-contained objects that encapsulate functionality. They can easily hide the complexity of a process from…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now