Solved

Multi Function Machine

Posted on 1998-04-09
40
283 Views
Last Modified: 2012-08-14
I have a Panasonic Multi Function Fax/Scanner.  When I try to load it, my PC can not find it as new hardware.  After I load the software, when I try to use it I get error messages "Device already in use" or Cannot communicate with comp 2 or cannot communicate.  How do I configure my PC to run the Multi Function Fax/Scanner.  I tried everything.  I am using the  correct cable. I used to hav two modems, 1-original modem on comp-1 and I removed a second modem from comp-2 which I installed and was working correct.
0
Comment
Question by:kaneohe
  • 18
  • 16
  • 5
  • +1
40 Comments
 
LVL 17

Expert Comment

by:mikecr
ID: 1134110
You need to set your parallel port in CMOS to bi-directional or ECP/EPP and it should work for you? If you need help on that let me know.

Mike
0
 

Author Comment

by:kaneohe
ID: 1134111
I am unable to utilize my multi function Fax/scznner.  When loading the software my PC can't find my fax machine ( Panasonic KX-FM220).  After loading software anyway, when I try to use my scanner my PC give me messages that it cannot communicate with comp port annd /or cannot open facsimile at this time, device already in use.  I got a response from mikecr, however, I'm not sure if I did it rigth, and I f I did, it still didn't work.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134112
Was the modem that was attached to COM2 an External Modem?
What brand was the modem?
Are you using the same cable you used to connect the modem to your computer? (assuming that you did, in fact have an external modem).
If it is the same cable, you could be having a problem there.
--Some external modems require a null-modem cable.

If it was an internal, we'll be in for some troubleshooting...
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1134113
kaneohe,
Are you running Windows95?
If so, are the COM2 resources listed in Device Manager correctly without conflicts? (port address 02F8, IRQ 3)
If not, what is your operating system?
Regards,
Ralph

0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1134114
kaneohe,
We need some feedback from you.
To save time, it will be helpful to know more about your computer.  Please list the components of your system that may apply.
(Motherboard, CPU, RAM, Hard Drive(s), CD-ROM, Soundcard, etc.)


0
 

Author Comment

by:kaneohe
ID: 1134115
It was an external modem that I took out.  There is no conflict in comp 2.  I have an Packard Bell D130 133 mhz, 16ram
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1134116
Are you using Windows95, and if so, is the software for your combo machine to be used with win95?
Ralph

0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134117
What bios revision do you have
0
 

Author Comment

by:kaneohe
ID: 1134118
My fax is works on win 95.

I don't know what ou mean by bios revision?
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134119
when you boot up your computer, it will say "press f1 to enter setup..."
while it is displaying that message, look in that area of the screen for anything that says
"ver 3.00.012.DN0R" or any other number
It will be in the upper left hand of the screen.

Did your fax machine come with software?  What is it called (the software).
0
 

Author Comment

by:kaneohe
ID: 1134120
The installation disk are called Multi-Function Center version 1.0 for Windows.  On it states installation for windows 95
0
 

Author Comment

by:kaneohe
ID: 1134121
When I reboot my PC it reads

bios 1.00.05. Dnor
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1134122
While in windows go to device manager and remove the listed com2 port.  Also remove any modems that may be listed as using com2.  Shut down and reboot.  Windows should then detect the com port and re-install it correctly when it loads.
Let me know what happens and tell me if you need step-by-step directions on how to do this.
Ralph

0
 
LVL 15

Accepted Solution

by:
jrhelgeson earned 100 total points
ID: 1134123
Hang on, my friend

First off,  You have the Packard Bell Orlando PB680 Motherboard that is having a problem that needs to be dealt with first off.  Your motherboard has an internal serial header that is not even in use, and cannot be used anyway.  Even though it is not in use, windows still tries to allocate resources for it, and this will make life dificult.

First off, what you will need to do is to download the bios update from Pakcard Bell, it will upgrade your BIOS from 1.00.05 DN0R to version 1.00.12 DN0R (7 full upgrades later).
This file is located at the following address:

ftp://ftp.packardbell.com/pub/bios/14262403.exe

You will need to have a blank floppy ready in order to flash the bios.

Once the file is downloaded, execute it, and it should create a boot disk for you to use to flash your bios.  Follow the instructions very carefully, and once that the BIOS is updated, we should have very little problems setting up the rest of your equipment.

Once this task is completed, please reject this answer.

Thank You.

Joel R. Helgeson
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1134124
Joel,
I don't disagree with the upgrade.  Seven revisions probably take care of a lot of grief!  
But if he previously had a modem successfully installed on COM2, why should this be a problem to install?
Ralph

0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134125
We are a PB authorized repair facility *(one of our "less advertised" achievements).
The comm ports do some extremely wierd stuff on the old BIOS rev. that makes it work reeeel funky.  It would work sometimes, and not others.

In fact, I'm suprised he even got the external COMM port to work...

Let's just let him install the update, then we should be able to get him squared away..

JR
0
 

Author Comment

by:kaneohe
ID: 1134126
I did what you told me bios upgrade.  Everything went wll, When I reboot with disk, my screen ended in dos mode a: w/flashing cursor.  I got stuck so I rebooted my PC again.  While rebooting I did not see any change on my screen concerning bios, it still stated 1.00.05.

I then removed comp 2 and reinstalled it and tryed to run my fax, still can.  Message : Unable to open selected facimile communication port com 2
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134127
Did it give you instructions on what to do after you rebooted, -- How to update the bios?
0
 

Author Comment

by:kaneohe
ID: 1134128
NO. It just told me to reboot my computer.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134129
I see...

It did not properly configure your boot disk,  simple fix.

Place the disk containing the bios files into your floppy drive.
While in windows, go to a command prompt-- (Start|Programs|MS - Dos Prompt)..
Once there, type:
SYS A:

This will make the disk bootable, and should enable you to then re-program the BIOS.

IF NOT--

If your computer continues to boot, without updating the bios you will need to do the following.

When the computer is booting up, press the F8 key the second you see the "Starting Windows 95..." statement, or the blue startup banner.  This should take you to a "startup menu", choose option #7, Safe mode command prompt only.

Once at the dos prompt, change to your a: drive and type the word "autoexec" and press enter.
That should take you into the bios flash utility.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:kaneohe
ID: 1134130
Aloha, it's me again.  I tried the first option and it told me that the system was transfered. However, when rebooting, there is no change on my screen concerning the bios, still reads the same.  So I tried option 2, and when I type in autoexec, it tells me bad command.  

Thank you for helping me so far and please don't give up.  I need your help.
Mahalo  (Thank you)
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134131
Give up?  Never!

What files did it place on your floppy?

You should have these files:

1012DN0R.BI1
1012DN0R.BI2
1012DN0R.BI3
1012DN0R.BIO
1012DN0R.RCV
AUTOEXEC.BAT
BEEP.COM
BIOSDN0.RE1
BIOSDN0.RE2
BIOSDN0.RE3
BIOSDN0.REC
IFLASH.EXE
LOADREC.EXE

Plus maybee some others.

COMMAND.COM
IO.SYS
MSDOS.SYS

Do you have these files?

Also, give me your e-mail address.  I could give you an "updated" flash bios program.

Joel
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134132
Or, we could go about it this way...

From out at the dos prompt, go to the a: then type the following commands

a:
beep
iflash

{press enter}
{select "Update Flash Memory Area From File" (third option)}
(select "Update System Bios"}
{Press the down arrow and select "10012dn0r"}
{select "continue with programming"}

Then it will start programming the bios.

Once it is finished, it may prompt you, then the computer will re-boot itself.
After it has rebooted, Press F1 to enter into the setup utility...

{go to ADVANCED}
{Peripheral Configuration}

Serial Port 1 Interface should say "DISABLED" and be *greyed out*. (if not, change it)
Serial Port 2 Interface should be set to "LPT2, 2F8 IRQ 4" or "AUTO CONFIG" (if not, change it)
Serial Port IR Mode should be "DISABLED" (if not, change it)

{press escape}
{go to exit}
{select exit, saving changes}

Then your computer will re-boot again.  Be sure to remove the floppy from the drive.
Notice the bios version now.....

Now let's try your software!
0
 

Author Comment

by:kaneohe
ID: 1134133
Thanks for not giving up.  My email is hi96744k@gte.net

I won't do anything until I here from you again
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134134
Actually,
Try the steps I gave you in my last comment, that will be easier than trying to automate the process from here...

Have Fun!
0
 

Author Comment

by:kaneohe
ID: 1134135
When hit enter after the beep it's ok, however, when I hit enter after iflash, a message comes up that says, this program will not run under virtual-86 mode, and then it goes right back to the flashing cursor
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134136
That message means you are either (a) still in windows, or (b) have your memory manager loaded.

did you press the {f8 key} to get to the *startup menu*?
You need to be at the "safe mode command prompt only"

or- you could also do this,

go to the windows directory, (while in dos) and rename your himem.sys driver by typing
REN HIMEM.SYS HIMEM

Then re-boot your computer, it will not go into windows because it cannot find the memory manager because we re-named it.

after the bios is flashed, go back to the windows directory and rename the file back by typing:
REN HIMEM HIMEM.SYS

Then your computer should let you boot up normally.

0
 

Author Comment

by:kaneohe
ID: 1134137
I tried flashing again this time in safe mode and it worked.  When I reboot it shows 10012dnOr.  Two things:
My fax/scanner had no chaane, it still doesn't work.
The other thing is it appears that my internet runs slower and I have a hard time connecting to certain sites.
0
 

Author Comment

by:kaneohe
ID: 1134138
I am also having trouble receiving mail.  I think windows is not recog=gnizing the himem.

I don't know if you are receing this message and  I don't know if you will be able to send me any messages
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134139
If you are having that serious of problems, you may need to re-install windows because you should not be having this type of problems at all!
If you had a problem with your HIMEM.SYS, you would not be able to get into windows at all.
A bios update never causes problems like this, unless it takes a problem you're allready having, and makes it more visible.

Try re-installing windows at this point.
0
 

Author Comment

by:kaneohe
ID: 1134140
I reinstalled windows and I still am having problems.  When I check my mail I can not establish a connection.  When I click to go to web sites I get messages that can not establish connections.  I then restored my computer (Dummy, I still have the same problems, only now I don't have office 97.  My brother loaded it up for me awhile ago, and now I lost everything.  I tryed ren himem.sys himem but that doesn't work. when I retored my PC, I was hoping that would restore my bios back to the original setting 100.05, but that did,nt work.  I hope you can read this message becuase now I,m in worst shape then I ever 'was.
0
 

Author Comment

by:kaneohe
ID: 1134141
what could cause my mail to give me problem like I have, unable to establish connection?
0
 

Author Comment

by:kaneohe
ID: 1134142
I may not be able to open my mail to read your response, but I migth be able to read it from this site.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134143
it would be in the dial-up networking connection, or your tcp/ip settings.

Call your ISP for assistance in that area, like I said you should *not* be having these problems as a result of the BIOS update!

0
 

Author Comment

by:kaneohe
ID: 1134144
I'm back!! After you told me that the bios has nothing to do with the internet, I looked into the systems and found that some kind of error in the network adapter.  I again report my PC and I no longer have problems with the internet or my email.

I did'nt try running the Fax/scanner yet, but I will soon, and I will let you know what happens.  Thanks for all your help. By the way, would you know of a site that someone can get an evaluation download of microsoft office 97  (looking for MSWORD)?
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134145
Let me know!
0
 

Author Comment

by:kaneohe
ID: 1134146
It works, thank you very much.  He sure put alot of hard work into helping me with my problem.  He never gave up on me and continued even things got bad.  He sure is an asset to anyone who needs help with thier PC or anyother equipment.  That you and the expert-exchange.

Aloha and Mahalo from Hawaii
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134147
I am glad I could help you, and glad we could get your computer working properly!

I appreciate your compliments, and if there's anything else I can do just let me know.

Joel R. Helgeson
President & CEO
Corporate Computer Solutions, Inc.
On-Site · Only, Inc.
0
 

Author Comment

by:kaneohe
ID: 1134148
Joel,  What is yor email address?  Or do I reach you thru the experts-exchange address?

Thank You again.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 1134149
You can place a question out in the Experts Exchange, and place my name in the question line.  That usually works well.

I am allways hanging out in the printers area.  (my personal area of expertice, in case you did not notice).

8o)
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Upper back Pain: My back hurt for months. Upper back, mostly my neck, spine and across my shoulder blades. I was getting headaches too, that felt like they were caused by tension in my shoulders, but now I feel fine! I'm sharing this hoping someone…
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
This video discusses moving either the default database or any database to a new volume.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now