IRQ Conflict

I have a WIN95OSR2 IRQ conflict between the S3Trio64V2(DX/GX)Display Adapter and the IRQ Holder for PCI Streaming (whatever this is).  Settings will not allow me to change the S3Trio IRQ from 9.  I want to find out how to change the other from IRQ 9 to resolve this problem.  I refresh but they conflict upon boot-up.
DennyctAsked:
Who is Participating?
 
jrhelgesonConnect With a Mentor Commented:
The answer is in your BIOS configuration.

Enter into your bios, (generally by pressing F1, or DELete on most systems) and look at the chipset configuration.

Disable the Automatic Configuration, then change the order of IRQ selection, or disable the IRQ from the PCI IRQ selection list.  All IRQ's on the selection list are reserved for use by PCI Steering...by the bios.

If you get me the motherboard make & model, and the bios type (ami, award, phoenix, etc) then I could give you more accurate info if this doesn't help you resolve it completely.

Also,  there could be a BIOS update available for your PC that will take care of problems like these,  I'll be able to check once you obtain the info above.

Next, I would go to www.bmdrivers.com and get the latest & greatest bus mastering, and PCI Bridge drivers available.

jrhelgeson
0
 
busukaCommented:
Maybe you meant PCI steering ? Anyway, you can disable IRQ for Video Card. Several
ATI cards has jumper on it. Check your card for this jumper (if exist at all).
Take latest driver: http://www.s3.com/bbs/775drv/w9524107.zip
Best solution that I can bring in this moment is:
Strip your system to bare minimum: pull out all cards, sound, modem. Just leave S3 card,
then reboot and check if Win95 still has conflict. If no conflict, insert cards one-by-one,
every time check if conflict arise. If all cards you have PnP then good chance that you'll
get rid of conflict with small blood ;))) If no, notice which card gave you headache.
Also several BIOSes can have setting: allocate IRQ for video. This can be in Integrated
Peripherals section.
0
 
aquarCommented:
The PCI adapter is select the icq with the MOTHERBOARD.
Most of them are PNP by motherboard.
The method of mine is use the F8 option in the bootup period and
selete the 4 option is SAVE MODE.
In the save mode. Delete the video card and IRQ Holder for PCI Streaming  and any thing you think it may lead to the irq conflict.
Then restart it may the win95 recheck the pnp setup .
Maybe will solve it.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
aquarCommented:
jrhelgeson
your answer very alike mine
0
 
DennyctAuthor Commented:
I have a Green 586 board with American Megatrends (1994) AMIBIOS.  The only place I found to change the IRQ numbers are in the Chipser Setup.  Under it there are PCI Slots 1 through 3.  They are set to auto configuration.  I have one IRQ open and that is 5.  Should I substitute it one at a time in the three slots to see if this fixes the problem?
0
 
DennyctAuthor Commented:
I went into my AMI Bios and tinkered with the settings. There are 3 slots for changing the IRQ value.  After changing the first to five, nothing happened.  I then switched it back to Auto, and changed the second slot to 5.  Upon bootup, the Plug&Play discovered a new device (IRQ Steering).  I went into my systems file and found it there with a IRQ of 5.  It also reconfigured the S3 Display Adapter to five also.  Still a conflict.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.