MP3 and Linux (RH5.0)

(I have a Sound Blaster 16 PnP "Authentic")  Does anyone know of a way to get mp3 files to play under Linux? I downloaded a player, and tried to install it, but compilation failed, because it couldn't find mpeg.h, or some special mpeg header with a similar name.  The sound works otherwise.
anavrinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TalenceCommented:
If you give the URL of the place you got this from, I may try
to figure out if this can be fixed easily.
0
anavrinAuthor Commented:
Well, I got the program off a cd I have that is the archives of sunsite.unc.edu
The program is playmp3.

0
somberlainCommented:
try a search for x11amp, it rox and dont eat up your CPU, i guess it even werkz w/ a 486-120, phear! theres lots of mp3 players and if something dont werk for ya, just get another. if u give the URL i can compile the thing on my box for ya, i run slackware which uses a different glibc than redhat 5, so it mite not werk even if i do compile it.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

wqclatreCommented:
Take a look in :
ftp://ftp.redhat.com/pub/contrib/hurricane/i386/

There you have mpg123, jukebox, mpegplay or  xmp3player.

I like the jukebox programs.

You install teh programs with rpm -ivh filename

My favorite mpeg player is amp, but I don't remember the link now....Try altavista..
0
anavrinAuthor Commented:
Every program I get keeps failing on the dependencies for libqt.so.1, but I installed qt, and it still wont work.  So, nothing will install.
0
wqclatreCommented:
If it's so that you have allredy installed qt.
(Use the latest qt-1.33-1rh5.i386.rpm and the qt-devel-1.33-1.rh5.i386.rpm found at ftp://ftp.redhat.com/pub/contrib/hurricane/i386/
And install with rpm -ivh filename. If you just upgrade a old package use rpm -Uvh filename)
)

You can install jukebox and the other packages using
rpm -ivh --nodeps filename
0
anavrinAuthor Commented:
Well, when I installed qt with rpm the first time, I don't think the rpm worked, because all it did was copy the source to ../redhat/SOURCES directory, and I had to take the file, unzip it, read the INSTALL file, and do a Make on, it.  Well, if I am going to start over, how do I get rid of the old one completely, and be sure its gone?

0
wqclatreCommented:
Oh, it sounds like you used a Source rpm and not a binary rpm with qt.
DO a rpm -e qt and a rpm -e qt-devel to remove the packages.
If it says that you don't have those packages installed just install them.
0
anavrinAuthor Commented:
well, I fixed the qt problem, but now, xamp, thinks its in the wrong architecture, jukebox, gives core dumps, xmp3player brings up a menu, does nothing, and then crashes.
do you know of anything that works?
0
wqclatreCommented:
Those works fine for me,but I have installed all files in the redhat updates directory at:
ftp://ftp.redhat.com/pub/redhat/updates/5.0/i386/

Mabe it's your ld.so that's old. If you havn't upgrade it since you installed RH 5.0 I think it's a good idea to do so.

0
anavrinAuthor Commented:
I have the newest version of ld.so
0
wqclatreCommented:
I can put some other Mpeg players on my ftp if you like to try them.

ftp://a201.ryd.student.liu.se/pub/Linux/misc/mp3

0
anavrinAuthor Commented:
I tried your splay, and that doesn't work either.  The window comes up fine, I open a file, and that works, and it read it as an MP3 file,stereo, timelength,... But, then when I go to press play, nothing happens, it just sits there, nothing visual, or audio happens, I just see the "Play button" get pressed in, but nothing starts.  That is the same thing that happened with x11amp, and another one, I  forgot which one.
0
wqclatreCommented:
The sound works fine with other aplications????
What does cat /dev/sndstat says???
0
anavrinAuthor Commented:
Sound works fine on everything else except (Real Audio Player)
This is what is in /dev/sndstat.

Sound Driver:3.5.4-960630
Kernel: Linux localhost.localdomain 2.0.32 #1 Wed Nov 19 00:46:45 EST 1997 i686
Config options: 0

Installed drivers:

Card config:

Audio devices:
0: Sound Blaster 16 (4.16)

Synth devices:
0: Yamaha OPL-3

Midi devices:

Timers:
0: System clock

Mixers:
0: Sound Blaster

0
xtermCommented:
Like I responded to one of your other posts earlier, your
sound is not set up correctly - take a look in your syslog
(/var/log/messages) - I'd be willing to bet that you are
getting Sound DMA errors.  

Is your sound support modular or built into the kernel?
It should be an easy fix if I know how you generated your
current kernel.
0
anavrinAuthor Commented:
I used the default kernel, which I believe leaves the sound as modular, and I used sndconfig, the configurator for Sound Blaster PnP cards specifically, and it worked, and my sound works for au files, midi,wav,and cd's, but not for mp3's, and not for Real Audio either.  I really saw no reason to compile another kernel, since "this one works", but if you could tell me what needs to be fixed in my sound configuration, then I'll do it, but I don't know what seeing that it seems to work with the other sound fromats.  Thanks for the help.  
0
gfreeman081597Commented:
I'd be really interested in hearing the fix to that too, as I can't record or play Real Audio on my Sound Blaster 16 under RH5.0.  I need to be able to record with the RA server for WWW purposes...

Thanks, you guys are gods!
0
xtermCommented:
Try sndconfig again and enter in the following values:

I assume your IRQ is correct, or it wouldn't work at all,
but the SB defaults are 8-bit DMA = 1, 16-bit DMA (or
secondary) = 5.  The midi base is 0x330, IRQ 9.

I assume your SB IRQ is 5 if you haven't changed the default.
Set all those to the same as the card, and it will work just
fine.

If you don't know what the card is set at, go to Creative's
site and grab the do$ drivers for the card & copy them to
a dos boot floppy & set the card to whatever you set in
sndconfig.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.