CD Autorun Problem

My PC seems to have lost its CD Rom Auto run capability, although CD's run fine from the Start menu. I have checked the enable auto insert notification and this seems OK.  To be sure I have deleted this option and then reset it but still no luck.
I sometimes get the following error message on start up - "an exception has ocurred at 0028:C10B7B83 in VXD--- This was called from 0028:C15B246B".  I dont Know if this exception message relates to a seperate problem or the CD Auto Run problem.  Any help regarding Auto Run and the exception message would be appreciated.
XS750FAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

busukaCommented:
First: enter Device Manager (roght-click on My Computer -> Properties ->
Device Manager tab) and check if you have any hardware conflict
(red/yellow exclamation mark).
Second: what your hardware ? CPU, RAM, motherboard, CD, video,
 sound, other cards.
Third: upon startup, press F8 right after message 'Starting Win95'
 and select Logged boot (BOOTLOG.TXT). Post here FAILed lines.
Fourth: post here your CONFIG.SYS / AUTOEXEC.BAT
0
kmrussellCommented:
Go into control panel
-go into "system"
-click on the "device manager" tab
-open up the "CD-ROM" tree by clicking the "+" sign
-double-click your cd rom
-click on the "settings" tab and make sure "Auto Insert Notification" has a check in it
-click ok until you get out
-
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rmarottaCommented:
Do you have this problem with both audio and data CDs?
Do you have more than one CDROM drive in your system?
Regards,
Ralph

0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

busukaCommented:
kmrussell, why you jumped with answer and not read question: "I
 have checked the enable auto insert notification and this seems OK.  To be sure I have deleted this
 option and then reset it but still no luck."

0
XS750FAuthor Commented:
To BASUKA Here is the information you asked for:

1, There is no hardware conflict showing in device manager

2, My Hardware – Intel pent 200mmx, 430TX PCI Chipset, 32mb EDO Ram, 512k Pipeline Burst Cache, 3.2GB Ultra ADA DMA-33 Hard Drive, 3D Matrox Mystique 220 4mb SGRAM 64bit 3D Graphics Card, 24 Speed CD Rom Drive

3, BOOTLOG.TXT –

[00127F22] Load Failed = nsdis2sup.vxd
[00127F31] load Failed = vshare
[00127F4F] Load Failed – EBIOS
[00127FCA] Deviceinitfailed = MTRR
[00127FCE] Deviceinitfailed = VPOWERD
[00128061] Dynamic load failed c;\WINDOWS\SYSTEM\MRCI.VXD: [00128062] File not found
[00128158]INITCOMPLETEFAILED = SDVXD

4, AUTOEXEC.BAT-

/L:500 /F5100
C:\AUDIODRV\ESSCFG.EXE /A:220 /I:5 /O:1 /B:330 /J:E
C:\AUDIODRV\ESSVOL.EXE /V:8 /L:8 /W:8 /H:0 /C:8 /S:8 /A:0
PATH=C:\;C:\WINDOWS;C:\WINDOWS\COMMAND;C:\MOUSE
LH MOUSE
C:\MOUSE\MOUSE.COM
CLS
MODE CON CODEPAGE PREPARE=((850)C:\WINDOWS\COMMAND\EGA.CPI)
MODE CON CODEPAGE SELECT=850
KEYB UK,,C:\WINDOWS\COMMAND\KEYBOARD.SYS
SET BLASTER = A220 15 D1 T4

5, CONFIG.SYS –

DEVICE=C:AUDIODRV\ES1868.COM /A:0 /I:0
DEVICE=C:WINDOWS\HIMEM.SYS
DEVICE=C:WINDOWS\EMM386.EXE NOEMS
DEVICE=C:\ATAPI\TOSHV111.SYS/D:MSCD000
DOS=HIGH, UMB
FILES=100
BUFFERS=40
DEVICE=C:\WINDOWS\COMMAND\DISPLAY.SYS CON(ega,,1)
COUNTRY=044, 850, c:\WINDOWS\COMMAND\COUNTRY.SYS

To KMRUSSELL - The Device Manager settings are OK

To MAROTTA – Audio CD’s automatically start, the problem is just with data CD’s.  I have only one CD drive

Thank you for all your interest in my problem, I hope the above information helps you to find the solution  - Best regards XS750F

0
XS750FAuthor Commented:
To BASUKA Here is the information you asked for:

1, There is no hardware conflict showing in device manager

2, My Hardware – Intel pent 200mmx, 430TX PCI Chipset, 32mb EDO Ram, 512k Pipeline Burst Cache, 3.2GB Ultra ADA DMA-33 Hard Drive, 3D Matrox Mystique 220 4mb SGRAM 64bit 3D Graphics Card, 24 Speed CD Rom Drive

3, BOOTLOG.TXT –

[00127F22] Load Failed = nsdis2sup.vxd
[00127F31] load Failed = vshare
[00127F4F] Load Failed – EBIOS
[00127FCA] Deviceinitfailed = MTRR
[00127FCE] Deviceinitfailed = VPOWERD
[00128061] Dynamic load failed c;\WINDOWS\SYSTEM\MRCI.VXD: [00128062] File not found
[00128158]INITCOMPLETEFAILED = SDVXD

4, AUTOEXEC.BAT-

/L:500 /F5100
C:\AUDIODRV\ESSCFG.EXE /A:220 /I:5 /O:1 /B:330 /J:E
C:\AUDIODRV\ESSVOL.EXE /V:8 /L:8 /W:8 /H:0 /C:8 /S:8 /A:0
PATH=C:\;C:\WINDOWS;C:\WINDOWS\COMMAND;C:\MOUSE
LH MOUSE
C:\MOUSE\MOUSE.COM
CLS
MODE CON CODEPAGE PREPARE=((850)C:\WINDOWS\COMMAND\EGA.CPI)
MODE CON CODEPAGE SELECT=850
KEYB UK,,C:\WINDOWS\COMMAND\KEYBOARD.SYS
SET BLASTER = A220 15 D1 T4

5, CONFIG.SYS –

DEVICE=C:AUDIODRV\ES1868.COM /A:0 /I:0
DEVICE=C:WINDOWS\HIMEM.SYS
DEVICE=C:WINDOWS\EMM386.EXE NOEMS
DEVICE=C:\ATAPI\TOSHV111.SYS/D:MSCD000
DOS=HIGH, UMB
FILES=100
BUFFERS=40
DEVICE=C:\WINDOWS\COMMAND\DISPLAY.SYS CON(ega,,1)
COUNTRY=044, 850, c:\WINDOWS\COMMAND\COUNTRY.SYS

To KMRUSSELL - The Device Manager settings are OK

To MAROTTA – Audio CD’s automatically start, the problem is just with data CD’s.  I have only one CD drive

Thank you for all your interest in my problem, I hope the above information helps you to find the solution  - Best regards XS750F

0
rmarottaCommented:
XS750F,
If the proposed answer does not solve your problem, please re-open the question so that other experts may submit a solution.

1) What version of Win95 are you using?
2) How is the hard drive partitioned?
3) Are you using bus mastering?
4) If so, how are the hard drive controllers listed in Device Manager?

Regards,
Ralph

0
busukaCommented:
Hmm, BOOTLOG looks normal, but something still bugging me.
Dynamic load failed c;\WINDOWS\SYSTEM\MRCI.VXD
Is ';' sign after C typo. Check files SYSTEM.INI and WIN.INI for
this string and replace ; with :
If you didn't found it there, run Regedit and search in registry.
Except SDVXD everything looks normal.
As Ralph said, please reject proposed answer.
0
sKiiKeCommented:
I once had problem with autorun. Autoinsert notification was checked etc. The obviously is another way to tweak registry so that datacds and audioCDs don't autoplay

Get Tweak-UI from Microsoft freeware Powertoys. In Tweak-UI there is a tab, Paranoia. There You can either get rid of autoplay of dataCDs and audioCDs or get them back ;)
0
rmarottaCommented:
Any progress yet, XS750F?

0
XS750FAuthor Commented:
To overcome the problem I have re-loaded windows 95. This is'nt subtle, and has'nt told me what went wrong - but the problem seems to have been resolved.  CD Auto run is now O.K. and I am not getting any more exception messages.  I have been left with a slight start up problem as my ststem.ini file seems to be looking for file names - ntkern.vxd, enable.vxd, and mtrr.vxd which are no longer present.  As this is now a different problem I will post it as a seperate question.
Thanks to everyone for your help and interest
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.