Outlook as the default mail client ("mailto:")

Is it possible to set Outlook as the default mail client ?

I want to use outlook whenever the hyperlink "mailto:xxx@yyy" is present.
Currently when I try to click on such a link (event from within Outlook) - Netscape's
mail is poped up.
erezgurAsked:
Who is Participating?
 
TSauerConnect With a Mentor Commented:
Ok,
I´m only working with windows NT, but this should also works under Win95

Open regedit
Use the search command and look for a entry mailto
under this entry you should find a key shell/open/command

Under command replace the entry with the following one:

pathto\OUTLOOK.EXE -c IPM.Note /m "%1"

After restarting yr. system when you click on a mailto, the Outlookclient should come up.

But remember to save your old settings befor you make changes, and there should be multiple expiriences of this key in the registry.

0
 
d4jaj1Commented:
If your using version 98 - you can do this within Outlook, otherwise, you'll have to make a registry change.  What version are you using?
0
 
erezgurAuthor Commented:
Windows 95, Outlook 97, Netscape communicator 4.*

What do I have to edit in the registry ?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
d4jaj1Commented:
Try this - you doen't even need to modify the registry.  From teh Win95 control panel, double-click on the Internet icon.  In teh dialog box, select the Programs tab.  The options should be Mail, News and, (if IE4.01 is installed) Internet Call.  In the Mail drop down box, select Outlook.

Also, the next time Netscape starts, it may ask you if you want to chnage it to teh default newsreader.  Choose NO and make sure you check "Don't perform this check next time" option. Any problems, let me know.  

Good Luck!

Jay
0
 
erezgurAuthor Commented:
Jay,

Thanks for the effort, but It was already set to Microsost Exchange.

Sorry, didn't make the trick.

Erez
0
 
TSauerCommented:
Did you want to change this setting for the general system, this is a regestry setting.
If you want to do this only in Netscape, there must be a setting in the Novigator
0
 
erezgurAuthor Commented:
Currently, Netscape's mail window is poped-up whenever i click
on a "mailto:" link, even within Outlook.

I want to use Outlook as my email client and associate it with
the "mailto:" links, from within Outlook and if possible from
Netscape as well.

And yes, my "URL:mailto protocol" (from View->options->file types) is set to Outlook "...OFFICE\OUTLOOK.EXE" -c IPM.Note /m "%1").

Erez
0
 
erezgurAuthor Commented:
Adjusted points to 150
0
 
d4jaj1Commented:
Is it set to Outlook or Exchange?
0
 
erezgurAuthor Commented:
It is set to OUTLOOK. I've included the value in my prev. remark,
but here it is again:

... And yes, my "URL:mailto protocol" (from View->options->file types) is set to
Outlook "...OFFICE\OUTLOOK.EXE" -c IPM.Note /m "%1").
         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
0
 
Aland CoonsSystems EngineerCommented:
Was Outlook installed before or after Netscape was last installed or upgraded?

Also, use regedit to double check the registry item --
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto
shell\open\command
is as you previously described
"C:\Program Files\Microsoft Office\Office\outlook.exe" -c IPM.Note /m "%1"

then check
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PROTOCOLS\Handler\mailto
CLSID = {3050f3DA-98B5-11CF-BB82-00AA00BDCE0B}

which registry setting
should be HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\
{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B}
(default) = Microsoft HTML Mailto Pluggable Protocol

finally check
_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Exchange\Protocols\Mailto
Shell\Open\Command
(default) = rundll32.exe url.dll,MailToProtocolHandler %l

_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook\
Protocols\Mailto
Shell\Open\Command
(default) = "C:\Program Files\Microsoft Office\
Office\outlook.exe" -c IPM.Note /m "%1"

If all this checks out and you have already tried re-installing Outlook97/98 to make sure it was installed after Netscape we'll just have to dig a bit deeper.
0
 
erezgurAuthor Commented:
comments for TSauer:
=====================
Everything you've mentiond is already set correctly in the registry.


comments for alandc:
=====================
I didn't find in my registry the following entries:
1) KEY_LOCAL_MACHINE\SOFTWARE\Classes\PROTOCOLS\
2) HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\3050f3DA-98B5-11CF-BB82-00AA00BDCE0B}
3) LOCAL_MACHINE\SOFTWARE\Clients\Mail\Exchange\
0
 
Aland CoonsSystems EngineerCommented:
1)  prefix with H   i.e.  HKEY_LOCAL...
2)  missing { proceeding 3050f3..   i.e.  CLSID\{3050f3DA-....
3)  prefix with HKEY  i.e. HKEY_LOCAL...

There should at least a #1 and #2 present.  It is believable that #3 may not be present if the "Inbox" (Exchange Client) had not been loaded previous to Outlook97/98.

You might try uninstalling Outlook AND Exchange.  You can get rid of exchange by going into the control panel and Add/Remove programs then choose the 2nd tab "Windows Setup" and there uncheck Microsoft Exchange. While you're in there go to the bottom and get rid of the Microsoft Network (if you don't use it).  When you reinstall Outlook it will install any OS features it needs to function correctly.
0
 
erezgurAuthor Commented:
alandc:
I'm sorry, but I've got no such entries (the typing mistakes I made only in my remarks):
I dont have a \Classes\PROTOCOLS (I do have Classes\Printers, \Classes\Prod.Cap and \Classes\psfile)
I dont have the {305* entry. (I do have an entry for {2F1.. and then for {307...)

Maybe it has to do with the fact that the Hebrew version of Win 95 is based on an earlier version of Win95...
and yes, the Exchange was not install before I began to use Outlook.
0
 
Aland CoonsSystems EngineerCommented:
If you ever ask for technical support the fact that you use the Hebrew version of Win95 is not a small fact to be omitted. Sorry that I cannot provide any additional assistance.
0
 
erezgurAuthor Commented:
I guess you're right.
Thanks for the effort.

Erez
0
 
killerwhaleCommented:
I believe what you are trying to do is descirbed in a Netscape kb article:

http://help.netscape.com/kb/consumer/19980630-3.html

The fix described is claimed to work for the Navigator only version of Netscape, but appears to work with Communicator if you obtain navmapi32.dll (included with Navigator 4.08) and place it in the Netscape\Communicator\Program directory.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.