Solved

Fifa 97, 98 and NHL 97, 98 is very slow

Posted on 1998-05-01
22
756 Views
Last Modified: 2013-12-26
When I start FIFA 97 and NHL 97 in windows 95 the graphics are real slow. It takes minutes before I reach the menu and when I click on a button, the next menu takes very long time to load and so on.

But when I start the game in MS-DOS the game works as it shoud.

What causes this?

I have a Pentium 150, 40 MB ram, and DirectX 5.
0
Comment
Question by:gronkvist
22 Comments
 
LVL 6

Expert Comment

by:WxW
ID: 1099762
Check if many programs are run with Fifa 9x . Also check your DirectX - I have not installed it and the game goes fine with a P133/32
0
 

Author Comment

by:gronkvist
ID: 1099763
Sorry it did'nt work.
I have closed all other programs when I start NHL 98, 97 ......
I have removed all DirectX driver.
I have reinstalled DirectX drivers, first DirectX2 then DirectX3 and then 5
All DirectX drivers are certified
There is no difference, the games are still slow.

Also when I tryed NBA Power Play the game was real slow.
0
 
LVL 5

Expert Comment

by:stevemiller
ID: 1099764
What are the requirements for the game?  Also what is your video memory and what type of video card are you using?
0
 

Author Comment

by:gronkvist
ID: 1099765
The requirements for the game (NHL97 and FIFA97) are Pentium 75, 16 MB Ram, 1 MB SVGA video card DirectX2  and 2x CD-ROM.

My configuration:
P150, 40MB Ram, 2 MB Tseng ET4000/W32 P SVGA video card, DirectX5 and 4x CD-ROM
0
 

Expert Comment

by:lyc
ID: 1099766
Check if you have any external programs loaded in.
One good example is magnaram. It may seem to enhance your performance, but when it comes to such games, it dramatically slows them down. Check out such programs by either pressing ctrl-alt-del or by checking your system tray (the icons beside the clock)
0
 

Author Comment

by:gronkvist
ID: 1099767
I have no other programs running.
When I press Ctrl+Alt+Del I only have something called Explorer (I don't know what this program does), and if I try to end that program I get three options "Turn off the computer", "Restart Windows" and "Restart in MS-DOS". (The same options when you what to end Windows in the Start Menu.)
0
 

Expert Comment

by:DanDyer
ID: 1099768
Did you use the minimum installation?  If so the computer will be using the CD-ROM a lot which may slow it down.

Also try installing the DOS version rather than the Windows version, and run that from Windows, I found this to be more stable on my machine.

P.S. Try Actua Soccer 2.  Better than FIFA '97, much quicker and more intuitive control.
0
 

Author Comment

by:gronkvist
ID: 1099769
I used maximum installation. When I use the dos version of NHL97 and FIFA97 there is no problem with the speed, but NHL98 and FIFA 98 can't be played in dos mode, it require windows95.
0
 
LVL 12

Expert Comment

by:James Elliott
ID: 1099770
In your hardware profile under graphics there should be an option of how much you wish to accelerate your graphics hardware. Try any of those settings. Also, try looking in the setup of the game to see if the graphics are not tryingto run on a 3dfx card. On recent games, the 3dfx graphics card is default and so has to be changed. You will probably either find the option in the game irtself of when indtalling.

0
 

Author Comment

by:gronkvist
ID: 1099771
I've tryed all the settings in hardware profile but it didn't help.
I've also tryed changeing the cache from the CD-ROM but no luck.
The 3dfx acceleration was not activated in the game setup.( It toke about 5 minutes to get to the setup menu.)
The mouse is also very slow in the game, when I move the mouse it take about 10 sec before it reacts and then another 10 sec and so on. It seems like the graphics are updated every 10 sec. If thats any help.
0
 
LVL 1

Expert Comment

by:stevesm
ID: 1099772
Try upgrading your video drivers, this is one of the recommendations that EA suggests before installing directx 5.

Also try  turning off the following in NHL98

toggle ice textures off(Details menu)
cycle audio to low(Options menu)
cycle player detail low(Details menu)
reduce screen size - the smaller the screen size the greater the improvement(Details menu)

Try making similar adjustments in FIFA98

Have you checked your virtual memory settings, I have the same games and found that windows was consistantly resetting my hard drive during the game. This problem usually occured after playing a few minutes though. Despite what windows tells you reseting the virtual memory is not a bad thing but actually quite helpful. Try tripling your ram for both the min and max setting.
And then try the game.

Good luck and let me know if this helps .......Steve
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Expert Comment

by:smaccubb
ID: 1099773
There are two things you should check: 1. Check your system properties, performace and make sure that you have the cd-rom set for Quad Speed or higher, 2. check your display settings (graphics) to make sure you have hardware accelleration set to full. Let us know.
0
 

Author Comment

by:gronkvist
ID: 1099774
I have the CD-ROM set to quad speed or higher and I have hardware accelleration set to full.
I have tryed all other settings in the CD-ROM, Graphics and virtual memory but it didn't help.

It seems like my computer doesn't  like sports :-)
0
 
LVL 2

Expert Comment

by:aliebrah
ID: 1099775
It is quite possible that the game is trying to run at a high resolution like 1024x768 and this is really slowing things down. Maybe if you can change it to 640x480 it will run faster.
0
 

Author Comment

by:gronkvist
ID: 1099776
I have tryed to set the resolution to 800x600 and 640x480 but it didn't help.
I think it's strange that I only have problems with sports games.
0
 

Expert Comment

by:dannyv
ID: 1099777
I'm almost sure the problem is in your CDROM.
Then I tried FIFA98 with x4 CD, it was slow;
with x24 CDROM it was great (All this on P166).
0
 

Author Comment

by:gronkvist
ID: 1099778
The CD is not running during the first 2 pictures (the computer loads the 2 first images into the memory) so I don't think that is the problem.
0
 
LVL 1

Expert Comment

by:isilver
ID: 1099779
What kind of hardware accelerant are you currently running?  
0
 

Author Comment

by:gronkvist
ID: 1099780
I have no hardware accelerant. But I have bought a new computer now so I use this one instead.
0
 
LVL 2

Expert Comment

by:phooey
ID: 1099781
Not an answer (perhaps0 but I had problems with Jedi Knight because I had an old version of MSCDEX running.  i load this in AUTOEXEC.BAT so that dropping to DOS mode is seamless.  Since you say the games run in DOS OK then I guess that this is loaded.
Not sure where you get the latest version from but it DOES make a difference.  JEDI reported my CD as 2x and wouldn't load properly.  With new MSCDEX it reports 8x properly and works fine.
0
 
LVL 1

Accepted Solution

by:
Topace earned 100 total points
ID: 1099782
The things I would say are wrong are:

1. Any RAM doubler, compression agent, etc. should be turned OFF before trying the game.

2.  You should check to see if you loaded the program correctly by uninstalling it, and then re-installing it.  Also -- Choose the MAXIMUM install feature.   Also make sure you restart your computer.

3.  Make sure you have ALL the DirectX drivers loaded and certified.  

4.  Make sure you have MSCDEX loaded correctly.  I had a MAJOR problem with some MAJOR problems with my games because of this.  Your best bet would be to re-install it from your CD-ROM drivers disk.  That way, it will not be tampered with. etc...

5.  Check to make sure your config.sys and autoexec.bat files do not have errors.  To do this, restart your computer, and just after the Win95 flsh screen comes up, make sure it doesn't say something like, "Error in your config.sys file on line 1"

6.  Make sure your all your CD-ROM and VIDEO card drivers are properly installed

7.  Right Click on MY COMPUTER and go to PROPERTIES.  Click the DEVICE MANAGER tab, and make sure that there are no Yellow '!'s on either your CD-ROM or your VIDEO CARD and multimedia sytems.  

If none of this works, tell me what kind of Sound Card you have and what is required.  

Topace
0
 

Expert Comment

by:marxl
ID: 1099783
I have had the same problem, the answer is the CD-rom if you can change it to a quicker one you'll see the difference, probably it's a problem of the win95 driver that gets too many times access to the cd
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Article by: Joseph
CONTENTS I.      What is a MOBA?   a. Definition   b. Origin   c. Current Generation II. The New Games   a. League of Legends   b. Heroes of Newerth   c. Dota 2   d. Smite III. Comparison IV. Conclusion ------------------------…
Programming  of  forecasting lottery numbers for self use  on Turbo C++ is done by use of random number generator code by a program algorithm logic. Random numbers usually generates numbers between definite interval. Therefore, when entering the c…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now