Triteal disable

'dtconfig -d' followed by 'dtconfig -kill' will kill the CDE session but on reboot, the CDE autoboots (Red Hat 4.2).
I know I can disable the autoboot of CDE by renaming the script in /etc/rc.d/rc3 but there ought to be a neater way of doing this ( the two commands listed above are sufficient with Solaris 2.6! ). Any thoughts on this?
stephenfAsked:
Who is Participating?
 
AlexandrIIConnect With a Mentor Commented:
If Your default runlevel is 5, then edit Your /etc/inittab file, and put 3 instead of 5 in string that says:
id:5:initdefault:
If not, try to put 2 instead. Anyway, CDE startup should be made from /etc/inittab, not from the rc3 file. Changing to runlevel2 will disable NFS, so if You're usig NFS, browse Your rc3 file and comment out CDE startup strings, and put them in /etc/inittab under "x:5:respawn:............." in order to start CDE from /etc/inittab. Then reboot and check whether it works. Im not sure 'bout CDE, but other Desktop Managers usually do so.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.