Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 284
  • Last Modified:

Gateway Q

I have install one REDHAT 5.0 on my PC (IP=64.200.200.200 Mask=255.0.0.0) and try to connect to the internet thru my gateway ip 64.0.0.128.  After installation I can ping to other computer in my LAN but not outside ... here are my netstat -rn output

Destination    Gateway   Genmask   Flags     MSS   Window irtt  Iface
127.0.0.0        0.0.0.0       255.0.0.0     U            3584     0         0    lo
64.0.0.0          0.0.0.0       255.0.0.0     U            1500     0         0    eth0
0.0.0.0          64.0.0.128   0.0.0.0         UG         1500     0         0    eth0

What wrong with my command and .. what command and how to correct this  or do I need to configure more on my gateway

TQs
0
khairi
Asked:
khairi
  • 5
  • 4
  • 3
  • +1
1 Solution
 
ahoffmannCommented:
what does ping report?
hat does traceroute report?
0
 
natmakCommented:
put a "nameserver ADDRESSES" line in /etc/resolv.conf, where 'ADDRESSES' replaces the IP numbers of the DNS server of your provider
then do chmod a+r /etc/resolv.conf
0
 
khairiAuthor Commented:
Okay...my first try it say destination unreachable ... then with the above ... the packet is lost .. never try the traceroute ... but I try today

okay if you say that addresses is the DNS Server then I will try to put the IP .. I thought that mean other thing ...I'm new to this term
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
ahoffmannCommented:
> destination unreachable
is a routing problem on the host you run ping

Did you use domain names or IP numbers for ping?
Can you ping both ends: server to workstation and workstation to
server?
0
 
alexbikCommented:
Hi,

It seems to me that the problem lies in the fact that you don't have an official IP number
for your machine. In this way you can send packets out allright, but the server you want
to reach has no way of reaching your machchine to get the reply to you.

If your gateway is a linux box as well, you should install IP masquerading on it, as
described in ftp://sunsite.unc.edu/pub/Linux/docs/HOWTO/mini/IP-Masquerade

Alex.
0
 
khairiAuthor Commented:
My Q is to get the default gateway .. using router which is not Linux Box... and I ping other Server and PC in my local LAN using name and IP number work find ...

What do you mean by official IP number ... it is supply by my ISP or what ?

Still not try other comment as I am not at my office
0
 
alexbikCommented:
Hi,

An 'official' IP address is assigned to you by your ISP. Usually, you will get one dynamic IP address (that means that the IP address is different every time you dial in). If you want to let multiple PC's access the Internet over one dialup link, you will either have to use IP masquerading, or you will need to get multiple static IP addresses from your ISP.

Alex.
0
 
khairiAuthor Commented:
Hi,

My company already have leased line connected to the ISP (64k)

I read question posted by Jake on setting up network with RH5.0 .. I thing I am facing with the same problemm with him ... and during installation RH does not recognized my net card ... I think I am going to try using other card ...

I have a router that have two IP which one IP (eg: official IP=202.0.1.4) connected to the ISP and other IP to my local LAN (64.0.0.128)

Okay ...  If my IP (64.200.200.200) in my local LAN can I ping outside IP thru my gateway ... if my configuration on the gateway is correct ...
0
 
ahoffmannCommented:
on your gateway you must do following:

      route add -net 64.0.0.0 gw 64.0.0.128 netmask 255.0.0.0 dev eth1
      route add default gw 202.0.1.4 dev eth0

assuming that eth0 is connected to you ISP and eth1 to your LAN
(probably your route has different syntax, please check with
man route)
0
 
alexbikCommented:
Hi,

If you have a leased line, it should be no problem to get a few extra IP numbers.
IP numbers are always static if you use a leased line. You should use IP numbers assigned by your ISP for all mahchines that need to connect to the Internet.

Alex.
0
 
khairiAuthor Commented:
Okay I finnaly got it  ... but my router is fine with other box in my office ...

but the command route add default gateway to my gatewaye IP solve the problem..

however, the router must allow the 64..... to go thru the router ..

Thanks All
0
 
ahoffmannCommented:
> however, the router must allow the 64..... to go thru the router ..

what do you mean by that?
Must every IP routed to you ISP, then  route add default ..  is
just enough.
0
 
khairiAuthor Commented:
The IP I am suppose to connect is just another IP which is located at another brach which  is connected directly with a leased line ... and the router used is configured to allow IP starting with 64.0.0.0 something  with same netmask as my superior said .... about connecting to the Internet thru the gateway is not possible but I am agree with using the Official IP to connect to Internet

Sorry about the misleading info ...... I just found out from my superior ... If incorrect please advise I am new to this IP thing
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now