Solved

x-windows

Posted on 1998-05-05
24
315 Views
Last Modified: 2010-04-22
I have a big problem with x-windows in my linux ( redhat 5,0 ). The problem is that x-windows do not execute anytask . the problem must be with the x-manager but i haven't got any more . the problem is that no matter which task i try to execute , x-win do not do anything . The root shell only presents a black screen with no other function . moreover netscape will not execute not anything else giving me nothing more than a black non responding screen.
how can i solve the problem or install another x-manager ?
0
Comment
Question by:mixelogj
  • 11
  • 4
  • 3
  • +5
24 Comments
 
LVL 1

Author Comment

by:mixelogj
ID: 1635014
Please solve it as soon as possible . it is urgent !
0
 
LVL 3

Expert Comment

by:mhomann
ID: 1635015
Have You the right x-server for your card?

0
 
LVL 2

Expert Comment

by:aszure
ID: 1635016
Need more info about which server (metrox, xfree86, acceleratedx ?) and what video card are you using?
0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635017
sorry but i'm not that advanced about linux . I am using the Diamond Viper v330 on a pc mmx ( intel ) 200 , 64 mb sdram . 350 mb of linux space ( no virtual memory ) a modem of 28.800 bps and a cd 20x .How can i get the right x-server ?
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1635018
login to a console window (tty) then start following (depending
on your shell):

      csh, tcsh# xinit >&x.log
      bash, sh, ksh# xinit >x.log 2>&1

you should get a screen with grided background and a X-shape
pointer. Any buttons on the mouse should show a popup-menu.
Stop X server with Ctrl+Alt+Backspace and send contens of x.log
0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635019
you don't understand , nothing ( including shells ) are functioning under x-windows . nothing...
0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1635020
Did you try to reinstall redhat 5.0?

0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635021
no i didn;t because this is the last result since i have installed some programs which i need . This is the last resort , please tell me how to fix this without reinstallation
0
 
LVL 1

Expert Comment

by:Talence
ID: 1635022
Question: what happens if you start X and then stop it?
This can be done either by ctrl-alt-backspace or by going
to another tty (ctrl-alt-F1, ctrl-alt-F2, etc) and killing
the process from there. I wonder why you are trying to start
netscape when you can't even get X to run :-)

Tal.

0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635023
x-windows do run . but no applications function including the root shell .
0
 
LVL 1

Expert Comment

by:Talence
ID: 1635024
Oh, I'm sorry.. what I meant was: ".. get X to run properly"

For all clarity, please answer this question: when you start
X, do you get to see something like a greyish blackground or
any background for that matter? I'd like to know this because
this might indicate that your _actual_ problem doesn't involve
getting the right X server or configuring it properly.

If it's not the X server that's causing your problem (and after
rereading your question, I don't really think it is), then it
might be your window manager. Furthermore, if your 'root shell'
(some xterm, I presume..?) is black, it might be because both
the foreground and background colors are set to black for some
reason.

I think the problem should be quite simple to solve, but you
really have to provide more accurate information.

Tal.
0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635025
Yes i can see background in x-win . I see a black and white background with a quite low refresh rate ( must be 60hz ). The display is not of good quality .I don't think it is the colours because no application i executed ( even netscape ) . moreover when i type a command which should lead me to an application ( different environment ) in the root shell , nothing happens . That application is bitchx which executes perfectly well under linux ( not x-win ) . The thing is that x-win run at the beggining well but NO applications respond or execute . I have asked someone who is good at linux and he said it is a problem of the x-manager . He also told me how to load different managers nder x-win . the thing is that no other x-managers can be found in my x-win . I haven't installed everything from the cd due to low disk space. I don't think the problem is in the colours because i see a normal background but it must be the x-manager .How can i solve it ? nothing responds under x-win , however x-windows do in initiate and shutdown correctly
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 51

Expert Comment

by:ahoffmann
ID: 1635026
> ou don't understand , nothing ( including shells ) are
> functioning under x-windows . nothing...

mixelogj, I think you meant my comment.
So if you look at Talence's comments, my suggestion is just that
in short words. I never said that you should do anything *after*
X has started, I want to know if core X is running properly.

All you descriptions about the bahavior let me think that an
application started automaticaly (by $HOME/.xinitrc or whatever)
causes the problem.

Could you please also tell us how much RAm and swap you're using?
0
 
LVL 1

Expert Comment

by:Talence
ID: 1635027
Could you check if something like 'fvwm' or 'fvwm95*' is
present on your system? Also, post your ~/.xinitrc so we
can check it out.
0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635028
yes my x-manager is fwwm i do think this is the one which is causing the problem . I am using 64 mb sdram without any swap . i will answer you other question about some apps in the end of this week :) ( when i have time )
0
 
LVL 1

Expert Comment

by:Talence
ID: 1635029
Heh, why no swap?? Anyway... what I asked you was if it is
present on your system - perhaps you haven't installed it. So:

1) Does the binary 'fvwm' exist on your system?
   If so, proceed to 2.

2) Where do you call fvwm from? Did you specify the FULL PATH
   of fvwm? Check this by reading ~/.xinitrc.

3) Do you have an '.fvwmrc' file in your homedir?

Anyway.. answer these three questions and maybe your problem
can be solved.

Tal.


0
 

Expert Comment

by:AlexandrII
ID: 1635030
If You're using XFree86, try to do the following:
First of all, shut down the X server. Then log in as root and run SuperProbe utility located in /usr/X11R6/bin. This prog. will show You information about Your Video card (soj memory, RAMDAC, chipset etc). The second thing You should do is collect *all* the information 'bout Your monitor (Hor. sync., Vert. sync., resolution and refresh rates, etc) found in monitor's manual. Then re-run Xconfigurator utility and provide these parameters when asked. Answer "Probe" when asked to probe Your video. Also, if Xconfigurator cannot recognize Your video card, You'll be asked to provide information 'bout this. If, for example, You are not sure 'bout clockchip, set to "no" this point. And, for the first time, don't choose more then one resolution/color depth. Try for example only 800x600/8 bits. After Xconfigurator finished it's job, run X server by typing "startx". If it won't start, send me messages You would see on display. Also, if it still doesn't work, please send me Your /etc/X11/XF86config file.

Alex

0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635031
i'll try to do these . thanks
0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635032
Now ....this may sound redicoulous but bear in mind that i am not a linux expert .Because your instructions mere too complicated for me i decided to reinstall redhat 5,0 . I deleted the Linux partition and reinstalled the whole thing . All is good apart from something . Because the version of lilo in this version of redhat is unable to boot fat32 partitions ( that's where I have my win 95 ) I decided not to installl Lilo . now.... I can not find a way of booting linux , i simply cannot get into linux environment . Could you tell me the image file ( if any ) which makes a linux boot disk , or could you tell me where i can get another version of lilo ( more recent ) ? There is an image file ( boot.img ) but this image file drives me to install . HELP!!!!
0
 

Accepted Solution

by:
adt earned 10 total points
ID: 1635033
OK,  This is going ot be a convoluted method for getting back into Linux, as I hate
the Redhat boot disks for doing repairs.  First, you'll want to get a slackware boot disk
that will work for your machine.  Under windows, ftp to ftp://sunsite.unc.edu/pub/Linux/distributions/slackware/bootdsks.144 and get bare.i
While you're at sunsite cd to /pub/Linux/distributions/slackware/install and get RAWRITE.EXE.  Put the bare.i and RAWRITE.EXE is the same directory, perhaps c:\linux.

Reboot your windows95 to command prompt only mode and use rawrite to place the
image (bare.i) on a floppy disk.  The syntax should be "rawrite bare.i a:".  

If there are no errors, reboot your machine with the floppy disk in the drive.
When you get a prompt, enter the following:

mount root=/dev/hd? (where ? is your linux partition)

This should allow you to get back into linux.
To make a boot disk for yourself, you should be able to do the following:

dd if=/boot/vmlinuz of=/dev/fd0  
rdev -R /dev/fd0 1
rdev /dev/fd0 /dev/hd?  (where ? is the partition of you linux install)
This should be a reliable boot disk for you until you get lilo working.

When you have linux back, you still will not be able to use X.  Support for your Video
card, which is based on the NVidia Riva 128 Chipset, is not included by default
in XFree86 until XFree86 3.3.2.   The version RedHat has available is 3.3.1.

DO THIS FROM LINUX
To get X working for you, you'll have to go to:
ftp://ftp.suse.com/pub/suse_update/XSuSE/xnvidia/
and get xnvidia.rpm.
While you are at Suse, you'll have to cd to /pub/suse_update/XSuSE/config/
and get xsuseconfig_old.tgz.  
rpm -Uvh xnvidia.rpm
cd /
tar -xzvf ~/xsuseconfig_old.tgz

then run xf86config to configure your card useing the Nvidia X server.




X they have available, or you'll have to rebuild X from source yourself.
0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635034
Thanks . i'll try that but as i am not a linux expert i am not sure of the results . thanks !
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1635035
Hmm. reinstalling programs and even OSs somteimes, after several reboots, may help (for most M$ products it is the the recommented procedure:-), but are we talking about linux?

So, mixelogj, why are you not looking close to the problem, the X stuff, as some comments recomment?
Again, what happens and what is printed on your terminal when you just start X ?
0
 

Expert Comment

by:adt
ID: 1635036
Please ignore the very last line in my proposed answer for your problem.
My browser did something unexpected and stupid in the edit space.

mixelogj,  have you tried what I have suggested?  If it does not work, please let me
know what errors you get and what kind of behavior your machine exhibits.
0
 
LVL 1

Author Comment

by:mixelogj
ID: 1635037
ok but sou see , i tried to boot linux and it said : kernel panic : and something wrong with the partitions . soo it has gona have some time to reinstall . notice that i am booting from a boot disk with the kernel image .
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now