Modem won't disconnect

I have a Performa 6320CD with an internal modem (teleport silver?) and when the modem is plugged into the phone jack, it opens the telephone line and won't disconnect causing the "european siren" and "please hang up and try your call again" along with static and silence.  Regular telephone works and will disconnect when the call is completed, but the modem won't disconnect.  I have to unplug the modem line from the phone jack, plug it back into the wall and immediately sign on to the application using the modem to get an outside line.

This problem just began two nights ago after having the computer almost two years.  I have installed no new software.
bamabudAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

squintCommented:
Sorry, your modem is just plain broken.
JegredeCommented:
What software are you using??

WileyKatCommented:
Several ideas for you:

1. If you are using any modem script, change it to Teleport Platinum. My 6300CD is a Platinum, not a Silver. There is a difference. If you are using something like FreePPP that doesn't use modem scripts, change your modem init to ATZ and your hangup to ATH.

2. Check to make ABSOLUTELY sure that the Global Village Toolbox extension and Teleport control panel are correctly installed and configured. Missing one or both can cause major problems (as I found out)

3. If you aren't already, start using Open Transport and OT/PPP, both free downloads from Apple's FTP site(s). They're a lot more stable than anything else I've ever used. FreePPP crashed mine out every time.

4. Check the phone cable itself. If there's some kind of defect in it, that might cause the problem.

5. If your Global Village Toolbox extension is installed, make sure you are using the newer version. An update is available on their website if you are not.

6. If none of these help, I don't really know.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WileyKatCommented:
Er...just out of curiosity, which of my ideas worked?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.