Modem answers every call in win3.1 and dos

I just installed Trumpet Winsock on a friend's computer who's running win3.1 and Dos.  Before I installed TW, everything was fine.  The modem wouldn't answer incoming phone calls.  Now, if the computer is simply sitting idly in DOS or win3.1 and regardless of whether any applications are open or not, the modem attempts to answer any incoming call.  Is there an easy way of disabling this?  I posted this also in the Win 3.x General area (not realizing until afterwards that there's now a Modem discussion group), so if you can answer this question, go ahead and answer my cross-posting too (which is for 200 points) ... so 300 points total.
kenneth022597Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jrhelgesonCommented:
Is it an Internal or external modem?
0
kenneth022597Author Commented:
It's an internal USR Sportster 14.4
0
jrhelgesonCommented:
I did not mean to answer the question.
You need to put a reset command in the modem reset line after winsock disconnects.
0
Vitali NassennikCommented:
IMHO, modem accidentally has been programmed by ATS0=1&W. This command instructs modem to auto-answer on incoming calls and writes this setting in modem's memory. Now you have to re-program modem to disable auto-answering.
1. Run any terminal program in interactive mode.
2. Be sure that modem is attached to computer and turned on.
3. Enter AT<Enter>. Modem should respond OK. (Just check).
4. Enter ATS0=0&W. Modem should respond OK. (Disable auto-answer and write setting in profile 0).
5. You can now finish terminal program. All done.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kenneth022597Author Commented:
Thanks a lot!  That solved my problem.  I cross-posted this question in Win3.x General, so go ahead and answer that one as well (I listed that one for 200 points).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.