c drive failure

when i go to turn my computer on i get nothing but c fail..i have it says hit f1 to continue but nothing happens except c failure...it also at one time said h host need to be scanned...we did that and nothing happened..it always comes right back to the window that says c drive has failed...when this started it was freezing on me all the time and now it won't let me do anything i can't get to the command prompt or anything..i have a expo 486 with c and d drive with h as a host...i have rebooted and rebooted and still goes back to that same window c drive has failed....it also makes a terrible rattling noise when it is thinking...it also takes for ever to think...it took over 15 min to get to the window that said c drive has failed..
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


Sorry but it sounds to me like your hard drive has failed.  Long time to access and rattling noises.  I had a similar problem myself not long ago with an older machine.

You can try a couple of things before assuming the worst tho'

First try booting to a system diskette (assuming you have one!) Then see if you can see C, D or H (you don't say if these are partitions on the same hard drive or different drives)

Next boot up to your BIOS (method depends on machine - eg hold down 'del', 'esc', 'F2' during boot up)
Try changing the 'primary boot drive' to D and reboot...
Try changing it to H and reboot...

Let me know the outcome.  If no success then hopefully you have backups of what was on the disk(s) and some spare cash for a replacement hard disk.

Good Luck - MorFF
MREDAuthor Commented:
Tried all this.  No success
The only thing you can do at this point is to attempt to run Fdisk on the drive and remove the partition, format the drive and reinstall the operating system. If this doesn't work you need to buy another hard drive. It does sound to me like your drive is toast or your controler is bad. It is probably one or the other. I am sorry to give you bad news but I have seen this too often before.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Webinar: Miercom Evaluates Wi-Fi Security

It's not just about Wi-Fi connectivity anymore. A wireless security breach can cost your business large amounts of time, trouble, and expense. Plus, hear first-hand from Miercom how WatchGuard's Wi-Fi security stacks up against the competition in our upcoming webinar!


He won't be able to run fdisk if he can't boot the machine.  The rest of your answer is an echo of mine.... ;-)


Can you expand on 'no success'  What was the result at each thing you tried.  This may point us better down the path of anything else it could be.  

I would get ready to accept the fact that your HDD is goosed.  (my original answer)

Cheers - MorFF

If you have Fdisk on the bootdisk you should be able to Fdisk the drive, if the drive is any good. I do think the drive is bad and that Fdisk won't work either. The only other option is a bad controller. It is worth a try before throwing the drive in the trash.
MREDAuthor Commented:
This is a computer my neighbor bought from me.  If she gets the computer back home I may be able to get more information.  It is about 5 years old, a 486 dx66, Seagate 850 hard drive divided into C and D drive (because the bios can't support over 540. She has compressed part of the C drive, creating the H.  The battery for the bios has never been replaced.  Could the battery be (part of) the problem? My gut feeling is as the experts are saying that the hard drive is done, is probably the answer.

Mr. ED
Hi Mr Ed,
  I think you are correct. I think the drive is toast. The battery is probably not an issue. Try to Fdisk the drive from a boot floppy and see if you can do that. Then Fdisk it back into two partitions and format them both. Sys the C drive and see if you can boot it. The data is probably lost on the drive. If this doesn't work, try putting and new controller card in first. They are only about $20 then if that doesn't fix it replace the drive.
the C fail could be two things:

bad hard drive or bad controller

due to the horrible rattling noise it sounds like the drive is dead, since its 5 years old theres no hope of a warranty. I just had something like this happen with my maxtor hard drive. I called them up and they got me a replacement drive. might wanna check them out if ur in need of a new disk, they have a 3 yr warranty w/ a "no quibble" replacement policy, so if it winds up being the controller and it toasts the new drive, u can get a new one shipped out right away.
MREDAuthor Commented:
Thanks MorFF, somberlain and daadams,
If you guys know how to split the points on this let me know. I Think you all have the answer.  A new hard drive on a 5 year old 486 don't sound like a real good idea to me. It might be time to say good-bye to an old 486.
Mr ED  

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.