Solved

Abend with install.nlm

Posted on 1998-05-11
3
463 Views
Last Modified: 2008-02-01
I have a friend running Netware 4.11 and he is trying to install the latest service pack.  When he goes to install a product not listed it causes an Abend, below is the Abend log.

Server SERVER1 halted Monday, 11 May 1998   3:46:37 pm
Abend: Server-4.11a: CPU Hog Detected by Timer

Registers:
    CS = 0008 DS = 0010 ES = 0010 FS = 0010 GS = 0010 SS = 0010
    EAX = D7F30EEE EBX = 030D2E4C ECX = 00000005 EDX = 0327AC40
    ESI = F90BB40C EDI = 0310967A EBP = 030D1D14 ESP = 030D1CEC
    EIP = 00000000 FLAGS = 00007002


Running process: Install Process
Created by: INSTALL.NLM
Stack pointer: 30D1C7C
Stack limit: 30C9010
Scheduling priority: 0
Wait state: 00
Stack: F802AAEE  ?
       --D7F30EEE  ?
       F802B5EB  ?
       F81B5E59  (INSTALL.NLM|InstallBIOSWriteSectors+A5)
       --030D24CC  ?
       F81AD3F5  (INSTALL.NLM|InstallGetToken+173)
       -F90BB409  (INSTALL.NLM|MPDetectInfo+3C49)
       --03109677  ?
       --00000008  ?
       F81B850B  (INSTALL.NLM|InstallBIOSWriteSectors+2757)
       --030D1EB0  ?
       --030D24CC  ?
       F81B5E59  (INSTALL.NLM|InstallBIOSWriteSectors+A5)
       --030D2E4C  ?
       F81B8032  (INSTALL.NLM|InstallBIOSWriteSectors+227E)
       -F90BB409  (INSTALL.NLM|MPDetectInfo+3C49)
       --00000000  ?
       --030D1D7C  ?
       --030D24CC  ?
       F81B5E59  (INSTALL.NLM|InstallBIOSWriteSectors+A5)
       --030D24CC  ?
       F81B5E59  (INSTALL.NLM|InstallBIOSWriteSectors+A5)
       F81B2B88  (INSTALL.NLM|InstallReadFile+2F5)
       --03253010  ?
       --032643B0  ?
       --00001340  ?
       F81B5E59  (INSTALL.NLM|InstallBIOSWriteSectors+A5)
       --00000000  ?
       --00001340  ?
       --00000000  ?
       --00001340  ?
       --00000000  ?

Additional Information:
    The NetWare OS detected a problem with the system while executing
    a process owned by INSTALL.NLM.  It may be the source of the problem or
    there may have been a memory corruption.

Can anyone shed any light on this?  Could it be corrupt memory?

Thanks
Roger
0
Comment
Question by:lindr
3 Comments
 
LVL 3

Accepted Solution

by:
paulnic earned 200 total points
ID: 1592379
Corrupt memory is not especially likely if this is the only time the server abends.  Searching for "install AND abend AND 4.11" on Novell's tech support knowledgebase turned up the following document, which traced another occurence of a similar problem to a bad copy of INSTALL.NLM.  Hope it works for your friend!

Peace^^Paul

Abend Going into Products Options in Install  (Last modified: 16DEC1997)

     This document (2933005) is provided subject to the disclaimer at the end of this document.
         
     Symptom

     When customer tries to go into products option in install the server abends. The running process is the install.nlm. Tried renaming the products.dat file thinking it was corrupt, but the server still abended. Tried loading the install.nlm from a floppy that had been copied from iwsp4a. This time the server did not abend.

     Solution

     Install.nlm was corrupted when iwsp4a was installed. But it would only abend going into products option. Once a clean copy of install.nlm was used the abend was resolved.

                                     Abend Going into Products Options in Install
      Document ID:
                          2933005
      Creation Date:
                          12DEC97
      Modified Date:
                          16DEC97
      Document Revision:
                          1
      Novell Product Class:
                          NetWare OS
      Novell Product and Version:
                          NetWare 4.11


0
 
LVL 1

Author Comment

by:lindr
ID: 1592380
Thanks for the prompt answer, I'll get him to try it out.  I did try searching the knowledge base but didn't come up with that TID.  Must practice my searches :o)
0
 
LVL 3

Expert Comment

by:brosenb0
ID: 1592381
Something else to look at.  We had a similar problem here and it was due to install auto-loading a bad version of Btrieve (used to manage the product database, products.dat).  Reloading Btrieve fixed the problem, however, looking at the stack dump, yours seems to be a stuffed install.nlm as paulnic said.

BR.
0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
NETWARE 5.1 - CREATE A DUPLICATE SERVER FOR BACKUP 6 440
finding permissions 6 641
IPX/SPX on Windows 7 (64-bit) 6 12,426
Replicate files using Rsync 5 343
When you’re making plans to join the modern business race, you should analyze various details that may affect your results. Nowadays, millions of businesses are trying to grow into established and appreciated professional enterprises.
Learn how the use of a bunch of disparate tools requiring a lot of manual attention led to a series of unfortunate backup events for one company.
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now