Problem installing X windows using 3D Xpression card

I am running RedHat linux (2.0.23) on a machine with 64 Mb of RAM and ATI 3d Xpression graphics
    card. I have used Xconfigurator to set up XF86Config file. When I try to execute startx, I get an empty
    grey screen with a cursor, which I can move around but cannot get any X windows. Pressing left mouse
    button elicits a beep, right button does nothing. I have two-button PS/2 mouse which seems to be
    recognized by the system (and Xconfigurator too). What should I do?
andrzejAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
adtConnect With a Mentor Commented:
I had a similar problem with RedHat when upgraded X.   I had a file called .Xclients which
was being loaded.  Deleting or renmaing it to .Xclients.old should fix your problem.
Mkae sure you .xsession is not symlinked to this file.
To customize your personal settings, you can copy the system xinitrc
</usr/X11R6/lib/xinit/xinitrc> to your personal .xsession.

Let me know if you need more than this

0
 
andrzejAuthor Commented:
Edited text of question
0
 
andrzejAuthor Commented:
Edited text of question
0
 
aszureCommented:
You probably dont have a window manager configured. I would go to RedHat's ftp and get the rpm for fvwm or fvwm2. Then go into the home directory (probably /root). and make a .xinitrc file.
type this
pico .xinitrc
Then type "exec fvwm" or "exec fvwm2" depending on which one that you choose. Then hit CTRL-X
And save it.
If ya need somemore help mail me aszure@mailexcite.com
0
 
andrzejAuthor Commented:
I have fvwm and fvwm2 installed. My startx script points to xinitrc file which in turn contains the line 'exec fvwm'. I have
tried to change it to 'exec fvwm2' but this did not help.
0
All Courses

From novice to tech pro — start learning today.