• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 241
  • Last Modified:

syslog doesn't log

One line of syslog.conf is like this:
*.err;kern.debug;daemon.notice;mail.crit;user.none      /var/adm/messages
My problem is:
1. If I do a    logger -p daemon.notice "test message"
I will get a "test message" in /var/adm/messages
2. If I do a cd /tools/abc ( /tools is an automount point and abc doesn't exist under /tools ) I didn't get any error message which this message would show up before and besides some other machine's messages file will imediately show the error messages like "automountd[135]: mount of /tools/abc failed" .

I tried to cycle the syslogd many times but didn't help at all.

Thanks for the help.
Emay
0
Emay
Asked:
Emay
1 Solution
 
OMCommented:
Did you try
daemon.* /var/adm/messages
?
0
 
braveheartCommented:
I would have thought that "user.none" in your config file would disable messages from cd, although I may be wrong. Do you get the same results when using "user.err", "user.warning" and "user.notice". Mind you, this is bound to generate far more messages than you will usually want.
0
 
EmayAuthor Commented:
No, it did not work! Thanks anyway.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now