AcerOpen F34PV disconnects my mouse


I have installed my modem AcerOpen F34PV in my PC, with Windows 95 OSR2. And the problem comes when i work with my modem, for example connecting to the internet. The mouse dies when the computer begin the dialg with the modem, it seem obviously a conflict between IRQ or I/O addresses. But the problem is that there is no conflict! The IRQs are OK, i have COM4 with IRQ3 (like a COM2 unused) and 2E8-2EF (also unused). My mouse configuration is IRQ4 and I/O 03F8-03FF.   The modem works fine, i can navigate perfectly, but with the keyboard... :)

when i installed the modem in my Windows NT (same PC) everything worked. But now i have Windows 95...

Where could be the problem??
ineilaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lturnerCommented:
Best suggestion I would have is to change your modem from com4 to com2.  Disable com2 in your bios, or change it to com4.  I hope this resolves your problem.  Les
0
ineilaAuthor Commented:

I can't change the com port with BIOS. And the COM4 seems to be the only COM this Internal Modem supports...
0
OttaCommented:
A serial-port mouse usually uses COM1 and IRQ 3.
The second serial-port usually uses COM2 and IRQ 4.
If your modem is configured as COM3,
then it probably also tries to use IRQ3,
which creates the "conflict".

So, use BIOS-setup to disable the "onboard" COM2 port,
and set your modem to COM2, and it will work.

Or, use BIOS-setup to enable the "onboard" COM2 port,
and set your modem to COM4, and it will work,
as long as no other device is using IRQ 4.

0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

OttaCommented:
Revised (thanks, RalphM, for spotting my dyslexic writing)
+++
A serial-port mouse usually uses COM1 and IRQ 4.
The second serial-port usually uses COM2 and IRQ 3.
If your modem is configured as COM3,
then it probably also tries to use IRQ 4,
which creates the "conflict".

So, use BIOS-setup to disable the "onboard" COM2 port,
and set your modem to COM2, and it will work.

Or, use BIOS-setup to enable the "onboard" COM2 port,
and set your modem to COM4, and it will work,
as long as no other device is using IRQ 3.
(You don't need to have any physical devices on COM2 or COM3
to get COM4 to work correctly.)
0
ineilaAuthor Commented:
RalphM:

My modem has jumpers to set the IRQ and I/O address.
It has instructions to install the modem, and it says
i must create a com3 and com4 port in windows 95, where
com4 must have configures like i selected with jumpers.
I selected: IRQ3 2E8.
With Windows NT everything works, the problem comes with Win95. I reinstalled the win95, and the problem continues.

0
amckerrCommented:
I have had similar problems in the past.  The answers you have been getting are on the right lines: you have an interrupt conflict.  However, this is coming from (my guess) your modem not being plug and play compatable, so windows 95 is having difficulty allocating IRQs and I/Os to it.
You want to reserve the IRQ you use for you modem in BIOS as non-plug'n'play.  Most BIOSs will let you do this (the BIOS on my ASUS TX97 does anyway).
Make sure that you put your mouse on a different IRQ from your modem (best to leave the mouse on COM1 and put the modem on COM2), because getting more than 2 serial ports to work can be a royal pain in the ass.  The directions you have already got from RalphM & Otta cover this very well.
Restart Windows and with any luck Windows will allocate all the requried system resources except for the on you reserved.  Make sure that the COM2 port matches the jumpers on your modem.  Change the modem setup to look at COM2 in control paneland hopefully your problem is solved.  
NT 4 is not plug'n'play, and therefore relies on a user setting up everything correctly.  Windows 95 is supposed to be plug'n'play, but is quite often plug'n'"you've go no chance".
Good luck and I hope this clears up your problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ineilaAuthor Commented:
The answer seems good. The problem is that my BIOS can't manage ports.Is very simple.

I'm thinking in changing my modem.

Thanks.


0
OttaCommented:
> The problem is that my BIOS can't manage ports.
> Is very simple.
> I'm thinking in changing my modem.

Changing your modem is unlikely to help.
Most "modern" motherboards have "built-in" COM1 and COM2 ports.
So, you need to use BIOS-setup to "disable" the COM2 port,
if your modem is going to use COM2.
Or, you need to set your modem to COM4
(COM3 tends to conflict with the mouse on COM1),
which can co-exist with COM2 (as long as you do not actually
_USE_ the COM2 port).

When you start your computer, which BIOS does it state that it is?


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.