Solved

MIDI IN no longer works

Posted on 1998-05-18
20
289 Views
Last Modified: 2013-12-29
MIDI IN use to work well on old HD.  
No longer works since reinstalling Win 95 on to new HD.
No other hardware changes made.  
MIDI controller and MIDI cable ok.
Wave files, MIDI OUT & Joy stick still works well.

SYSTEM:
Pentium 120, Intel Advanced/EV Endeavor motherboard,
on board Creative Labs VIBRA 16S CT2504, 48MB RAM, Windows 95.

SETTINGS:
Control Panel\Systems\Device Manager:
 Creative Sound Blaster 16 Plug & Play
 I/O 0220-022F & 0330-0331 & 0388-038B
 Interupt 10, DMA 03 & 07
 No conflicts

ControlPanel\Audio:
 Playback: SB16WaveOut(220)
 Recording: SB16WaveOut (220)

ControlPanel\MIDI\Single Instrument:
 MIDI for External MIDI port
   \External MIDI Instrument
 MIDI for Internal OPL2/OPL3 FM Synthesis
0
Comment
Question by:bwong110297
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
20 Comments
 
LVL 14

Expert Comment

by:smeebud
ID: 1713024
Did you re-install everything, or transfer the data to your new HDD?

What are you using you midi for, what kind of software?

Bud
0
 

Author Comment

by:bwong110297
ID: 1713025
All software was reinstalled.
I use Music Time, by Passport Designs, most of the time,
but a few other MIDI apps as well.  
I use it to transcribe music.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713026
Does that software have MIDI IN AND MIDI OUT PORT SETTings in you software settings.

bud
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 

Author Comment

by:bwong110297
ID: 1713027
All MIDI programs have MIDI setting to be made.  The drivers are listed and selected in each of the apps.  None of the apps show conflicts or problems.  

I'm beginning to wonder if it is a hardware failure reather than a software configuration prolem.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713028
Do you get a message when you try to input??
And of course your "midi in port" is set correct?

Bud
0
 

Author Comment

by:bwong110297
ID: 1713029
When I play my Yamaha keyboard, I simply get no response in any of my MIDI apps. No error messages.  Nothing.

I tried a MIDI monitor, called Windows MIDI Watcher.  It should allow me to view all of the MIDI data flowing into the computer as I play notes.  Nothing is getting through.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713030
So nothing is going out.
I use The new CakeWalk and Korg M1.

It sounds like the local on you yamaha may not be turning off.

let go with troubleshootings 1st rule, the obvious.
Check sound card to see if it's seated properly, cable hooked up properly.
Most Important in looking at the obvious, [I know, you've probably done this]
you cables, In to out, and out to in.

I just made that mistake the other day.

Bud
0
 

Author Comment

by:bwong110297
ID: 1713031
I have 3 different MIDI keyboards.  None have LOCAL ON/OFF.  Everything is sent.

Vibra is a 16 bit sound chip that is built in to my Intel motherboard.  There is a small audio connector card that provides the usual connectors to the back of the computer.  I have reseated it a couple of times.

The MIDI cable connects to the joystick port of the computer, and the MIDI IN connects to the keyboard OUT on the controller side.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713032
The settings you show in your question; were they the same before reinstall??

If you can remember.
Bud
0
 

Author Comment

by:bwong110297
ID: 1713033
Current settings are very close to the settings before the reinstallation, but I doubt if they are exact.  And I have tried numerous combinations of drivers and settings since.

A new finding:
MD CD-ROM will not play audio CD's through the sound card anylonger.  This the first time I have tried to do so since reinstalling everything on the new HD.  It works fine in all other respects.  Headphone jack works ok.  MS CD Player & MS Media Player work as usual without error messages.  I'm still playing all wav, midi and Real Audio files ok.

Bud,
Forgive me if I am using EE wrong, but since your last entry seems to be a Comment, rather than an Proposed Answer, I think it is more appropriate for me to reopen the question.  Thanks for your assistance.

Brace Wong
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713034
You were right to reject me. I just do that to get peoples attention. i'd explain why but it's a long story,

I think that the Neww HDD blew your old drivers out of the water.
Go to http://www.creaf.com/home.html
and get Vibra drivers.

What brand of CD-ROM do you have?

Bud
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713035
Also,
http://www.creaf.com/wwwnew/tech/ftp/ftpinx.html

http://www.creaf.com/wwwnew/tech/ftp/ftp-pat.html#sb16
v24w31up.exe
      File Date:
                 970808
      File Size:
                 1,175,468 bytes
      Description:
                 Updated Windows 3.1 Install disk 1 for Vibra 16/24x kits with install software
                 SBCD-CDS1D-1-US or GA64-CDS3D-1-US.
                 GA64-PAS3D-1-US (Revision 1)

                 Corrects problem of Vibra 16/24x kits shipped with a CD-ROM that will not install on a
                 486 system running DOS/WIN3.1x.
============
settings
Sound Blaster ASP/16-bit stereo
          Port: 220
          IRQ: 5
          DMA: 5
          Midi: OPL3
================

0
 
LVL 1

Expert Comment

by:pcservice
ID: 1713036
Is it still working with the old HD ? If yes try to reinstall the Mini MPU401 comp, and check for conflic
0
 
LVL 1

Expert Comment

by:albberat
ID: 1713037

 Have you ever tried to double click the Sound Volume Icon at the taskbar(lower-right corner). After you double click it you will find a dialog box showing those mixers. See if Midi is checked. On the upper-left  of this sound volume dialog box there is a menu, I think it says Properties(Files...) or similar thing. Since you have been through a lot this will not cost you more than 30 secs. See and find out there the midi leaks. Like Select Recordings see if midi-in is selected or similar stuff you are going to find there.(Sorry I do not have a Windows machine in front of me now). I think there is your problem since you have no conflict in DMA or IRQ's.

 Good Luck ....

 
0
 

Author Comment

by:bwong110297
ID: 1713038
Albberat,
Volume Control looks ok.  In Recording, MIDI is selected; the MIDI box is checked, and the volume is up.

Bud,
I have investigated sites from Creative Labs before.  I've downloaded new drivers and installed them too.  But I'll look again. Maybe I missed something.

PCService,
I tried installing Microsoft's MPU-401 Compatible, but the Device Mgr says "...device not present, not working properly, or does not have all of the drivers installed...".  I don't know what the specific problem is.  Is OPL2/OPL3 FM Synthesis the same thing?

Reinstalling Win95 doesn't do any good.  Does anybody think that I would be successful in getting MIDI IN back if I deleted Window and reinstalled everything? I'll do it if I have to.

Follow up, re: Audio CD's not playing 5/22 -
The CD audio problem was totally unrelated to the original MIDI problem.  It was simply a loose audio connection connection between the CD-ROM and the sound board.
0
 
LVL 14

Accepted Solution

by:
smeebud earned 200 total points
ID: 1713039
I think you should run your hareware wizzard in control panel. If that bears no fruit, before you wipe out your HDD and start over, you can lose nothing in using this metod 1st.
---------------
Re-Setup Using the "setup  /p f" Switches
X:\setup  /p f
Where X is your CD drive letter
This will cause windows 95 to re-examine your setup.
This will clean, read and rewrite your Win.ini and System.ini,
without over-writing your updated dll's vxd's extensions.
f - This switch enables Clean Registry mode. It forces Detection
to clean and correct the root branch of the registry before starting.
This switch is ignored when Setup is run in the Windows 95
graphical user interface (GUI).
When setup prompts you for "Typical or Custom Setup", choose Custom.
This allows you to have control over every step of the setup.
This will do a compare and replace missing or corrupted files and
will take you back where you were before the error.
From dos insert your CD and run from your cd this command...
(setup  /p f) When setup prompts you for "Full or Custom Setup",
choose Custom. This allows you to have control over every step of the setup.
This will do a compare and replace missing or corrupted files and will take
you back where you were before the error.

This has Become a;
"Standard Procedure". It's not always a fix all, but it never
hurts to try it. I've never seen any ill effects from it yet. The
only thing I've seen it do negative is once in a while an association
or two may get lost. Which Is easy to fix. I always recommend a
Registry backup along with this for safety.
ALWAYS BACKUP YOUR REGISTRY FIRST!
Get WRP. WRPV3.ZIP is the Best and easiest Backup/Restore I've Seen.
Go To: http://www.webdev.net/orca/ Search WRP
                                      FOR YOUR CONFIDENCE
                          RESTORE WINDOWS FILES/VERIFY INSTALL OPTION
http://support.microsoft.com/support/kb/articles/q141/8/41.asp 
When you run Windows 95 Setup from within Windows 95, the
Restore Windows Files option (also known as
the Verify Install option) may not appear.

CAUSE

This behavior can occur if a title in the Setuplog.txt file
contains more than 32 characters (including spaces). Titles
are also known as section headers, and begin and end with
brackets ([]).

RESOLUTION

Disable any titles containing more than 32 characters in the
Setuplog.txt file. To do so, follow these steps:

1.Restart the computer. When you see the "Starting Windows 95"
message, press the F8 key, and then
choose Command Prompt Only from the Startup menu.

2.Type the following lines at the command prompt:

attrib -h setuplog.txt
edit setuplog.txt

3.Place a semicolon (;) at the beginning of any title
containing more than 32 characters.

4.On the File menu, click Exit. Choose Yes to save the
file when you are prompted.

5.Restart the computer and then run Setup again.

MORE INFORMATION

The Restore Windows Files option includes the following
choices:

Restore Windows files that are changed or corrupted
Copy all Windows files again

Choosing the first option replaces only files that are
missing or have changed since the last time you ran Setup.
Choosing the second option replaces all files and allows
you to change the installation folder.

Note that if any of the following lines are missing from
the Setuplog.txt file, the Restore Windows Files option
will not be available in Setup:

restart=passed
started=passed
installdir=<directory>
reboot=1

                                  Other setup Switches, i.e; SETUP /p b
When running setup, type this as the command line: (this
presumes that your cd rom drive is drive "D")

D:\SETUP /p b
This will enable you to step through each detection step.

If Windows 95 hangs on shutdown reinstall Windows 95
to a different folder to rule out the possibility of damaged files.
For example, if Windows 95 is currently installed in the Windows
folder, install it to a Win95 folder. If your computer has a Plug and
Play BIOS, reinstall Windows 95 using the "setup /P I" command
to rule out a defective Plug and Play BIOS.

Bud
0
 

Author Comment

by:bwong110297
ID: 1713040
Bud,

Thank you.  Life is good again.  
I ran setup with "/p f", and MIDI IN works again.  
When I entered "setup /?", the "/p f" option wasn't listed.  Where did you get this info?
0
 

Author Comment

by:bwong110297
ID: 1713041
Bud,

I thought I was awarding you 200pts. I hope you got it. I don't understand why the data at the top of this page says I have 1100pts and this was a 20pt question, while my current balance is 900 (200 less than before).  

Let me know if you did not receive your points.

Brace
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713042
Setup Switches for Win95
http://support.microsoft.com/support/kb/articles/q128/4/00.asp

I don't know if I got the points or not.

Don't worry about it, I've got plenty::))

Bud
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1713043
As I look, no I didn't recieve the points.

We ouught to fix this so the board works right.

Please write linda@experts-exchange.com and tell her will you.

reference
http://www.experts-exchange.com/Q.10053306

Thanks Brace
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article summaries thoughts and ideas from two years of sustained use. It provides good reasoning to make the jump to Windows 10.
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question