NT TCP/IP Routing problems with multiple network cards

I have two NT servers ('A' and 'B'),  each with 3 network cards. I have configured TCP addresses as below and have RIP installed on both servers, with IP forwarding enabled. The subnet mask is set to 255.255.255.0 on all interfaces, including the clients.

My problem is that machines can only see (ping) machines on the same subnet. Trying to ping C1 from C2 or C4 from A doesn't work reporting no route to host.


                                       'A'         192.168.2.x           'B'
192.168.1.x   C1  ---------+---------------------------------+---------  C4 192.168.4.x
                                        |                                           |
                                        | 192.168.5.x                       |  192.168.3.x
                                      C2                                        C3              

Server 'A' has NICs with addresses 192.168.1.1, 192.168.2.1 and 192.168.5.1
Server 'B' has NICs with addresses 192.168.3.1, 192.168.4.1 and 192.168.2.2
The clients are configured with an appropriate address for each subnet.

What should the correct subnet mask and default gateways be for each of  the NT server interfaces and the clients? Does the fact that I am using private IP addresses cause problems with the routing?

Thanks for any help,

Ron

omega1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tonpCommented:
Your easiest solution here would be to make it a class B network, using 172.16.x.x and a netmask of 255.255.0.0. That way, they all have the same network number and are able to cummunicate with each other. (There's no need to change the IP number for this to work of course, so you can try this out with the 192.168.x.x numbers first).
If that's not what you want, is probably best to set up different routes for each netid. Using the route command (from a command prompt just type 'route') you can manually add the various gateways. For example, on machine A you need to add a route for 192.168.1.0 (255.255.255.0) with the exact IP number for the 192.168.1.x NIC (should also work with the 192.168.2.x address I guess). To reach machine B's 192.168.4.x, add a route specifying machine's B 192.168.2.x exact IP address for 192.168.4.0.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
omega1Author Commented:
I think this may have worked, however I found that the problem was actually the default gateways on each of the NICS.

192.168.1.1 - Should have no gateway
192.168.5.1 - Should have no gateway
192.168.2.1 - Gateway 192.168.2.2
192.168.2.1 - Gateway 192.168.2.1
192.168.3.1 - Should have no gateway
192.168.4.1 - Should have no gateway


Having changed the settings to match these, the routing now works.

Thanks for the help.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.