keep a copy of using email!!

I want set the email system on linux, the root(or administrator or a user) can receieve a cc mail of what other users send and receieve.

Anyone know how to setup it on sendmail???

thanks
boingoneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

muesliCommented:
Is this ethical?  If you can't configure it yourself, maybe you shouldn't be doing it.  See sendmail.cf
0
ahoffmannCommented:
If it's a standalone system, sendmail.cf usually needs not be changed, just start sendmail.
If your system is part of LAN/WAN, you first need to setup DNS.
If you just want to reseive mail from a mailhost use POP3.
0
boingoneAuthor Commented:
The reason to set like this is, the root or administrator want to receieve a copy of  mail of what other users send and receieve. How to setup it on sendmail ?
0
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

rbrCommented:
To option is -O MeToo="root"

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
boingoneAuthor Commented:
how? setup at which file(s)?
0
rbrCommented:
You should have a /etc/sendmail.cf file. Use this one.
0
boingoneAuthor Commented:
just add a line ( -O MeToo = "root" ) at any part of sendmail.cf and restart it will ok?
0
rbrCommented:
Look for a me too line.
I could look like OmFalse alter this in
Omroot
or if it looks like O MeToo alter this in
O MeToo="root"

0
boingoneAuthor Commented:
I edit the following line at /etc/sendmail.cf

# send to me too, even in an alias expansion?
O MeToo="root"

and reboot again, my Linux is slackware 2.0.30

I try both send out and receieve by a user, but the root still can't get any mail of that user!

did I do the right thing?

thanks
0
ahoffmannCommented:
I don't think that the O MeToo  option will do what boingone wants. It just makes a copy of each mail send back to the originator.

Try to modify the  Mprog  and/or  Mlocal  macros (sorry don't have the bat-book handy right now for the syntax). You must add the Cc: or (for you "big brother" watching Bcc:) to the command line of the appropriate deliver program.
0
boingoneAuthor Commented:
can u tell more detail on how to set it up on the macros
0
ahoffmannCommented:
try following in sendmail.cf:

   HBcc: root

or

   H?P?Bcc: root
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.