Change Serial to an PS/2 mouse?

Whats the excact "procedure" to fix this?

The new mouse is MS PS/2-mouse, and I
even tested it on a different computer to see
that there was nothing wrong it.
I removed the old mouse drivers from Control Panel
and took away the lines from autoexec.bat,
turned off the computer and plugged the new mouse
to the machine, but get anwers like:
"Keyboard error or keyboard not present".
When I checked for conflicts in IRQ´s or
similiar, there was none!
Thanks in advance!!!
Peter
peterxAsked:
Who is Participating?
 
nigesConnect With a Mentor Commented:
You could have a jumper on your motherboard that sets some sort of ps/2 setting. Alternatively, I have limited knowledge of this, but I have seen keyboard ports the same size and pin no. as a ps/2 mouse port. You might be plugging it into this.....

Read your motherboard manual for ps/2 settings.

The keyboard error could also be a totally isolated problem, that coincidently started when you got your mouse, it could be a faulty keyboard lead or socket, try jiggling it around a bit.

Another problem that it could be is in the bios settings, there could be an option that has ps/2 set to disabled or similar, but I doubt this would produce a keyboard error....

--Nige
0
 
cumboCommented:
Hi Peterx,

If Niges' answer doesn't do the trick we need some more information. Why are you changing to a PS2 Mouse? Was the PS2 port already on your computer? If it was are you sure it is plugged into the Motherboard? Windows 95 automatically detects which ever type of mouse is installed. You don't need to remove the serial driver to have Win 95 detect a PS2 mouse. Sounds like the PS2 mouse is taking the keyboard IRQ. Ps2 mouse should use IRQ 12 by default. The keyboard should be on IRQ 1. Is the keyboard PS2?

Cumbo
0
 
peterxAuthor Commented:
Thanks both Niges & Cumbo :)

when I got my new motherboard,
I was using a serial mouse,
and in such a hurry to test some progs,
and games, that I didnt bother too much
which way the connectors for the PS/2 where..
so they where wrong...
thanks guys
peter
0
 
nigesCommented:
No worries, glad it works...

--Nige
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.