Solved

Can't install Lilo - Bad cyl #

Posted on 1998-06-02
9
222 Views
Last Modified: 2013-12-15
I just tried to install Slakware 3.4 on a 2 GB IDE disk. When I tried to install Lilo, it complained about my cylinder number 2081, which is bigger than 1023... This sounds awfully much like old DOS. :-( How do I fix it?
0
Comment
Question by:obg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 1

Expert Comment

by:m4rc
ID: 1627439
from what i understand, it doesnt mean you cannot use fdisk w/ that drive.  i just installed slackware 3.4, and recieved the same error.  the reason was because the drive was so large.  linux can handle big drives w/o problem, but lilo, apparently, is only good at recognizing/accessing cylinders up to a certain point.  i use lilo and it works fine, because my main partition starts before cylinder 1024.  does your system boot up to linux?  w/ lilo?  or a boot disk?  if not, you might try repartitioning and arrange your / close to the front, like /dev/hda1, for example.

0
 
LVL 2

Author Comment

by:obg
ID: 1627440
Thanks for your quick answer. I'm sorry to reject it, but I can't believe that there is no way to make Lilo able to handle bigger disks... As you said, fdisk seems to work fine with that drive.
0
 
LVL 1

Expert Comment

by:m4rc
ID: 1627441
perhaps there is a way to tell lilo about the geometry of your drive.  try looking into lilo options like:

disk=device-name
              Defines  non-standard  parameters for the specified
              disk.  See section "Disk geometry" of user.tex  for
              details.

       disktab=disktab-file
              Specifies  the  name  of  the disk parameter table.
              The map installer looks for /etc/disktab if  `disk-
              tab'  is  omitted.  The use of disktabs is discour-
              aged.

0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 3

Accepted Solution

by:
marcelofr earned 100 total points
ID: 1627442
It's not a lilo problem, it's BIOS problem: Linux depends on BIOS to recognize partition table, detect bootable partition, *LOAD* and exec partition table boot program which will finally load and pass control to lilo to load the kernel...

-- Marcelo
0
 
LVL 2

Author Comment

by:obg
ID: 1627443
I know, but new BIOS:es can handle large disks. Why can't lilo keep up?
0
 
LVL 3

Expert Comment

by:marcelofr
ID: 1627444
New BIOSes can handle large disks but NOT in NORMAL layout. You must use LBA or whatever trick your bios gives you to remap the disk geometry.

Really have you installed ANY OS booting from a partition outside 1024 cyls without a disk driver (which surely LILO supports)?
0
 
LVL 2

Author Comment

by:obg
ID: 1627445
I know that too, but why can't Lilo use LBA, then?

I must admit, I haven't tried that many boot-menu-systems. I used OS/2's boot manager for a while. - Until I stopped using OS/2 a year (or two) ago. I am not used to speak positively about M$, but isn't their boot upp menu capable of booting NT/95 from large disks?
0
 
LVL 3

Expert Comment

by:marcelofr
ID: 1627446
LILO DOES USE LBA... Maybe your bios gives you more than 1023 cyls EVEN with LBA... Again the problem is a 10 bit number...

Actually I'm using a one partition 6Gb disk with a translation named extended (I don't remember exactly) without any problems... It uses 780 cyls of 4Mb each..

Good Luck,

-- Marcelo
0
 
LVL 2

Author Comment

by:obg
ID: 1627447
?!?!? I don't know much about the LBA standard at techniqual level, but I do know that my bios (which is almost brand new) reports LBA-disks with far more than 1024 cylinders. If you use a large disk, I'd guess you're lucky having got your boot-strap at a sector which can be contained within that old 16-bits word...

BTW: The problem is already solved long ago. However, the subject is still interresting.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question