Bad Fault MS Dos Extender

Installing Win95 CD OS2R2 on IWILL mb w/32 meg (2 simms) goes OK, until just past the point where it makes the bootable floppy, then goes into the file copy from CD to HD.  At different points during this process, it always hangs up with "BAD FAULT IN MS DOS EXTENDER" with varying memory addresses.
What does the msg mean ?  What is the problem ?  What can I correct ?
On an older BCM mb, the whole thing goes like clockwork all the way thru, but this board is in use.
rgbatemanAsked:
Who is Participating?
 
linda101698Connect With a Mentor Commented:
I am posting rgbateman's solution as an answer so it can be saved in the previously asked questions.

Linda Gardner
Customer Service @ Experts Exchange

 I have found the answer
     which has to do with the MB itself being too fast for EDO 60 ns simms.  This
     will vary from MB to MB despite the fact that most MBs now have PIPELINE
     BURST CACHE (PBSRAM) which has access times of 4.5 ns to 8 ns.  I've
     replaced the simms with a 32 meg unbuffered 10ns dimm.  All is well.  The
     install now goes from start to finish without a hitch.  So if anyone gets "Bad
     Fault in MS Dos extender", this is a memory speed mismatch between
     external cache and main memory.  Note: pbsram has simultaneous read and
     write.  Main mem does not.
0
 
waynebCommented:
disable all anti-virus in bios also disable all shadow ram ie: video bios shadow and system bios shadow set memory timing to higher number if at 60ns try 70ns set to auto configuration.
0
 
waynebCommented:
disable all anti-virus in bios also disable all shadow ram ie: video bios shadow and system bios shadow set memory timing to higher number if at 60ns try 70ns set to auto configuration.
0
Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

 
waynebCommented:
Also no autoexec.bat or config.sys, copy win95 cabs to directory on harddrive and run setup off the harddrive not the cdrom.  So reboot with no cdrom drivers loaded or any other tsr in memory.
rule out a boot sector virus.
0
 
rgbatemanAuthor Commented:
wayneb response is appreciated, but already tried as suggested by tech support at IWILL.
MB has only two speed settings; 60 or 70.  Have tried both.
Also tried disable the external cache, but Win95 install wouldn't have it that way.  I've decided to go to the extra expense of purchasing DIMM memory and trying that.  Will post the result.

0
 
rosscoeCommented:
when you go to setup win95 use the command line:

setup /is /im

Try this first. If that doesn't work, make sure that you have himem.sys and emm386 loaded and that DOS is loaded high. Basically, you need more that about 580k memory free.. But try with the switched first!
0
 
smeebudCommented:
Don't buy memory till you optimize what you have.
=========
How To Optimize DOS Memory Under OSR2? The EMM386 NOEMS BUG

If you are using the EMM386 memory manager with the NOEMS or RAM switch, your upper memory and extended memory is lost
when restarting in DOS mode. All drivers and devices then load into low memory (causing a shortage of low memory). Here's a
sample config.sys line which causes the bug.
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS X=A000-C7FF
Solution: None.
Workaround: Some users appear to not have this problem at all, for whatever reasons. There seem to be users the suggestion works
for, and users the suggestion doesn't work for. So, here they are:
Suggestion 1: Use an older version (previous Windows95 or DOS version) of EMM386.EXE.
Suggestion 2: Use the AUTO switch instead of NOEMS or RAM.
Suggestion 3: Make sure you load SMARTDRV as well.
NOTE: The SMARTDRV option is a topic of great debate; Experiment.
Suggestion 4: Use the RAM ON switch instead.
Suggestion 4: Do not allow the doublespace driver to load.
Suggestion 5: Upgrade to DirectX 4 (DirectX 2 is bundled with OSR2).
Suggestion 6: Use the "MS-DOS Prompt" icon/.pif instead of booting/restarting to DOS. Customize the settings of this .pif.
----------
Fun, 32-Bit Style Game users, listen up!
For maximum DOS memory in an MS-DOS session, add the line LocalLoadHigh=1 to the [386Enh] section of SYSTEM.INI. Players
of Duke Nukem 3D and Quake-or anyone who plays a game that uses 32-bit DOS extender software-will reap the benefit of that much
more memory.
----------
Low Free Conventional Memory with OEM Service Release 2
http://www.microsoft.com/kb/articles/q156/3/32.htm
There is so much information on memory and OSR2 that I couldn't put it all here. Do this please;
Go to; http://www.microsoft.com/kb/default.asp
At Step 1: Choose Windows 95
At Step 5: Enter as a Search Phrase "msdos.sys and memory"
----------
New in OSR2 is support for Hard Drive/CDROM Direct Memory Access. With DMA enabled, no processor time is used to access the
hard drive or CD ROM. The result is an improvement in overall system performance. However, the default for DMA is disabled (for
the default OSR2 Bus Mastering IDE controller drivers)!
Note that varying hardware configurations will show varying improvements in system performance when DMA is enabled.
To enable HD DMA, go to Control Panel > System > Device Manager > Disk Drives. Highlight your hard drive, click properties. Click
the "settings" tab. Check the box next to "DMA." Restart the system when prompted, and repeat for any additional hard or CD ROM
drives.
NOTE that the DMA checkbox only appears 1) for IDE drives, and 2) only if the default OSR2 bus mastering IDE controller drivers
are installed and configured correctly. Some IDE drives do not support Bus Mastering. To determine if your hardware supports Bus
Mastering, do the test described at http://www.microsoft.com/kb/articles/q159/5/60.htm.
OSR2 supports Bus Mastering, but only by checking the DMA box, is Bus Mastering turned "on."
Note that the DMA check box only appears when using the default Windows95 OSR2 Bus Master drivers. If you are using non-bus
mastering drivers, the DMA box won't show up because Bus Mastering cannot be enabled. If you are using other Bus Mastering
drivers, the DMA box does not show up because it is enabled by default, and you don't have the option of disabling Bus Mastering.

Bud
0
 
rgbatemanAuthor Commented:
ROSSCOE response is appreciated.  But SETUP /IS /IM was no help; in fact caused a gpf in
SUWIN.  Using HIMEM.SYS is a must always.  But I have found the answer which has to do with the MB itself being too fast for EDO 60 ns simms.  This will vary from MB to MB despite the fact that most MBs now have PIPELINE BURST CACHE (PBSRAM) which has access times of 4.5 ns to 8 ns.  I've replaced the simms with a 32 meg unbuffered 10ns dimm.  All is well.  The install now goes from start to finish without a hitch.  So if anyone gets "Bad Fault in MS Dos extender", this is a memory speed mismatch between external cache and main memory.  Note: pbsram has simultaneous read and write.  Main mem does not.
NO FURTHER RESPONSES NEEDED, BUT I DO APPRECIATE THE EFFORT(S).

0
 
smeebudCommented:
rg,
Please write
linda@experts-exchange.com and ask here to remove your question, and get you offered points back.

Common curtesy,
Regards,
Bud
0
 
rgbatemanAuthor Commented:
SMEEBUD evidently is quite knowledgable, but I couldn't see where anything he said would be of help in answering my specific questions.  I've sent a note to LINDA as requested to have my question deleted, as I have found the answer myself.  
0
 
smeebudCommented:
Good man rg, that was the point.

Otherwise it just hangs around here active forever.

Bud
0
All Courses

From novice to tech pro — start learning today.