Solved

IExplorer or IIS locks the file after viewing it

Posted on 1998-06-12
7
553 Views
Last Modified: 2013-12-25
I am using MS IIS v4 from the Option Pack, and viewing the web with IExplorer 4. After viewing a file located on my server, either Explorer or IIS locks the file and I can't change it for about a minute. This is very annoying when creating a web and finetuning the layout. Does anyone recognize the problem?

Thanks for any help,
Martin
0
Comment
Question by:mnprsd
  • 4
  • 3
7 Comments
 
LVL 28

Accepted Solution

by:
sybe earned 70 total points
ID: 1858301
This is a known but in IIS4, there are several ways to get around it:

1. edit the registry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\InetInfo\Parameters\

Change or add (DWORD): ObjectCacheTTL and set it to 0
Change or add: DisableMemoryCache and set it to 0

2.
Those were not in enough in some cases I have seen. Then there an additional (hard way) solution: let IIS4 treat HTML files as ASP (because ASP does not have that problem)

That can be done in the IIS-manager, properties. I don't have it here right now, but one of the tabs shows a list of which extensions should be run by which application. Add .htm and .html and let it be handled by asp.dll (just like .asp and .asa that are already there.







0
 

Author Comment

by:mnprsd
ID: 1858302
Hmm... I must say that I was really positive when I saw your answer, but it didn't work. I tried both the registry settings, and the changes for the .html/.htm application. It is the ISAPI applications, right?

If you know any thing that might cause this problem, please reply.
0
 
LVL 28

Expert Comment

by:sybe
ID: 1858303
you'll have to restart after changing the setting, did you ?
0
Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

 
LVL 28

Expert Comment

by:sybe
ID: 1858304
I'll look at it after the weekend when i am at work, I have solved this problem several times.
0
 

Author Comment

by:mnprsd
ID: 1858305
Yeah. First I only restarted the services, but since that didn't work I restarted the whole computer. Still nothing. You didn't explicitly say that the DisableMemoryCache should be a DWORD, but I assumed it.


0
 
LVL 28

Expert Comment

by:sybe
ID: 1858306
I checked at my pc at work, and I got DisableMemoryCache set to 1 (not to 0 as i first said). That works fine with me.

About IIS4 setting:
- chose properties of a website
- select Home Directory
- click on "configuration"

There you see a list of extensions which will be handled by external exe or dll files.
Add .htm and .html and let them run over asp.dll (just like .asp and .asa)

Hope this works.

0
 

Author Comment

by:mnprsd
ID: 1858307
It worked, really. I was enough to set the registry settings. Thanks!!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Envision that you are chipping away at another e-business site with a team of pundit developers and designers. Everything seems, by all accounts, to be going easily.
Today, the web development industry is booming, and many people consider it to be their vocation. The question you may be asking yourself is – how do I become a web developer?
The viewer will learn how to dynamically set the form action using jQuery.
The is a quite short video tutorial. In this video, I'm going to show you how to create self-host WordPress blog with free hosting service.

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question