email problems

Hi, I'm a newbie running Linux on my home box and I have some problems with email through my ISP.

***What I'm using***
Slackware 3.4 distribution of Linux 2.0.30
Sendmail 8.8.7
Fetchmail 4.4.7

***The Problems***
1. I can't send email to people with accounts on the same ISP, including myself, no matter whether I use addresses like
email.address@isp.domain
or
username@isp.domain.
2. People on other domains get my messages, but if they try to use "reply" I don't get their replies. If they send email explicitly to my address it gets through O.K.
I'd really be grateful for any help with this.
periclisAsked:
Who is Participating?
 
vikiConnect With a Mentor Commented:
Here, you will find the way to send email :

****    sendmail.mc file follows    ******

divert(-1)
dnl #####################################################################
dnl # #
dnl # #
dnl # For use with Slackware Linux 3.4, BSD sendmail 8.8.7 #
dnl # #
dnl # Use "m4 filename.mc > /etc/sendmail.cf" to generate #
dnl # the sendmail configuration file. #
dnl # #
dnl # Uses generic mapping to map usernames on local host.domain #
dnl # to email addresses on ISP. #
dnl # #
dnl # Note that no reference to actual local host.domain name is made; #
dnl # generic mapping is applied to the local domain by default.  #
dnl # #
dnl #################################################################
divert(0)
include(`/usr/src/sendmail/cf/m4/cf.m4')dnl
OSTYPE(linux)dnl
DOMAIN(generic)dnl
divert(-1)
dnl # Apply generic mappings to addresses of senders on specified domain.
dnl # Default domain is local.
divert(0)
GENERICS_DOMAIN dnl
FEATURE(always_add_domain)dnl
divert(-1)
dnl # Use generic mapping table with specified map definition.
dnl # Default definition is: hash -o /etc/genericstable
dnl # Entries in /etc/genericstable only need to be as simple as:
dnl # username: email.address@isp.domain
dnl # Bring generic mappings into effect with:
dnl # sendmail -bi -oA/etc/genericstable
divert(0)
FEATURE(genericstable)dnl
FEATURE(masquerade_envelope)dnl
define(`confSMTP_MAILER',`smtp8')dnl
define(`confDEF_CHAR_SET',`ISO-859-1')dnl
divert(-1)
dnl # Specify the outgoing mailserver
define(`SMART_HOST',`smtp:your_smtp_server.com')dnl
FEATURE(local_procmail,``/usr/bin/procmail'')dnl
MAILER(local)dnl
MAILER(smtp)dnl
dnl

Bye
See you
Vikie




0
 
bryanjonesCommented:
In your /etc/sendmail.cf file their is a line as follows:
# who I masquerade as (null for no masquerading) (see also $=M)
DM(yourISPDomainName ie> idiots.com).
0
 
richrussellCommented:
Check that your host name is set up correctly in your /etc/hosts file and your /etc/sendmail.cf file - refer to the HOWTO and man pages as to how you should set it up for your setup.

If they don't agree, you don't get mail. But if you explicitly give IP addresses, you will as there is no name resolution to do.

Also ckeck the DNS name server setup, this could be a cause of not resolving properly
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jhanceCommented:
Do you really want to run sendmail in an environment like this?  Since your linux box is the only computer on your network, why not just use Pine, Elm, or some other POP-3 client program and access your mailbox on the ISP with it?
0
 
jhanceCommented:
Do you really want to run sendmail in an environment like this?  Since your linux box is the only computer on your network, why not just use Pine, Elm, or some other POP-3 client program and access your mailbox on the ISP with it?
0
 
periclisAuthor Commented:
I'm using BSD sendmail because it came with my distribution... Previous attempts to use smail or pine instead failed, a whole new line of inquiry would have to be started. I've read as much documentation about sendmail as I can get my hands on. My local hostname and domain are set up properly, the Slackware setup utility prompts for the names and does it all automatically.

Masquerading doesn't work because it only masquerades the domain, not the username, and I need to masquerade the whole address, since the ISP's mail system only knows me as username@my.isp, and not as periclis@mymachine.mydomain. If I masquerade, the address becomes periclis@my.isp and I get "unknown user" responses. I could of course make an account on my machine with the same username as I have on my isp and masquerade the domain, but this seems a "kludgy" solution.

Could this be done by setting up some kind of alias for senders on my machine (for outgoing mail)? All the info on aliases I've found seems to refer to aliaases for recipients (incoming mail).
Any ideas?
0
 
jeffa072897Commented:
With your local sendmail do you have DNS running?
When you send mail off of the system sendmail will query DNS for MX systems.
If not try setng it up, making sure you have an MX record that points to your ISP's mail server. I had to do this to get a local attached Linux box to get mail into the local network.
You may be able to do this in sendmail.cf, but, I can't help you therte.
0
 
periclisAuthor Commented:
Thank you very much Vikie for the detailed response!

GENERICS_DOMAIN and FEATURE(genericstable) are the solution to my problem. My email now works just fine!

Once again, thanks a lot!

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.