Printing FROM Linux YO Windows NT

Background:
LAN network consists of 1 Linux server, 1 Linux client machine, and 1 Windows NT 4.0 Server that is only used as  a workstation.

I recently attached a HP OfficeJet to the Win NT Machine. It woks fine for local print requests coming from the NT box, but I cannot figure out how to setup a printer entry on my Linux box so that I can send print requests from linux to the printer on the NT box. Any help would be appreciated!

-Andy
LVL 1
icculusAsked:
Who is Participating?
 
ahoffmannCommented:
Install samba on your linux, if not packed with RedGat you may get it at  http://www.samba.org

smbclient then will do what you want (you must have setup the printer on NT and shared it)

Good luck.
0
 
adtCommented:
What distiribution and version of Linux are you using?
0
 
icculusAuthor Commented:
I'm running Red Hat 5.0
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
jhanceCommented:
NT has an lpd compatible queue service that linux will talk to by default.  It's not loaded or enabled by default, so you need to install and configure it.
0
 
icculusAuthor Commented:
I tried this but could not get i to work. After reading the documentation it looks like this is for defining a printer connected to a unix machine so that you can print from the NT machine with the unix system's lpd. I have the printer connected to the NT machine and want to print from the remote linux box... If your answer is correct I'll need more help to be able to utilitze it...

Thanks,
Andy
0
 
jhanceCommented:
From http://www.samba.bst.tj/samba/docs/faq/sambafaq-3.html#ss3.8

The SAMBA documentation pages say to do ONE of these two things.  You appear to have done BOTH of them:

-----------

3.8 I've applied NT 4.0 SP3, and now I can't access Samba shares, Why?
As of SP3, Microsoft has decided that they will no longer default to passing clear text passwords over the network. To enable access to Samba shares from NT 4.0 SP3, you must do ONE of two things:

Set the Samba configuration option 'security = user' and implement all of the stuff detailed in ENCRYPTION.txt.
Follow Microsoft's directions for setting your NT box to allow plain text passwords. see Knowledge Base Article Q166730
0
 
jhanceCommented:
Please reject my answer above.  I posted it to the wrong question by mistake.  Sorry...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.