We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

starting stuff

trying
trying asked
on
Medium Priority
228 Views
Last Modified: 2010-04-20
i am VERY new to the RedHat Linux os. i've installed everything ok, can even boot to one of 3 os's (win95, dos, linux), BUT, i don't know how do anything! how do i run a program? how do i start xwindows? what is $ mean (i see it in documentation, but not on my screen)? how do i play all the nifty games, such as atc?

please help.
Comment
Watch Question

A good starting point is to go to your local bookshop and buy a book such as 'Linux Unleashed' or even borrow it from a library. Once you get the hang of unix, you'll love it.

Reading a few books on getting started with Linux will save you making lots of mistakes and screwing the system up - it's better to know something rather than trying to muddle through.

You'll find loads of books on Linux, have a read through and get one that you find easy to understand - avoid anything too technical if you don't already know unix admin.
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Author

Commented:
periclis, you have provided more information than the manual or the "HOWTO's" that i have encountered on the internet!
logging in at # makes sense now!

if i understanding this correctly, (from online help and such), files that have an * after it are executables? i've listed information in directories with ls -l or -F etc., and have seen files (programs?) with the *, such as in the games directory, but i am unable to execute them. why? i'm in the correct path (usr/games). i used games because they are usually the easiest programs to run without doing any harm.

as for X11R6, i have all the information to properly config it. i just didn't know how to begin X11R6 to begin with. what is the command to start it? i heard it's startx. which i've tried and received the message, "can't open display". i probably should start xf86confg* to do this. ?

any additional info would be greatly appreciated.

Commented:
Hi, thanks for the appreciation. Cruising the directories in a UNIX system looking for executables is not the way to go about it:

1. In UNIX there are some executables that are simply files with  commands in them that call other programs, a bit like .BAT files in MS-DOS. These are called shell scripts. Some programs don't work properly if they're started directly from the command line, an associated shell script must be called instead. For example, many UNIX programs are set up as a collection of separate programs that do different bits of the job. When you call the shell script they're started in the proper order, pass info to each other etc. and the application works If you find the executables themselves and try to call each from the command line, it probably won't work.

2. You seem to be confusing the path with the working directory. What you see before the # or $ or whatever your shell is is your working directory. You seem to know how to use ls to look at files in your working directory. You can also start executables in your working directory. The path, however, is a presettable list of directories, set up so you can call executables in them no matter which directory you're in. For example, if the directory /usr/local is on your path, then you can call any executables in /usr/local no matter where your working directory is. To see which directories are on your path, issue the command
# echo $PATH
To show the working directory, issue the command
# pwd
When you're using some command shells such as bash, which I suspect you are, the working directory also appears to the left of the prompt.

3. Your games don't work because they need X.

4. You don't need to start X to configure it, in fact starting X without properly configuring it first could damage your monitor. YOU HAVE BEEN WARNED. To configure X, just start the configuration program xf86config form your prompt. This will generate the configuration file XF86Config. Once this is properly done you should be able to start X by isuing the command startx. See part 3. of my previous answer.

If you don't succeed in configuring X using xf86config, post a new question about configuring X with all the information I mentioned was going to be needed (about the monitor, the graphics card, the mouse etc.) in part 3. of my previous answer and we'll take it from there.

Good luck!
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.