Solved

Java Not Starting

Posted on 1998-06-17
18
194 Views
Last Modified: 2010-03-30
I'm running Netscape 4.05 on Windows NT and every time I goto a page that has a Java Applet the Cue line says "Starting Java ..." and the entire Netscape session becomes locked up.  PlaidMan (in the note on Jan 4th entitled "Starting Java")   suggested that the browser is just loading "it's internal JRE" and that "Eventually, the page loads and you don't have to worry about it until you open Netscape next time."  

This does not seem to be the case for me, I'm running a Pentium 300 MHz machine with 256 meg of memory and  after a half an hour Netscape was still locked up.  So my question is, what do I need to do to get Netscape 4 to load an applet?  Thanks.

vanfleet
0
Comment
Question by:vanfleet
  • 7
  • 7
  • 2
  • +2
18 Comments
 
LVL 28

Expert Comment

by:sybe
ID: 1223333
see http://www.winfiles.com/bugs/nsjava.html

basically the solotion is to add
-start_java
in the shortcut to NN4


0
 

Author Comment

by:vanfleet
ID: 1223334
I thought this solution would fix my problem but it has not, when I put -start_java in the shortcut and tried to start it, all I got was the splash window with the message "Starting Java..." then once again NN4 is locked up.

I also loaded Communicator 4.04 on a different machine and had exactly the same result.  I noticed that the fix to this problems on www.winfiles.com is for Communicator 4.02 and 4.03 running windows 95, I'm running 4.04 and 4.05 on Windows NT.  Does someone know what's going on here?
0
 
LVL 4

Expert Comment

by:evijay
ID: 1223335
Please open the java console in the tools menu. See what message it displays.
You can download the developer version of netscape 4.05 (which is different from release) from developer.netscape.com. This doesnt give any problems.

vijay

0
 

Author Comment

by:vanfleet
ID: 1223336
When I open the Java Console I get the same result as before, I get a message at the bottom of my window saying Starting Java ... then it's gone out to lunch again.  I really
don't understand this, am I the only one having this problem?

I haven't tried the developer version yet, I'll try it out and see what happens, this may get me up and running but it won't help my customers much.

I'd be happy to add another 100 porints (or more) if someone can offer me an easy fix that I can offer to my customers also.  Thanks.
0
 
LVL 2

Expert Comment

by:threshold
ID: 1223337
There r many problems that causes the applets can not run in browsers.

Most of problems can be detected by java console.
You can use [Communicator][Java Console] to open the cosole to debug your applet.
Press [h] , you will see the debug options.
Please turn on the options, and press shift key and click [Reload] in same time, you will find the problems.

Press [0-9], you can see the trace your applet in detail.

Press [l], you will see the classes downloaded by browser. Maybe, you can find the classes that can not be downloaded properly.
(It's the most problems of Applet)
0
 

Author Comment

by:vanfleet
ID: 1223338
threshold

Please read my previous note, my problem is not with one single applet, my problem is that everytime Java tries to start, netscape becomes locked up.  As I said in my previous note, when I try to start the Java Console Netscape also becomes lock up, and I can get no information from it.
0
 
LVL 2

Expert Comment

by:threshold
ID: 1223339
As I said, You can open the java console first and set up the opetions, then open the document that contains you applet, then click console quickly.
You will c message from the console.
Maybe, your first applet has take too much CPU time. If it happens, the other applications will be slow too.
Or there is many classes needed, NS is busy to load them.

There are many reasons cause Browser be locked up, You can list the source here, it's helpful to find the problem.
0
 
LVL 2

Expert Comment

by:threshold
ID: 1223340
sorry, wrong typing, It's 'options', not 'opetions'
0
 

Author Comment

by:vanfleet
ID: 1223341
threshold, I appreciate your help but your still not understanding my problem.  I can NOT under ANY circumstances bring up the Java Console, even if I have a blank page loaded the Java Console will NOT come up at all.  All I get is a locked up session with the CPU running at 100%.

Every time Netscape tries to start Java it becomes locked up, this includes the following:

 - When I try bring up the Java Console
 - When I put -start_java in the shortcut
 - When I try to load a page that has a Java applet

ALL of these circumstances result in a locked up session, and each time the session becomes locked up, the message at the bottom of the Netscape window says "Starting Java ...".
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 2

Expert Comment

by:threshold
ID: 1223342
sorry, wrong typing, It's 'options', not 'opetions'
0
 
LVL 2

Expert Comment

by:threshold
ID: 1223343
Did you try the examples of http://java.sun.com?
If the applets from Sun run well in your browser, I think there is something wrong in the Thread of your applet.
Maybe, One of the threads of the applet contains a endless loop, it will cause leak of CPU time.
If there is a loop to perform 'Delay' function, you can use the 'sleep(n)' to replace it.

You can print something by System.out.println(...), and find out the endless loops.
0
 

Author Comment

by:vanfleet
ID: 1223344
I'M NOT TRYING TO RUN MY OWN APPLET YET, I'M ONLY TRYING TO GET JAVA TO START!
0
 
LVL 2

Expert Comment

by:threshold
ID: 1223345
Oh, I c...
You can bring up the Java Console.
I think some files needed by NS 4.05 are corrupted, or under wrong permissions.
Uninstall NS 4.05 and restart your Computer and reinstall it in other directory.
good luck.
0
 
LVL 2

Expert Comment

by:threshold
ID: 1223346
can't, not can. sorry
0
 
LVL 1

Accepted Solution

by:
VincentT earned 200 total points
ID: 1223347
I used to have problems with netscape's java.  (i'm on unix)
Most of the time, unsetting the classpath before launching netscape does it. (I did a little wrapper shell script for that).

It it does not help, get the 4.05+jdk1.1 netscape from
ftp://ftp.netscape.com/pub/communicator/4.05/development/english/windows/windows95_or_nt/4.05_plus_JDK1.1_pr1/
0
 

Author Comment

by:vanfleet
ID: 1223348
VincentT,

The Netscape 4.05+jdk1.1 version worked fine.  It wasn't quite the solution I was looking for, even though it may be the only one.  Before I grade your answer I wanted to clarify somthing, I tried unseting the classpath but the results were the same, I was wondering if I need to remove the envorinment variable alltogether or can I just set it equal to nothing?  Can you give me anymore information about this?  Thanks.
0
 
LVL 1

Expert Comment

by:VincentT
ID: 1223349
When I say "unsetting the classpath", I imply "make sure you don't have a classes.zip somewhere in your classpath"!

conflicts happens when the VM find two sets of core classes.
(at least, on unix (linux))
0
 

Author Comment

by:vanfleet
ID: 1223350
Thanks, for your help!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
groupSum5 challenge 5 73
Requested array size exceeds VM limit 3 85
Java / Linux and Regular Expressions 11 71
couple of eclipse 5 27
Java had always been an easily readable and understandable language.  Some relatively recent changes in the language seem to be changing this pretty fast, and anyone that had not seen any Java code for the last 5 years will possibly have issues unde…
In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
Viewers learn about the “while” loop and how to utilize it correctly in Java. Additionally, viewers begin exploring how to include conditional statements within a while loop and avoid an endless loop. Define While Loop: Basic Example: Explanatio…
Viewers will learn about if statements in Java and their use The if statement: The condition required to create an if statement: Variations of if statements: An example using if statements:

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

27 Experts available now in Live!

Get 1:1 Help Now